summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-27 05:59:01 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-27 05:59:01 +0000
commit6c645d0be94acd7a114805cdfe5a7a371207f983 (patch)
treedcd506751a55cb4ebd45293c4516e906dac864f6 /sci-biology/raxml
parentremove old (diff)
downloadgentoo-2-6c645d0be94acd7a114805cdfe5a7a371207f983.tar.gz
gentoo-2-6c645d0be94acd7a114805cdfe5a7a371207f983.tar.bz2
gentoo-2-6c645d0be94acd7a114805cdfe5a7a371207f983.zip
Version BUmp, 312897
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/raxml')
-rw-r--r--sci-biology/raxml/ChangeLog8
-rw-r--r--sci-biology/raxml/files/raxml-7.2.6-makefile.patch29
-rw-r--r--sci-biology/raxml/metadata.xml4
-rw-r--r--sci-biology/raxml/raxml-7.2.6.ebuild41
4 files changed, 80 insertions, 2 deletions
diff --git a/sci-biology/raxml/ChangeLog b/sci-biology/raxml/ChangeLog
index 12abc66afb9a..18a21292326a 100644
--- a/sci-biology/raxml/ChangeLog
+++ b/sci-biology/raxml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/raxml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/ChangeLog,v 1.6 2011/06/21 06:38:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/ChangeLog,v 1.7 2011/06/27 05:59:01 jlec Exp $
+
+*raxml-7.2.6 (27 Jun 2011)
+
+ 27 Jun 2011; Justin Lecher <jlec@gentoo.org> +raxml-7.2.6.ebuild,
+ +files/raxml-7.2.6-makefile.patch, metadata.xml:
+ Version BUmp, 312897
*raxml-7.2.5-r1 (21 Jun 2011)
diff --git a/sci-biology/raxml/files/raxml-7.2.6-makefile.patch b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
new file mode 100644
index 000000000000..ae83e2eef4e7
--- /dev/null
+++ b/sci-biology/raxml/files/raxml-7.2.6-makefile.patch
@@ -0,0 +1,29 @@
+ Makefile.gcc | 6 +++---
+ 1 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.gcc b/Makefile.gcc
+index 716b6c6..f0c1de2 100644
+--- a/Makefile.gcc
++++ b/Makefile.gcc
+@@ -1,10 +1,10 @@
+ # Makefile August 2006 by Alexandros Stamatakis
+ # Makefile cleanup October 2006, Courtesy of Peter Cordes <peter@cordes.ca>
+
+-CC = gcc
++CC ?= gcc
+
+
+-CFLAGS = -D_GNU_SOURCE -fomit-frame-pointer -funroll-loops -O2 -msse
++CFLAGS += -D_GNU_SOURCE
+
+
+
+@@ -19,7 +19,7 @@ all : raxmlHPC
+ GLOBAL_DEPS = axml.h globalVariables.h
+
+ raxmlHPC : $(objs)
+- $(CC) -o raxmlHPC $(objs) $(LIBRARIES)
++ $(CC) $(LDFLAGS) -o raxmlHPC $(objs) $(LIBRARIES)
+
+ classify.o : classify.c $(GLOBAL_DEPS)
+ evaluatePartialSpecialGeneric.o : evaluatePartialSpecialGeneric.c $(GLOBAL_DEPS)
diff --git a/sci-biology/raxml/metadata.xml b/sci-biology/raxml/metadata.xml
index 3f2ec4ab4025..9fbd5c20ef5f 100644
--- a/sci-biology/raxml/metadata.xml
+++ b/sci-biology/raxml/metadata.xml
@@ -6,5 +6,7 @@
<name>Andrey Kislyuk</name>
</maintainer>
<herd>sci-biology</herd>
- <use><flag name='sse3'>Enable optimization for SSE3 capable chips</flag></use>
+ <use>
+ <flag name="sse3">Enable optimization for SSE3 capable chips</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-biology/raxml/raxml-7.2.6.ebuild b/sci-biology/raxml/raxml-7.2.6.ebuild
new file mode 100644
index 000000000000..5d573e87651d
--- /dev/null
+++ b/sci-biology/raxml/raxml-7.2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/raxml/raxml-7.2.6.ebuild,v 1.1 2011/06/27 05:59:01 jlec Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A Program for Sequential, Parallel & Distributed Inference of Large Phylogenetic Trees"
+HOMEPAGE="http://wwwkramer.in.tum.de/exelixis/software.html"
+SRC_URI="http://wwwkramer.in.tum.de/exelixis/software/RAxML-${PV}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse3 +threads"
+
+# mpi is not supported in version 7.2.2. mpi is enabled by adding -DPARALLEL to CFLAGS
+DEPEND="" # mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/RAxML-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+
+ use sse3 && append-cflags -D__SIM_SSE3
+ use threads && \
+ append-cflags -D_USE_PTHREADS && \
+ append-ldflags -pthread
+
+ tc-export CC
+}
+
+src_compile() {
+ emake -f Makefile.gcc
+}
+
+src_install() {
+ dobin raxmlHPC
+}