summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-06-03 20:41:16 +0000
committerJeroen Roovers <jer@gentoo.org>2010-06-03 20:41:16 +0000
commit3961b7253ed562836e3c0c79b330ed721ce7c926 (patch)
treea4b32a69b86367b1ecdbd684272c8942c68e42a1 /net-proxy
parentversion bump (diff)
downloadgentoo-2-3961b7253ed562836e3c0c79b330ed721ce7c926.tar.gz
gentoo-2-3961b7253ed562836e3c0c79b330ed721ce7c926.tar.bz2
gentoo-2-3961b7253ed562836e3c0c79b330ed721ce7c926.zip
Introduce USE=minimal to not install documentation or man pages and to not depend on app-text/asciidoc thanks to jakie jia (bug #321753). Do not move HTML templates to docdir as they are not docs.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-proxy')
-rw-r--r--net-proxy/tinyproxy/ChangeLog8
-rw-r--r--net-proxy/tinyproxy/files/tinyproxy-1.8.1-minimal.patch10
-rw-r--r--net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild19
3 files changed, 30 insertions, 7 deletions
diff --git a/net-proxy/tinyproxy/ChangeLog b/net-proxy/tinyproxy/ChangeLog
index 45f32753bc17..7f000ce178c5 100644
--- a/net-proxy/tinyproxy/ChangeLog
+++ b/net-proxy/tinyproxy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-proxy/tinyproxy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/ChangeLog,v 1.14 2010/05/26 18:03:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/ChangeLog,v 1.15 2010/06/03 20:41:16 jer Exp $
+
+ 03 Jun 2010; Jeroen Roovers <jer@gentoo.org> tinyproxy-1.8.1.ebuild,
+ +files/tinyproxy-1.8.1-minimal.patch:
+ Introduce USE=minimal to not install documentation or man pages and to not
+ depend on app-text/asciidoc thanks to jakie jia (bug #321753). Do not move
+ HTML templates to docdir as they are not docs.
*tinyproxy-1.8.1 (26 May 2010)
diff --git a/net-proxy/tinyproxy/files/tinyproxy-1.8.1-minimal.patch b/net-proxy/tinyproxy/files/tinyproxy-1.8.1-minimal.patch
new file mode 100644
index 000000000000..82793a8894d0
--- /dev/null
+++ b/net-proxy/tinyproxy/files/tinyproxy-1.8.1-minimal.patch
@@ -0,0 +1,10 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -2,7 +2,6 @@
+ src \
+ data \
+ etc \
+- docs \
+ m4macros \
+ tests
+
diff --git a/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild b/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild
index 94ce198a9e35..2bcad1c93ddc 100644
--- a/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild
+++ b/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild,v 1.1 2010/05/26 18:03:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/tinyproxy/tinyproxy-1.8.1.ebuild,v 1.2 2010/06/03 20:41:16 jer Exp $
EAPI="2"
@@ -13,17 +13,23 @@ SRC_URI="http://www.banu.com/pub/${PN}/1.8/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="debug +filter-proxy reverse-proxy transparent-proxy
+IUSE="debug +filter-proxy minimal reverse-proxy transparent-proxy
+upstream-proxy +xtinyproxy-header"
-DEPEND="app-text/asciidoc"
+DEPEND="doc? ( app-text/asciidoc )"
RDEPEND=""
src_prepare() {
epatch "${FILESDIR}"/${P}-ldflags.patch
+ use minimal && epatch "${FILESDIR}/${P}-minimal.patch"
eautoreconf
}
+
src_configure() {
+ if use minimal; then
+ ln -s /bin/true ${T}/a2x
+ export PATH="${T}:${PATH}"
+ fi
econf \
$(use_enable filter-proxy filter) \
$(use_enable reverse-proxy reverse) \
@@ -38,10 +44,11 @@ src_install() {
sed -i \
-e 's:mkdir $(datadir)/tinyproxy:mkdir -p $(DESTDIR)$(datadir)/tinyproxy:' \
Makefile
- make DESTDIR="${D}" install || die "install failed"
+ emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
- mv "${D}/usr/share/tinyproxy" "${D}/usr/share/doc/${PF}/html"
+ if ! use minimal; then
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+ fi
newinitd "${FILESDIR}/tinyproxy.initd" tinyproxy
}