summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIoannis Aslanidis <deathwing00@gentoo.org>2007-06-19 17:52:56 +0000
committerIoannis Aslanidis <deathwing00@gentoo.org>2007-06-19 17:52:56 +0000
commit623870a5f42ad1be3f8c1ecab25d148d6fbdbab4 (patch)
tree917d2161df9c7334ea6a2e215a465f80855892e3 /net-p2p
parentAdd ~alpha wrt #162010 (diff)
downloadgentoo-2-623870a5f42ad1be3f8c1ecab25d148d6fbdbab4.tar.gz
gentoo-2-623870a5f42ad1be3f8c1ecab25d148d6fbdbab4.tar.bz2
gentoo-2-623870a5f42ad1be3f8c1ecab25d148d6fbdbab4.zip
Version bump. See bug #180693 for details.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/ktorrent/ChangeLog8
-rw-r--r--net-p2p/ktorrent/files/digest-ktorrent-2.2_rc13
-rw-r--r--net-p2p/ktorrent/ktorrent-2.2_rc1.ebuild46
3 files changed, 56 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 538e3598d406..0779c5fe31a0 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.48 2007/04/25 12:27:22 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.49 2007/06/19 17:52:56 deathwing00 Exp $
+
+*ktorrent-2.2_rc1 (19 Jun 2007)
+
+ 19 Jun 2007; Ioannis Aslanidis <deathwing00@gentoo.org>
+ +ktorrent-2.2_rc1.ebuild:
+ Version bump. See bug #180693 for details.
*ktorrent-2.1.4 (25 Apr 2007)
diff --git a/net-p2p/ktorrent/files/digest-ktorrent-2.2_rc1 b/net-p2p/ktorrent/files/digest-ktorrent-2.2_rc1
new file mode 100644
index 000000000000..5536ad94c9f1
--- /dev/null
+++ b/net-p2p/ktorrent/files/digest-ktorrent-2.2_rc1
@@ -0,0 +1,3 @@
+MD5 6ae1640be8d849476c44961961f3557b ktorrent-2.2rc1.tar.gz 3642882
+RMD160 348e524451823b42fec74f92e701d037afabc2e8 ktorrent-2.2rc1.tar.gz 3642882
+SHA256 e5e471ab0f771931dbc5c6cd4fb4b0632e459b543b93b017fdb33b91fdf634a8 ktorrent-2.2rc1.tar.gz 3642882
diff --git a/net-p2p/ktorrent/ktorrent-2.2_rc1.ebuild b/net-p2p/ktorrent/ktorrent-2.2_rc1.ebuild
new file mode 100644
index 000000000000..ac87114bd792
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-2.2_rc1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-2.2_rc1.ebuild,v 1.1 2007/06/19 17:52:56 deathwing00 Exp $
+
+inherit kde
+
+MY_P="${P/_/}"
+MY_PV="${PV/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdeenablefinal"
+
+DEPEND="dev-libs/gmp"
+
+need-kde 3.4
+
+LANGS="bg br ca cs cy da de el en_GB es et eu fr ga gl hu it ja km lt
+mk ms nb nl pa pl pt pt_BR ru rw sk sr sr@Latn sv tr uk zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+src_unpack() {
+ kde_src_unpack
+
+ local MAKE_LANGS
+ cd "${WORKDIR}/${MY_P}/translations"
+ for X in ${LANGS} ; do
+ use linguas_${X} && MAKE_LANGS="${MAKE_LANGS} ${X}"
+ done
+ rm -f ${S}/configure
+ sed -i -e "s:SUBDIRS=.*:SUBDIRS=${MAKE_LANGS}:" Makefile.am
+}
+
+src_compile(){
+ local myconf="--enable-knetwork"
+ kde_src_compile
+}