summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-14 20:53:15 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-14 20:53:15 +0000
commit2640fce2ea6049d6a2328adf5f5c0c796b3a9ca7 (patch)
tree3484f2ad307d90b152340be677416850bed2fb4b /net-p2p/xnap
parentInitial Import. (Manifest recommit) (diff)
downloadgentoo-2-2640fce2ea6049d6a2328adf5f5c0c796b3a9ca7.tar.gz
gentoo-2-2640fce2ea6049d6a2328adf5f5c0c796b3a9ca7.tar.bz2
gentoo-2-2640fce2ea6049d6a2328adf5f5c0c796b3a9ca7.zip
Initial Import.
Diffstat (limited to 'net-p2p/xnap')
-rw-r--r--net-p2p/xnap/ChangeLog10
-rw-r--r--net-p2p/xnap/Manifest2
-rw-r--r--net-p2p/xnap/files/digest-xnap-2.5-r11
-rw-r--r--net-p2p/xnap/metadata.xml10
-rw-r--r--net-p2p/xnap/xnap-2.5-r1.ebuild31
5 files changed, 54 insertions, 0 deletions
diff --git a/net-p2p/xnap/ChangeLog b/net-p2p/xnap/ChangeLog
new file mode 100644
index 000000000000..7583b79e7f4a
--- /dev/null
+++ b/net-p2p/xnap/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for net-p2p/xnap
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xnap/ChangeLog,v 1.1 2004/02/14 20:53:15 zx Exp $
+
+*xnap-2.5-r1 (14 Feb 2004)
+
+ 14 Feb 2004; <zx@gentoo.org> xnap-2.5-r1.ebuild:
+ Initial Release.
+ Thanks to Gunnlaugar <gthb@hi.is> for the suggestion. Bug #21143
+
diff --git a/net-p2p/xnap/Manifest b/net-p2p/xnap/Manifest
new file mode 100644
index 000000000000..da29d173f1cb
--- /dev/null
+++ b/net-p2p/xnap/Manifest
@@ -0,0 +1,2 @@
+MD5 6ad2a3d35a7bb4a71bdf9cbb66a88619 xnap-2.5-r1.ebuild 610
+MD5 e42bfee8ad9d2da376f965e1043d29a0 files/digest-xnap-2.5-r1 58
diff --git a/net-p2p/xnap/files/digest-xnap-2.5-r1 b/net-p2p/xnap/files/digest-xnap-2.5-r1
new file mode 100644
index 000000000000..6288b2053911
--- /dev/null
+++ b/net-p2p/xnap/files/digest-xnap-2.5-r1
@@ -0,0 +1 @@
+MD5 2d7b9b2f74a3b3a1630c79a946e0b285 xnap-2.5.jar 1328406
diff --git a/net-p2p/xnap/metadata.xml b/net-p2p/xnap/metadata.xml
new file mode 100644
index 000000000000..7d85eab6b198
--- /dev/null
+++ b/net-p2p/xnap/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+<longdescription>
+ XNap provides a plugin enabled framework for peer-to-peer (P2P) applications and a client which is based on that framework. It is free software and licensed under the GNU Public License .
+
+ XNap is purely written in Java. The client features a modern Swing based user interface and console support that will run nicely on every platform with a recent Java Runtime Environment (1.3 or higher).
+</longdescription>
+</pkgmetadata>
diff --git a/net-p2p/xnap/xnap-2.5-r1.ebuild b/net-p2p/xnap/xnap-2.5-r1.ebuild
new file mode 100644
index 000000000000..2579f5d3c35f
--- /dev/null
+++ b/net-p2p/xnap/xnap-2.5-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xnap/xnap-2.5-r1.ebuild,v 1.1 2004/02/14 20:53:15 zx Exp $
+
+DESCRIPTION="A P2P framework and client"
+HOMEPAGE="http://xnap.sf.net"
+SRC_URI="mirror://sourceforge/xnap/${P}.jar"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+RDEPEND=">=virtual/jre-1.3"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cp ${DISTDIR}/${A} ${WORKDIR}/
+}
+
+src_install() {
+ insinto /opt/${PN}/lib
+ doins ${P}.jar
+
+ echo "#!/bin/sh" > ${PN}
+ echo "cd /opt/${PN}" >> ${PN}
+ echo '${JAVA_HOME}'/bin/java -jar lib/${P}.jar '$*' >> ${PN}
+
+ into /opt
+ dobin ${PN}
+}
+