summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8 (patch)
treeb7fb21135562109c7d3faef78deeeb62db5981c3 /net-p2p/gnapster
parentnew version, compiles with gcc 3.1 (diff)
downloadgentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.gz
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.bz2
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/gnapster')
-rw-r--r--net-p2p/gnapster/ChangeLog19
-rw-r--r--net-p2p/gnapster/files/digest-gnapster-1.5.0-r21
-rw-r--r--net-p2p/gnapster/gnapster-1.5.0-r2.ebuild43
3 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/gnapster/ChangeLog b/net-p2p/gnapster/ChangeLog
new file mode 100644
index 000000000000..8c229836db69
--- /dev/null
+++ b/net-p2p/gnapster/ChangeLog
@@ -0,0 +1,19 @@
+# ChangeLog for net-p2p/gnapster
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnapster/ChangeLog,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+*gnapster-1.5.0-r2 (28 Mar 2002)
+
+ 28 Mar 2002; Seemant Kulleen <seemant@gentoo.org> gnapster-1.5.0-r2.ebuild :
+
+ Fixed nls USE flag bug, and separated out gdk from the gnome USE flag.
+
+*gnapster-1.5.0-r1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-p2p/gnapster/files/digest-gnapster-1.5.0-r2 b/net-p2p/gnapster/files/digest-gnapster-1.5.0-r2
new file mode 100644
index 000000000000..58973a0739e9
--- /dev/null
+++ b/net-p2p/gnapster/files/digest-gnapster-1.5.0-r2
@@ -0,0 +1 @@
+MD5 f73e173c5dd78bb910dd8a5235c842a6 gnapster-1.5.0.tar.gz 513813
diff --git a/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
new file mode 100644
index 000000000000..f58c9826d635
--- /dev/null
+++ b/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnapster/gnapster-1.5.0-r2.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A napster client for GTK/GNOME"
+SRC_URI="http://jasta.gotlinux.org/files/${P}.tar.gz"
+HOMEPAGE="http://jasta.gotlinux.org/gnapster.html"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 )"
+
+src_compile() {
+ local myconf
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ use gtk || myconf="${myconf} --disable-gdk-pixbuf --disable-gtktest"
+
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING README* TODO NEWS
+}