summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-02 20:02:53 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-02 20:02:53 +0000
commitd5fa09bc2d80262b2b8593036f2d4a4ab36e28b2 (patch)
tree790ab3b5df2372fd6039def52147a7627721a259 /net-nds
parentChange version scheme. Looks like a downgrade (diff)
downloadgentoo-2-d5fa09bc2d80262b2b8593036f2d4a4ab36e28b2.tar.gz
gentoo-2-d5fa09bc2d80262b2b8593036f2d4a4ab36e28b2.tar.bz2
gentoo-2-d5fa09bc2d80262b2b8593036f2d4a4ab36e28b2.zip
Migrate to EAPI=2 for fun.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-nds')
-rw-r--r--net-nds/rpcbind/ChangeLog6
-rw-r--r--net-nds/rpcbind/rpcbind-0.2.0.ebuild16
-rw-r--r--net-nds/rpcbind/rpcbind-9999.ebuild16
3 files changed, 19 insertions, 19 deletions
diff --git a/net-nds/rpcbind/ChangeLog b/net-nds/rpcbind/ChangeLog
index 4ca0a6d438b5..a881d601f597 100644
--- a/net-nds/rpcbind/ChangeLog
+++ b/net-nds/rpcbind/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-nds/rpcbind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.12 2011/04/24 17:50:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/ChangeLog,v 1.13 2011/09/02 20:02:53 vapier Exp $
+
+ 02 Sep 2011; Mike Frysinger <vapier@gentoo.org> rpcbind-0.2.0.ebuild,
+ rpcbind-9999.ebuild:
+ Migrate to EAPI=2 for fun.
24 Apr 2011; Raúl Porcel <armin76@gentoo.org> rpcbind-0.2.0.ebuild:
sparc stable wrt #358509
diff --git a/net-nds/rpcbind/rpcbind-0.2.0.ebuild b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
index 7e1827850a44..89796d9418cb 100644
--- a/net-nds/rpcbind/rpcbind-0.2.0.ebuild
+++ b/net-nds/rpcbind/rpcbind-0.2.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.8 2011/04/24 17:50:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-0.2.0.ebuild,v 1.9 2011/09/02 20:02:53 vapier Exp $
+
+EAPI="2"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
@@ -9,7 +11,7 @@ if [[ ${PV} == "9999" ]] ; then
#KEYWORDS=""
else
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
DESCRIPTION="portmap replacement which supports RPC over various protocols"
@@ -22,21 +24,17 @@ IUSE=""
DEPEND="net-libs/libtirpc"
RDEPEND=${DEPEND}
-src_unpack() {
+src_prepare() {
if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
eautoreconf
else
- unpack ${A}
- cd "${S}"
# fix busted timestamps
find . -type f -print0 | xargs -0 touch -r .
fi
}
-src_compile() {
- econf --bindir=/sbin || die
- emake || die
+src_configure() {
+ econf --bindir=/sbin
}
src_install() {
diff --git a/net-nds/rpcbind/rpcbind-9999.ebuild b/net-nds/rpcbind/rpcbind-9999.ebuild
index 8220e099444f..32e566e51b84 100644
--- a/net-nds/rpcbind/rpcbind-9999.ebuild
+++ b/net-nds/rpcbind/rpcbind-9999.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.3 2009/11/22 17:50:34 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-nds/rpcbind/rpcbind-9999.ebuild,v 1.4 2011/09/02 20:02:53 vapier Exp $
+
+EAPI="2"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.infradead.org/~steved/rpcbind.git"
@@ -22,21 +24,17 @@ IUSE=""
DEPEND="net-libs/libtirpc"
RDEPEND=${DEPEND}
-src_unpack() {
+src_prepare() {
if [[ ${PV} == "9999" ]] ; then
- git_src_unpack
eautoreconf
else
- unpack ${A}
- cd "${S}"
# fix busted timestamps
find . -type f -print0 | xargs -0 touch -r .
fi
}
-src_compile() {
- econf --bindir=/sbin || die
- emake || die
+src_configure() {
+ econf --bindir=/sbin
}
src_install() {