summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-05-08 21:02:45 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-05-08 21:02:45 +0000
commit69241faf1c358134a7a37b79453ab52ebac8d251 (patch)
tree3a4e870e54b4b9c427860c656e8862bdd7fa15d4 /net-misc
parentold (diff)
downloadgentoo-2-69241faf1c358134a7a37b79453ab52ebac8d251.tar.gz
gentoo-2-69241faf1c358134a7a37b79453ab52ebac8d251.tar.bz2
gentoo-2-69241faf1c358134a7a37b79453ab52ebac8d251.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dhcpcd/ChangeLog7
-rw-r--r--net-misc/dhcpcd/dhcpcd-4.0.0_beta2.ebuild85
2 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/dhcpcd/ChangeLog b/net-misc/dhcpcd/ChangeLog
index b4781bf73cd7..50805fb0109d 100644
--- a/net-misc/dhcpcd/ChangeLog
+++ b/net-misc/dhcpcd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/dhcpcd
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.187 2008/05/06 14:28:55 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/ChangeLog,v 1.188 2008/05/08 21:02:45 armin76 Exp $
+
+*dhcpcd-4.0.0_beta2 (08 May 2008)
+
+ 08 May 2008; Raúl Porcel <armin76@gentoo.org> +dhcpcd-4.0.0_beta2.ebuild:
+ Version bump
*dhcpcd-4.0.0_beta1 (06 May 2008)
diff --git a/net-misc/dhcpcd/dhcpcd-4.0.0_beta2.ebuild b/net-misc/dhcpcd/dhcpcd-4.0.0_beta2.ebuild
new file mode 100644
index 000000000000..a4aa328e7f8e
--- /dev/null
+++ b/net-misc/dhcpcd/dhcpcd-4.0.0_beta2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/dhcpcd/dhcpcd-4.0.0_beta2.ebuild,v 1.1 2008/05/08 21:02:45 armin76 Exp $
+
+EAPI=1
+
+inherit toolchain-funcs
+
+MY_P="${P/_alpha/-alpha}"
+MY_P="${MY_P/_beta/-beta}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A DHCP client"
+HOMEPAGE="http://roy.marples.name/dhcpcd"
+SRC_URI="http://roy.marples.name/${PN}/${MY_P}.tar.bz2"
+LICENSE="BSD-2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+SLOT="0"
+IUSE="+compat zeroconf"
+
+DEPEND=""
+PROVIDE="virtual/dhcpc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if ! use zeroconf; then
+ elog "Disabling zeroconf support"
+ {
+ echo
+ echo "# dhcpcd ebuild requested no zeroconf"
+ echo "noipv4ll"
+ } >> dhcpcd.conf
+ fi
+
+ if use compat; then
+ elog "dhcpcd-3 command line support enabled"
+ {
+ echo
+ echo "/* User indicated command line compatability */"
+ echo "#define CMDLINE_COMPAT"
+ } >> config.h
+ fi
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" DBDIR=/var/lib/dhcpcd || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodir /etc/dhcpcd/dhcpcd-exit-hook.d
+ insinto /etc/dhcpcd/dhcpcd-exit-hook.d
+ # The sample ntp script only works with with NTP, not openntp
+ doins hook-samples/ntp.sh
+ # The sample ypbind script only works with linux
+ use elibc_glibc && doins hook-samples/ypbind.sh
+}
+
+pkg_postinst() {
+ # Upgrade the duid file to the new format if needed
+ local old_duid="${ROOT}"/var/lib/dhcpcd/dhcpcd.duid
+ local new_duid="${ROOT}"/etc/dhcpcd/dhcpcd.duid
+ if [ -e "${old_duid}" ] && ! grep -q '..:..:..:..:..:..' "${old_duid}"; then
+ sed -i -e 's/\(..\)/\1:/g; s/:$//g' "${old_duid}"
+ fi
+
+ # Move the duid to /etc, a more sensible location
+ if [ -e "${old_duid}" -a ! -e "${new_duid}" ]; then
+ cp -p "${old_duid}" "${new_duid}"
+ fi
+
+ if use zeroconf; then
+ elog "You have installed dhcpcd with zeroconf support."
+ elog "This means that it will always obtain an IP address even if no"
+ elog "DHCP server can be contacted, which will break any existing"
+ elog "failover support you may have configured in your net configuration."
+ elog "This behaviour can be controlled with the -L flag."
+ elog "See the dhcpcd man page for more details."
+ fi
+}