summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-10-29 07:26:25 +0000
committerJustin Lecher <jlec@gentoo.org>2014-10-29 07:26:25 +0000
commit5bf439cea799d5eed5de8b809c634525f78063de (patch)
treef26c91d8730b259a562de0d26c81862159e0e8ad /net-misc/zsync
parentbump; update deps, update test phase and fix broken install in setup.py, (diff)
downloadgentoo-2-5bf439cea799d5eed5de8b809c634525f78063de.tar.gz
gentoo-2-5bf439cea799d5eed5de8b809c634525f78063de.tar.bz2
gentoo-2-5bf439cea799d5eed5de8b809c634525f78063de.zip
net-misc/zsync: Bump to EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'net-misc/zsync')
-rw-r--r--net-misc/zsync/ChangeLog8
-rw-r--r--net-misc/zsync/metadata.xml9
-rw-r--r--net-misc/zsync/zsync-0.6.2-r1.ebuild47
3 files changed, 58 insertions, 6 deletions
diff --git a/net-misc/zsync/ChangeLog b/net-misc/zsync/ChangeLog
index 6e59cbdad560..610c63e372ab 100644
--- a/net-misc/zsync/ChangeLog
+++ b/net-misc/zsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/zsync
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/zsync/ChangeLog,v 1.9 2014/05/31 02:14:13 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zsync/ChangeLog,v 1.10 2014/10/29 07:26:25 jlec Exp $
+
+*zsync-0.6.2-r1 (29 Oct 2014)
+
+ 29 Oct 2014; Justin Lecher <jlec@gentoo.org> +zsync-0.6.2-r1.ebuild,
+ metadata.xml:
+ Bump to EAPI=5
31 May 2014; Patrick Lauer <patrick@gentoo.org> zsync-0.6.2.ebuild:
Remove superfluous cd statement
diff --git a/net-misc/zsync/metadata.xml b/net-misc/zsync/metadata.xml
index 5ec067b6eefb..d675d5ef7117 100644
--- a/net-misc/zsync/metadata.xml
+++ b/net-misc/zsync/metadata.xml
@@ -1,10 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>robbat2@gentoo.org</email>
- </maintainer>
- <longdescription lang="en">
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
From the zsync web page:
"zsync is a file transfer program. It allows you to download a file from a
@@ -22,5 +22,4 @@
anyone can download the file, make a .zsync and provide it to other users (this
is what I am doing for the moment)."
</longdescription>
-
</pkgmetadata>
diff --git a/net-misc/zsync/zsync-0.6.2-r1.ebuild b/net-misc/zsync/zsync-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..2deeca1179f8
--- /dev/null
+++ b/net-misc/zsync/zsync-0.6.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/zsync/zsync-0.6.2-r1.ebuild,v 1.1 2014/10/29 07:26:25 jlec Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+ZLIB_PV=1.2.3
+ZLIB_P="zlib-${ZLIB_PV}"
+
+DESCRIPTION="Partial/differential file download client over HTTP which uses the rsync algorithm"
+HOMEPAGE="http://zsync.moria.org.uk/"
+SRC_URI="
+ http://zsync.moria.org.uk/download/${P}.tar.bz2
+ http://www.gzip.org/zlib/${ZLIB_P}.tar.bz2
+ http://www.zlib.net/${ZLIB_P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ZLIB_S="${WORKDIR}/${ZLIB_P}"
+
+src_prepare() {
+ # Move old zlib-1.2.11 out the way
+ mv "${S}"/zlib zlib-1.2.11-modified || die
+
+ cd "${ZLIB_S}" || die
+ # I am not sure how many other zlib patches we will need to port as well
+ # This covers the security vuln in 1.2.11
+ epatch "${FILESDIR}"/${P}-${ZLIB_P}-support.patch
+ rm -f Makefile || die
+
+ cd "${S}" || die
+ cp -a "${ZLIB_S}" "${ZLIB_P}-modified" || die
+ ln -s "${ZLIB_P}-modified" zlib || die
+
+ eautoreconf
+}
+
+src_install() {
+ dobin zsync zsyncmake
+ dodoc NEWS README
+ doman doc/zsync.1 doc/zsyncmake.1
+}