summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-03-29 13:35:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-03-29 13:35:23 +0000
commitdce801b472cc65b4a1ff607b927e59e4e0aec52d (patch)
tree69ab46f95d70773a7d0224de747df5329fb891e3 /net-misc/cgminer
parenttidy patch (diff)
downloadgentoo-2-dce801b472cc65b4a1ff607b927e59e4e0aec52d.tar.gz
gentoo-2-dce801b472cc65b4a1ff607b927e59e4e0aec52d.tar.bz2
gentoo-2-dce801b472cc65b4a1ff607b927e59e4e0aec52d.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc/cgminer')
-rw-r--r--net-misc/cgminer/ChangeLog8
-rw-r--r--net-misc/cgminer/cgminer-4.2.1.ebuild6
-rw-r--r--net-misc/cgminer/cgminer-4.2.2.ebuild86
3 files changed, 96 insertions, 4 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index 13b5e940db90..03116285474b 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/cgminer
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.67 2014/03/26 08:11:02 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.68 2014/03/29 13:35:23 blueness Exp $
+
+*cgminer-4.2.2 (29 Mar 2014)
+
+ 29 Mar 2014; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.2.2.ebuild,
+ cgminer-4.2.1.ebuild:
+ Version bump
26 Mar 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag descriptions from metadata.xml
diff --git a/net-misc/cgminer/cgminer-4.2.1.ebuild b/net-misc/cgminer/cgminer-4.2.1.ebuild
index a5c17d5d7439..d43658e02092 100644
--- a/net-misc/cgminer/cgminer-4.2.1.ebuild
+++ b/net-misc/cgminer/cgminer-4.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.2.1.ebuild,v 1.1 2014/03/24 19:06:15 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.2.1.ebuild,v 1.2 2014/03/29 13:35:23 blueness Exp $
EAPI=5
@@ -8,8 +8,8 @@ inherit autotools flag-o-matic
DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
-SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
-#SRC_URI="http://ck.kolivas.org/apps/cgminer/3.9/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/4.2/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
diff --git a/net-misc/cgminer/cgminer-4.2.2.ebuild b/net-misc/cgminer/cgminer-4.2.2.ebuild
new file mode 100644
index 000000000000..4e3d7766c2c9
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.2.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.2.2.ebuild,v 1.1 2014/03/29 13:35:23 blueness Exp $
+
+EAPI=5
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.2/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 avalon avalon2 bab bitmine_A1 bflsc bitforce bitfury cointerra drillbit hashfast icarus klondike knc minion modminer"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ dev-libs/jansson
+ ncurses? ( sys-libs/ncurses )
+ avalon? ( virtual/libusb:1 )
+ bflsc? ( virtual/libusb:1 )
+ bitforce? ( virtual/libusb:1 )
+ bitfury? ( virtual/libusb:1 )
+ cointerra? ( virtual/libusb:1 )
+ drillbit? ( virtual/libusb:1 )
+ hashfast? ( virtual/libusb:1 )
+ icarus? ( virtual/libusb:1 )
+ klondike? ( virtual/libusb:1 )
+ modminer? ( virtual/libusb:1 )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer)
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use modminer; then
+ insinto /usr/lib/cgminer/modminer
+ doins bitstreams/*.ncd
+ dodoc bitstreams/COPYING_fpgaminer
+ fi
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}