summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-08 23:55:47 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-08 23:55:47 +0000
commite480f049db2b09056ac3272ee77e5861503b3219 (patch)
treefa08c69c2440f316e2e0dd2c035338fd6e6c6ffd /net-libs
parentonly populate /dev for stage1 systems (diff)
downloadgentoo-2-e480f049db2b09056ac3272ee77e5861503b3219.tar.gz
gentoo-2-e480f049db2b09056ac3272ee77e5861503b3219.tar.bz2
gentoo-2-e480f049db2b09056ac3272ee77e5861503b3219.zip
Version bump.
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libetpan/ChangeLog10
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.493
-rw-r--r--net-libs/libetpan/libetpan-0.48.ebuild4
-rw-r--r--net-libs/libetpan/libetpan-0.49.ebuild59
4 files changed, 72 insertions, 4 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 7770c970a2f7..130d3e8c1ae0 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libetpan
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.39 2006/12/12 14:22:01 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.40 2007/01/08 23:55:47 ticho Exp $
+
+*libetpan-0.49 (08 Jan 2007)
+
+ 08 Jan 2007; Andrej Kacian <ticho@gentoo.org> libetpan-0.48.ebuild,
+ +libetpan-0.49.ebuild:
+ Version bump.
12 Dec 2006; Roy Marples <uberlord@gentoo.org> libetpan-0.48.ebuild:
Added ~x86-fbsd keyword.
diff --git a/net-libs/libetpan/files/digest-libetpan-0.49 b/net-libs/libetpan/files/digest-libetpan-0.49
new file mode 100644
index 000000000000..03ad07755267
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.49
@@ -0,0 +1,3 @@
+MD5 f6c973ea1aa53d947f034e093960da10 libetpan-0.49.tar.gz 1021102
+RMD160 0878873394f2c3d470a2b516413091f0fdd54a0b libetpan-0.49.tar.gz 1021102
+SHA256 4d7257ae2cce276b2a2a66209b35ff70ff06a3ab89a2d8f2d828d7f44f78e6eb libetpan-0.49.tar.gz 1021102
diff --git a/net-libs/libetpan/libetpan-0.48.ebuild b/net-libs/libetpan/libetpan-0.48.ebuild
index 3c3d6be575da..6b823219cf4e 100644
--- a/net-libs/libetpan/libetpan-0.48.ebuild
+++ b/net-libs/libetpan/libetpan-0.48.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.48.ebuild,v 1.2 2006/12/12 14:22:01 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.48.ebuild,v 1.3 2007/01/08 23:55:47 ticho Exp $
DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
HOMEPAGE="http://libetpan.sourceforge.net"
diff --git a/net-libs/libetpan/libetpan-0.49.ebuild b/net-libs/libetpan/libetpan-0.49.ebuild
new file mode 100644
index 000000000000..33646e93797a
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.49.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.49.ebuild,v 1.1 2007/01/08 23:55:47 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="berkdb debug gnutls sasl ssl ipv6"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with sasl` \
+ `use_enable ipv6` \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}
+
+pkg_postinst() {
+ echo
+ ewarn "The soname for libetpan has changed after libetpan-0.48."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+ echo
+}