summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-08-12 22:39:30 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-08-12 22:39:30 +0000
commit82a37b903cddfd1ac0c4335182e6c95bfe829410 (patch)
tree2bae7f0b71169d643d5187dff816e86522e79bca /net-libs/wvstreams/files
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-82a37b903cddfd1ac0c4335182e6c95bfe829410.tar.gz
gentoo-2-82a37b903cddfd1ac0c4335182e6c95bfe829410.tar.bz2
gentoo-2-82a37b903cddfd1ac0c4335182e6c95bfe829410.zip
Closing #59601.
Diffstat (limited to 'net-libs/wvstreams/files')
-rw-r--r--net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch9
-rw-r--r--net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch24
2 files changed, 33 insertions, 0 deletions
diff --git a/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch b/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
index 988f5e3e9399..dce6a8be9470 100644
--- a/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
+++ b/net-libs/wvstreams/files/wvstreams-3.75-fPIC.patch
@@ -29,3 +29,12 @@
+qt/wvqtstreamclone.fpic.o: include/wvqtstreamclone.moc
+qt/wvqthook.fpic.o: include/wvqthook.moc
+--- vars.mk 2004-08-12 22:07:41.902797093 +0000
++++ vars.mk 2004-08-12 22:16:37.327729755 +0000
+@@ -181,3 +181,6 @@
+ libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.4 -luniconf
+
+ uniconf/daemon/uniconfdaemon: libuniconf.so libwvutils.so -ldb
++
++bindings/uniconf_tcl.o: bindings/uniconf_tcl.c
++ $(call wvcc ,$@,$<,$*,-fPIC)
diff --git a/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch b/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch
new file mode 100644
index 000000000000..97bb2328827d
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-3.75-tcl_8_4.patch
@@ -0,0 +1,24 @@
+--- configure.ac 2004-08-12 19:35:56.695660963 +0000
++++ configure.ac 2004-08-12 19:36:26.232540924 +0000
+@@ -202,9 +202,9 @@
+ # tcl
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS_save="$CPPFLAGS"
+- WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.3)
++ WV_APPEND(CPPFLAGS, -I/usr/include/tcl8.4)
+ AC_CHECK_HEADERS(tcl.h,, [with_tcl=no])
+- AC_CHECK_LIB(tcl8.3, TclInterpInit,, [with_tcl=no])
++ AC_CHECK_LIB(tcl8.4, TclInterpInit,, [with_tcl=no])
+ if test "$with_tcl" != "no"; then
+ CPPFLAGS="$CPPFLAGS_save"
+ fi
+--- vars.mk 2004-08-12 21:32:32.627250401 +0000
++++ vars.mk 2004-08-12 21:32:39.932489430 +0000
+@@ -178,6 +178,6 @@
+ libwvgtk.a libwvgtk.so: $(call objects,gtk)
+ libwvgtk.so: -lgtk -lgdk libwvstreams.so libwvutils.so
+
+-libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.3 -luniconf
++libuniconf_tcl.so: bindings/uniconf_tcl.o -ltcl8.4 -luniconf
+
+ uniconf/daemon/uniconfdaemon: libuniconf.so libwvutils.so -ldb