summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-03-04 00:55:42 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-03-04 00:55:42 +0000
commit948f25254ea1d8210fe1e7d4b7ad961e23e3bd78 (patch)
treec15c4b1fcc297c6c032d84134102b17504c35c9d /net-libs/socket++/socket++-1.12.12-r1.ebuild
parentVersion bump, closes bug #81267. (diff)
downloadgentoo-2-948f25254ea1d8210fe1e7d4b7ad961e23e3bd78.tar.gz
gentoo-2-948f25254ea1d8210fe1e7d4b7ad961e23e3bd78.tar.bz2
gentoo-2-948f25254ea1d8210fe1e7d4b7ad961e23e3bd78.zip
Revision bump; added a pkgconfig script to make it easier to use in your apps.
(Portage version: 2.0.51.18)
Diffstat (limited to 'net-libs/socket++/socket++-1.12.12-r1.ebuild')
-rw-r--r--net-libs/socket++/socket++-1.12.12-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/socket++/socket++-1.12.12-r1.ebuild b/net-libs/socket++/socket++-1.12.12-r1.ebuild
new file mode 100644
index 000000000000..357450de2255
--- /dev/null
+++ b/net-libs/socket++/socket++-1.12.12-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/socket++/socket++-1.12.12-r1.ebuild,v 1.1 2005/03/04 00:55:42 ka0ttic Exp $
+
+DESCRIPTION="C++ Socket Library"
+HOMEPAGE="http://www.linuxhacker.at/socketxx/"
+SRC_URI="http://www.linuxhacker.at/linux/downloads/src/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug doc"
+
+DEPEND="sys-devel/automake
+ sys-devel/autoconf
+ sys-devel/libtool
+ sys-apps/texinfo"
+RDEPEND=""
+
+src_compile() {
+ einfo "Running autogen"
+ WANT_AUTOMAKE=1.7 ./autogen || die "autogen failed"
+
+ econf $(use_enable debug) || die "econf failed"
+ emake || die "emake failed"
+
+ if use doc ; then
+ cd ${S}/doc
+ einfo "Building HTML documentation"
+ # the 'html' target in both ${S}/Makefile and ${S}/doc/Makefile
+ # do indeed exist (and succeed when run manually), but fail when
+ # 'make html' is done here, so we call makeinfo ourselves.
+ makeinfo --html -I . -o html socket++.texi || die "makeinfo failed"
+ fi
+}
+
+src_test() {
+ cd ${S}/test
+ make check || die "make check failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README* THANKS || die "dodoc failed"
+
+ insinto /usr/lib/pkgconfig
+ doins ${FILESDIR}/${PN}.pc || die "failed to install pkgconfig script"
+ dosed "s/PV/${PV}/" /usr/lib/pkgconfig/${PN}.pc || die "sed failed"
+
+ if use doc ; then
+ dohtml doc/html/* || die "dohtml failed"
+ fi
+}