summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2011-03-04 00:11:20 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2011-03-04 00:11:20 +0000
commit6f33fc758cf006fe5ae87ab7d8adb45a50f7877f (patch)
treeefb89bcf2e861db6e166fef0600e9294e29da737 /net-libs/libgadu
parentadded upstream fix for the clearbuffersonmsg module that makes it ignore user... (diff)
downloadgentoo-2-6f33fc758cf006fe5ae87ab7d8adb45a50f7877f.tar.gz
gentoo-2-6f33fc758cf006fe5ae87ab7d8adb45a50f7877f.tar.bz2
gentoo-2-6f33fc758cf006fe5ae87ab7d8adb45a50f7877f.zip
Version bump
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libgadu')
-rw-r--r--net-libs/libgadu/ChangeLog10
-rw-r--r--net-libs/libgadu/libgadu-1.10.0.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/net-libs/libgadu/ChangeLog b/net-libs/libgadu/ChangeLog
index e570a4c7d1aa..0b27e1e669fa 100644
--- a/net-libs/libgadu/ChangeLog
+++ b/net-libs/libgadu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libgadu
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.48 2010/11/20 12:03:08 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/ChangeLog,v 1.49 2011/03/04 00:11:20 reavertm Exp $
+
+*libgadu-1.10.0 (04 Mar 2011)
+
+ 04 Mar 2011; Maciej Mrozowski <reavertm@gentoo.org>
+ +libgadu-1.10.0.ebuild:
+ Version bump
20 Nov 2010; Michael Weber <xmw@gentoo.org> libgadu-1.9.0-r1.ebuild,
libgadu-1.9.1.ebuild:
diff --git a/net-libs/libgadu/libgadu-1.10.0.ebuild b/net-libs/libgadu/libgadu-1.10.0.ebuild
new file mode 100644
index 000000000000..08bd77290644
--- /dev/null
+++ b/net-libs/libgadu/libgadu-1.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgadu/libgadu-1.10.0.ebuild,v 1.1 2011/03/04 00:11:20 reavertm Exp $
+
+EAPI="2"
+
+MY_P="${P/_/-}"
+
+inherit autotools-utils
+
+DESCRIPTION="This library implements the client side of the Gadu-Gadu protocol"
+HOMEPAGE="http://toxygen.net/libgadu/"
+SRC_URI="http://toxygen.net/libgadu/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+SLOT="0"
+IUSE="doc ssl static-libs threads"
+
+COMMON_DEPEND="
+ ssl? ( >=dev-libs/openssl-0.9.6m )
+"
+DEPEND="${COMMON_DEPEND}
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="${COMMON_DEPEND}
+ !=net-im/kadu-0.6.0.2
+ !=net-im/kadu-0.6.0.1
+"
+
+S="${WORKDIR}/${MY_P}"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+DOCS=(AUTHORS ChangeLog NEWS README)
+
+src_configure() {
+ myeconfargs=(
+ $(use_with ssl openssl)
+ $(use_with threads pthread)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS=(docs/html/)
+ autotools-utils_src_install
+}