summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-14 05:12:18 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-14 05:12:18 +0000
commiteb9141a9b9ec42c2a47212af568789a7b98f7ee8 (patch)
tree2ae67ba6df4873d24e550a10409c3c2fbbe6511a /net-irc
parentCleanup ebuild and fix building with newer glibc #240916 by Diego E. Pettenò. (diff)
downloadgentoo-2-eb9141a9b9ec42c2a47212af568789a7b98f7ee8.tar.gz
gentoo-2-eb9141a9b9ec42c2a47212af568789a7b98f7ee8.tar.bz2
gentoo-2-eb9141a9b9ec42c2a47212af568789a7b98f7ee8.zip
Fix building with newer glibc #251446 by Diego E. Pettenò.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/inspircd/ChangeLog8
-rw-r--r--net-irc/inspircd/files/inspircd-1.1.19-build.patch14
-rw-r--r--net-irc/inspircd/inspircd-1.1.19.ebuild16
3 files changed, 28 insertions, 10 deletions
diff --git a/net-irc/inspircd/ChangeLog b/net-irc/inspircd/ChangeLog
index 20e55a880128..a41674399123 100644
--- a/net-irc/inspircd/ChangeLog
+++ b/net-irc/inspircd/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-irc/inspircd
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.26 2008/09/18 20:05:44 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/ChangeLog,v 1.27 2009/01/14 05:12:18 vapier Exp $
+
+ 14 Jan 2009; Mike Frysinger <vapier@gentoo.org>
+ +files/inspircd-1.1.19-build.patch, inspircd-1.1.19.ebuild:
+ Fix building with newer glibc #251446 by Diego E. Pettenò.
18 Sep 2008; Markus Meier <maekke@gentoo.org> inspircd-1.1.19.ebuild:
amd64 stable, bug #236658
diff --git a/net-irc/inspircd/files/inspircd-1.1.19-build.patch b/net-irc/inspircd/files/inspircd-1.1.19-build.patch
new file mode 100644
index 000000000000..1b45d357778c
--- /dev/null
+++ b/net-irc/inspircd/files/inspircd-1.1.19-build.patch
@@ -0,0 +1,14 @@
+fix building with newer glibc
+
+http://bugs.gentoo.org/251446
+
+--- src/configreader.cpp
++++ src/configreader.cpp
+@@ -13,6 +13,7 @@
+
+ #include "inspircd.h"
+ #include "configreader.h"
++#include <limits.h>
+ #include <sstream>
+ #include <fstream>
+ #include "xline.h"
diff --git a/net-irc/inspircd/inspircd-1.1.19.ebuild b/net-irc/inspircd/inspircd-1.1.19.ebuild
index 20041f5bbfdf..b904cdbeefd7 100644
--- a/net-irc/inspircd/inspircd-1.1.19.ebuild
+++ b/net-irc/inspircd/inspircd-1.1.19.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.19.ebuild,v 1.5 2008/09/18 20:05:44 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-irc/inspircd/inspircd-1.1.19.ebuild,v 1.6 2009/01/14 05:12:18 vapier Exp $
inherit eutils toolchain-funcs multilib # subversion
DESCRIPTION="InspIRCd - The Modular C++ IRC Daemon"
HOMEPAGE="http://www.inspircd.org/"
SRC_URI="http://www.inspircd.org/downloads/InspIRCd-${PV}.tar.bz2
-mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
+ mirror://sourceforge/${PN}/InspIRCd-${PV}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="openssl gnutls ipv6 kernel_linux mysql postgres sqlite zlib ldap"
-RDEPEND="
- dev-lang/perl
+RDEPEND="dev-lang/perl
openssl? ( dev-libs/openssl )
gnutls? ( net-libs/gnutls )
mysql? ( virtual/mysql )
@@ -24,11 +23,12 @@ RDEPEND="
ldap? ( net-nds/openldap )"
DEPEND="${RDEPEND}"
-S="${WORKDIR}/inspircd"
+S=${WORKDIR}/${PN}
src_unpack() {
unpack ${A}
cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch #251446
local SQL=0
cd src/modules
@@ -63,7 +63,6 @@ src_unpack() {
}
src_compile() {
-
# ./configure doesn't know --disable-gnutls, -ipv6 and -openssl options,
# so should be used only --enable-like.
local myconf=""
@@ -98,7 +97,8 @@ src_install() {
MODPATH="${D}/usr/$(get_libdir)/inspircd/modules/" \
CONPATH="${D}/etc/inspircd" \
BINPATH="${D}/usr/bin" \
- BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher"
+ BASE="${D}/usr/$(get_libdir)/inspircd/inspircd.launcher" \
+ || die
insinto /usr/include/inspircd/
doins "${S}"/include/*