summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-09-03 14:49:58 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-09-03 14:49:58 +0000
commit3877056ebeb20e84de646fb9eb5b4b493a017f44 (patch)
tree1c3337114d470af5227e40394ab026c2c30452a1 /net-im/vacuum
parentVersion bump to version from Developer Tools 4.1 (diff)
downloadgentoo-2-3877056ebeb20e84de646fb9eb5b4b493a017f44.tar.gz
gentoo-2-3877056ebeb20e84de646fb9eb5b4b493a017f44.tar.bz2
gentoo-2-3877056ebeb20e84de646fb9eb5b4b493a017f44.zip
Bump to 1.1.1, add plugin to 9999
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-im/vacuum')
-rw-r--r--net-im/vacuum/ChangeLog8
-rw-r--r--net-im/vacuum/metadata.xml7
-rw-r--r--net-im/vacuum/vacuum-1.1.0.ebuild8
-rw-r--r--net-im/vacuum/vacuum-1.1.1.ebuild69
-rw-r--r--net-im/vacuum/vacuum-9999.ebuild10
5 files changed, 93 insertions, 9 deletions
diff --git a/net-im/vacuum/ChangeLog b/net-im/vacuum/ChangeLog
index ea854c6c624f..4e2d26aa403e 100644
--- a/net-im/vacuum/ChangeLog
+++ b/net-im/vacuum/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/vacuum
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.1 2011/04/29 16:08:39 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/ChangeLog,v 1.2 2011/09/03 14:49:57 maksbotan Exp $
+
+*vacuum-1.1.1 (03 Sep 2011)
+
+ 03 Sep 2011; Maxim Koltsov <maksbotan@gentoo.org> vacuum-1.1.0.ebuild,
+ +vacuum-1.1.1.ebuild, vacuum-9999.ebuild, metadata.xml:
+ Add vacuum-1.1.1, add 'birthdayreminder' plugin to vacuum-9999
*vacuum-9999 (29 Apr 2011)
*vacuum-1.1.0 (29 Apr 2011)
diff --git a/net-im/vacuum/metadata.xml b/net-im/vacuum/metadata.xml
index c3af4fab2d53..1a7f67893fd5 100644
--- a/net-im/vacuum/metadata.xml
+++ b/net-im/vacuum/metadata.xml
@@ -1,7 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>no-herd</herd>
+ <herd>proxy-maint</herd>
+ <maintainer>
+ <email>nikoli@lavabit.com</email>
+ <name>Nikoli</name>
+ </maintainer>
<maintainer>
<email>maksbotan@gentoo.org</email>
<name>Maxim Koltsov</name>
@@ -11,6 +15,7 @@
<flag name="annotations">Enable adding comments to the contacts in the roster</flag>
<flag name="autostatus">Change the status in accordance with the time of inactivity</flag>
<flag name="avatars">Enable assigning and displaying avatars</flag>
+ <flag name="birthdayreminder">Reminds about birthdays of your friends</flag>
<flag name="bitsofbinary">Allow other modules to receive or send a small amount of binary data in XMPP stanza</flag>
<flag name="bookmarks">Enable creating bookmarks of the Jabber conferences and Web pages</flag>
<flag name="captchaforms">Perform tests for humanity outside of Web browser</flag>
diff --git a/net-im/vacuum/vacuum-1.1.0.ebuild b/net-im/vacuum/vacuum-1.1.0.ebuild
index 197c08620a7f..50cc9d9ad488 100644
--- a/net-im/vacuum/vacuum-1.1.0.ebuild
+++ b/net-im/vacuum/vacuum-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.0.ebuild,v 1.1 2011/04/29 16:08:39 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.0.ebuild,v 1.2 2011/09/03 14:49:58 maksbotan Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -32,14 +32,16 @@ REQUIRED_USE="
pepmanager? ( servicediscovery )
registration? ( dataforms )
remotecontrol? ( commands dataforms )
- sessionnegotiation? ( dataforms )"
+ sessionnegotiation? ( dataforms )
+"
RDEPEND="
>=x11-libs/qt-core-4.5:4[ssl]
>=x11-libs/qt-gui-4.5:4
>=dev-libs/openssl-0.9.8k
adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
- x11-libs/libXScrnSaver"
+ x11-libs/libXScrnSaver
+"
DEPEND="${RDEPEND}"
DOCS="AUTHORS CHANGELOG README TRANSLATORS"
diff --git a/net-im/vacuum/vacuum-1.1.1.ebuild b/net-im/vacuum/vacuum-1.1.1.ebuild
new file mode 100644
index 000000000000..2f3a2534576c
--- /dev/null
+++ b/net-im/vacuum/vacuum-1.1.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-1.1.1.ebuild,v 1.1 2011/09/03 14:49:57 maksbotan Exp $
+
+EAPI="4"
+LANGS="de pl ru uk"
+
+inherit cmake-utils
+
+DESCRIPTION="Qt4 Crossplatform Jabber client."
+HOMEPAGE="http://code.google.com/p/vacuum-im"
+SRC_URI="http://vacuum-im.googlecode.com/files/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+PLUGINS=" adiummessagestyle annotations autostatus avatars bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rostersearch servicediscovery sessionnegotiation socksstreams vcard xmppuriqueries"
+IUSE="${PLUGINS// / +}"
+for x in ${LANGS}; do
+ IUSE+=" linguas_${x}"
+done
+
+REQUIRED_USE="
+ annotations? ( privatestorage )
+ avatars? ( vcard )
+ bookmarks? ( privatestorage )
+ captchaforms? ( dataforms )
+ commands? ( dataforms )
+ datastreamsmanager? ( dataforms )
+ filestreamsmanager? ( datastreamsmanager )
+ filetransfer? ( filestreamsmanager datastreamsmanager )
+ pepmanager? ( servicediscovery )
+ registration? ( dataforms )
+ remotecontrol? ( commands dataforms )
+ sessionnegotiation? ( dataforms )
+"
+
+RDEPEND="
+ >=x11-libs/qt-core-4.5:4[ssl]
+ >=x11-libs/qt-gui-4.5:4
+ >=dev-libs/openssl-0.9.8k
+ adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
+ net-dns/libidn
+ x11-libs/libXScrnSaver
+"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS CHANGELOG README TRANSLATORS"
+
+src_configure() {
+ # linguas
+ local langs="none;"
+ for x in ${LANGS}; do
+ use linguas_${x} && langs+="${x};"
+ done
+
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="$(get_libdir)"
+ -DINSTALL_SDK=ON
+ -DLANGS="${langs}"
+ -DINSTALL_DOCS=OFF
+ )
+
+ for x in ${PLUGINS}; do
+ mycmakeargs+=( "$(cmake-utils_use ${x} PLUGIN_${x})" )
+ done
+
+ cmake-utils_src_configure
+}
diff --git a/net-im/vacuum/vacuum-9999.ebuild b/net-im/vacuum/vacuum-9999.ebuild
index 17427e7bd0a2..e1e0ad7da1f6 100644
--- a/net-im/vacuum/vacuum-9999.ebuild
+++ b/net-im/vacuum/vacuum-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.1 2011/04/29 16:08:39 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/vacuum/vacuum-9999.ebuild,v 1.2 2011/09/03 14:49:57 maksbotan Exp $
EAPI="4"
LANGS="de pl ru uk"
@@ -14,7 +14,7 @@ ESVN_REPO_URI="http://vacuum-im.googlecode.com/svn/trunk"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-PLUGINS=" adiummessagestyle annotations autostatus avatars bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rostersearch servicediscovery sessionnegotiation socksstreams vcard xmppuriqueries"
+PLUGINS=" adiummessagestyle annotations autostatus avatars birthdayreminder bitsofbinary bookmarks captchaforms chatstates clientinfo commands compress console dataforms datastreamsmanager emoticons filestreamsmanager filetransfer gateways inbandstreams iqauth jabbersearch messagearchiver multiuserchat pepmanager privacylists privatestorage registration remotecontrol rostersearch servicediscovery sessionnegotiation socksstreams vcard xmppuriqueries"
IUSE="${PLUGINS// / +} vcs-revision"
for x in ${LANGS}; do
IUSE+=" linguas_${x}"
@@ -32,7 +32,8 @@ REQUIRED_USE="
pepmanager? ( servicediscovery )
registration? ( dataforms )
remotecontrol? ( commands dataforms )
- sessionnegotiation? ( dataforms )"
+ sessionnegotiation? ( dataforms )
+"
RDEPEND="
>=x11-libs/qt-core-4.5:4[ssl]
@@ -40,7 +41,8 @@ RDEPEND="
>=dev-libs/openssl-0.9.8k
adiummessagestyle? ( >=x11-libs/qt-webkit-4.5:4 )
net-dns/libidn
- x11-libs/libXScrnSaver"
+ x11-libs/libXScrnSaver
+"
DEPEND="${RDEPEND}"
DOCS="AUTHORS CHANGELOG README TRANSLATORS"