summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2010-11-22 16:29:07 +0000
committerOlivier Crête <tester@gentoo.org>2010-11-22 16:29:07 +0000
commitd3c2a2e802bc26b4eaac46c4532e8caa527da67d (patch)
tree72432bfa030222014a70fb6e446a13dde76b9f7c /net-im/pidgin
parentAdd missing patch (diff)
downloadgentoo-2-d3c2a2e802bc26b4eaac46c4532e8caa527da67d.tar.gz
gentoo-2-d3c2a2e802bc26b4eaac46c4532e8caa527da67d.tar.bz2
gentoo-2-d3c2a2e802bc26b4eaac46c4532e8caa527da67d.zip
Version bump, bug #346407
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'net-im/pidgin')
-rw-r--r--net-im/pidgin/ChangeLog8
-rw-r--r--net-im/pidgin/pidgin-2.7.6.ebuild (renamed from net-im/pidgin/pidgin-2.7.3.ebuild)31
2 files changed, 26 insertions, 13 deletions
diff --git a/net-im/pidgin/ChangeLog b/net-im/pidgin/ChangeLog
index 8e36589bccc4..d29288730bc6 100644
--- a/net-im/pidgin/ChangeLog
+++ b/net-im/pidgin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-im/pidgin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.206 2010/11/21 00:55:56 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/ChangeLog,v 1.207 2010/11/22 16:29:07 tester Exp $
+
+*pidgin-2.7.6 (22 Nov 2010)
+
+ 22 Nov 2010; Olivier Crête <tester@gentoo.org> -pidgin-2.7.3.ebuild,
+ +pidgin-2.7.6.ebuild:
+ Version bump, bug #346407
21 Nov 2010; Michael Weber <xmw@gentoo.org> pidgin-2.7.5.ebuild:
Added ~arm keyword (bug 343505)
diff --git a/net-im/pidgin/pidgin-2.7.3.ebuild b/net-im/pidgin/pidgin-2.7.6.ebuild
index 19b90212f064..e565e3c06a1d 100644
--- a/net-im/pidgin/pidgin-2.7.3.ebuild
+++ b/net-im/pidgin/pidgin-2.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.7.3.ebuild,v 1.6 2010/10/15 16:29:18 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/pidgin/pidgin-2.7.6.ebuild,v 1.1 2010/11/22 16:29:07 tester Exp $
EAPI=2
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="dbus debug doc eds gadu gnutls +gstreamer +gtk idn meanwhile"
IUSE+=" networkmanager nls perl silc tcl tk spell qq sasl +startup-notification"
IUSE+=" ncurses groupwise prediction python +xscreensaver zephyr zeroconf" # mono"
@@ -58,15 +58,18 @@ RDEPEND="
# Mono support crashes pidgin
#mono? ( dev-lang/mono )"
+# We want nls in case gtk is enabled, bug #
+NLS_DEPEND=">=dev-util/intltool-0.41.1 sys-devel/gettext"
+
DEPEND="$RDEPEND
dev-lang/perl
dev-perl/XML-Parser
dev-util/pkgconfig
- gtk? ( x11-proto/scrnsaverproto )
+ gtk? ( x11-proto/scrnsaverproto
+ ${NLS_DEPEND} )
dbus? ( <dev-lang/python-3 )
doc? ( app-doc/doxygen )
- nls? ( >=dev-util/intltool-0.41.1
- sys-devel/gettext )"
+ !gtk? ( nls? ( ${NLS_DEPEND} ) )"
DOCS="AUTHORS HACKING NEWS README ChangeLog"
@@ -100,13 +103,14 @@ DYNAMIC_PRPLS="irc,jabber,oscar,yahoo,simple,msn,myspace"
pkg_setup() {
if ! use gtk && ! use ncurses ; then
- einfo
elog "You did not pick the ncurses or gtk use flags, only libpurple"
elog "will be built."
- einfo
+ fi
+ if use gtk && ! use nls; then
+ ewarn "gtk build => nls is enabled!"
fi
if use dbus && ! use python; then
- elog "It's impossible to disable linkage with python in case dbus is enabled."
+ elog "dbus is enabled, no way to disable linkage with python => python is enabled"
fi
if use dbus || { use ncurses && use python; }; then
python_set_active_version 2
@@ -116,9 +120,8 @@ pkg_setup() {
src_prepare() {
gnome2_src_prepare
- epatch "${FILESDIR}"/${PN}-2.7.2-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-2.7.3-ldflags.patch
eautoreconf
-
}
src_configure() {
@@ -160,9 +163,10 @@ src_configure() {
econf \
--disable-silent-rules \
$(use_enable ncurses consoleui) \
- $(use_enable nls) \
$(use_enable gtk gtkui) \
$(use_enable gtk sm) \
+ $(use gtk || use_enable nls) \
+ $(use gtk && echo "--enable-nls") \
$(use gtk && use_enable startup-notification) \
$(use gtk && use_enable xscreensaver screensaver) \
$(use gtk && use_enable prediction cap) \
@@ -182,7 +186,8 @@ src_configure() {
$(use_enable networkmanager nm) \
$(use_enable zeroconf avahi) \
$(use_enable idn) \
- "--with-dynamic-prpls=${DYNAMIC_PRPLS}" \
+ --with-system-ssl-certs="/etc/ssl/certs/" \
+ --with-dynamic-prpls="${DYNAMIC_PRPLS}" \
--disable-mono \
--x-includes=/usr/include/X11 \
${myconf}
@@ -206,4 +211,6 @@ src_install() {
done
fi
use perl && fixlocalpod
+
+ find "${D}" -type f -name '*.la' -exec rm -rf '{}' '+' || die "la removal failed"
}