summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 18:36:21 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 18:36:21 +0000
commit4bbdaf74e45ff2f1fe7153dc8936d0033d79a400 (patch)
tree6783ad7f8aa591850bf4e3b7bd35a787d3814118 /net-fs
parentFix a FPE (diff)
downloadgentoo-2-4bbdaf74e45ff2f1fe7153dc8936d0033d79a400.tar.gz
gentoo-2-4bbdaf74e45ff2f1fe7153dc8936d0033d79a400.tar.bz2
gentoo-2-4bbdaf74e45ff2f1fe7153dc8936d0033d79a400.zip
Support linking against libsystemd, bug #526362.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/samba/ChangeLog6
-rw-r--r--net-fs/samba/files/samba-4.1.14-libsystemd.patch51
-rw-r--r--net-fs/samba/samba-4.1.14.ebuild4
3 files changed, 59 insertions, 2 deletions
diff --git a/net-fs/samba/ChangeLog b/net-fs/samba/ChangeLog
index 6df0fe658162..0db5a348c322 100644
--- a/net-fs/samba/ChangeLog
+++ b/net-fs/samba/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-fs/samba
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.702 2015/01/03 17:28:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/ChangeLog,v 1.703 2015/01/03 18:36:21 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org>
+ +files/samba-4.1.14-libsystemd.patch, samba-4.1.14.ebuild:
+ Support linking against libsystemd, bug #526362.
03 Jan 2015; Michał Górny <mgorny@gentoo.org> samba-4.1.14.ebuild:
Make systemd library support optional, bug #512510.
diff --git a/net-fs/samba/files/samba-4.1.14-libsystemd.patch b/net-fs/samba/files/samba-4.1.14-libsystemd.patch
new file mode 100644
index 000000000000..94b30c00e162
--- /dev/null
+++ b/net-fs/samba/files/samba-4.1.14-libsystemd.patch
@@ -0,0 +1,51 @@
+From 0f9b06ade820ce165015526220569db81e00150b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 3 Jan 2015 18:59:48 +0100
+Subject: [PATCH] Support libsystemd, renamed from libsystemd-daemon
+
+---
+ lib/util/wscript_build | 2 +-
+ wscript | 4 ++++
+ 2 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/lib/util/wscript_build b/lib/util/wscript_build
+index f161f96..6b6b511 100755
+--- a/lib/util/wscript_build
++++ b/lib/util/wscript_build
+@@ -10,7 +10,7 @@ bld.SAMBA_LIBRARY('samba-util',
+ server_id.c dprintf.c parmlist.c bitmap.c pidfile.c
+ tevent_debug.c util_process.c memcache.c''',
+ deps='DYNCONFIG',
+- public_deps='talloc tevent execinfo uid_wrapper pthread LIBCRYPTO charset util_setid systemd-daemon',
++ public_deps='talloc tevent execinfo uid_wrapper pthread LIBCRYPTO charset util_setid systemd systemd-daemon',
+ public_headers='debug.h attr.h byteorder.h data_blob.h memory.h safe_string.h time.h talloc_stack.h xfile.h dlinklist.h samba_util.h string_wrappers.h',
+ header_path= [ ('dlinklist.h samba_util.h', '.'), ('*', 'util') ],
+ local_include=False,
+diff --git a/wscript b/wscript
+index f389f90..3c4fa21 100644
+--- a/wscript
++++ b/wscript
+@@ -183,9 +183,12 @@ def configure(conf):
+ conf.env['ENABLE_PIE'] = True
+
+ if Options.options.enable_systemd != False:
++ conf.check_cfg(package='libsystemd', args='--cflags --libs',
++ msg='Checking for libsystemd', uselib_store="SYSTEMD")
+ conf.check_cfg(package='libsystemd-daemon', args='--cflags --libs',
+ msg='Checking for libsystemd-daemon', uselib_store="SYSTEMD-DAEMON")
+ conf.CHECK_HEADERS('systemd/sd-daemon.h', lib='systemd-daemon')
++ conf.CHECK_LIB('systemd', shlib=True)
+ conf.CHECK_LIB('systemd-daemon', shlib=True)
+
+ if conf.CONFIG_SET('HAVE_SYSTEMD_SD_DAEMON_H'):
+@@ -193,6 +196,7 @@ def configure(conf):
+ conf.env['ENABLE_SYSTEMD'] = True
+ else:
+ conf.SET_TARGET_TYPE('systemd-daemon', 'EMPTY')
++ conf.SET_TARGET_TYPE('systemd', 'EMPTY')
+ conf.undefine('HAVE_SYSTEMD')
+
+ conf.SAMBA_CONFIG_H('include/config.h')
+--
+2.2.1
+
diff --git a/net-fs/samba/samba-4.1.14.ebuild b/net-fs/samba/samba-4.1.14.ebuild
index 74d4208637d5..b9a3d90c8522 100644
--- a/net-fs/samba/samba-4.1.14.ebuild
+++ b/net-fs/samba/samba-4.1.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.14.ebuild,v 1.2 2015/01/03 17:28:06 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba/samba-4.1.14.ebuild,v 1.3 2015/01/03 18:36:21 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python2_{6,7} )
@@ -70,6 +70,8 @@ CONFDIR="${FILESDIR}/$(get_version_component_range 1-2)"
PATCHES=(
"${FILESDIR}/${PN}-4.1.14-named.conf.dlz.patch"
"${FILESDIR}/${PN}-4.0.19-automagic_aio_fix.patch"
+ # support libsystemd (instead of libsystemd-daemon), bug #526362
+ "${FILESDIR}/${PN}-4.1.14-libsystemd.patch"
)
WAF_BINARY="${S}/buildtools/bin/waf"