summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2014-10-23 10:11:16 +0000
committerSven Wegener <swegener@gentoo.org>2014-10-23 10:11:16 +0000
commit9a078e87d7baf1950f5da7f9c310f83035c3213a (patch)
tree8e408f97af3884c27b0f6d7b1795f1ef1c03ef46 /net-dns
parentUnconditionally enable completion, bug #526232. (diff)
downloadgentoo-2-9a078e87d7baf1950f5da7f9c310f83035c3213a.tar.gz
gentoo-2-9a078e87d7baf1950f5da7f9c310f83035c3213a.tar.bz2
gentoo-2-9a078e87d7baf1950f5da7f9c310f83035c3213a.zip
Version bump, bug #524450.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0x64D4CF24)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/pdns-recursor/ChangeLog7
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.6.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index ed1e42d3600c..e4cae1466fa5 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.48 2014/07/20 19:22:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.49 2014/10/23 10:11:16 swegener Exp $
+
+*pdns-recursor-3.6.1 (23 Oct 2014)
+
+ 23 Oct 2014; Sven Wegener <swegener@gentoo.org> +pdns-recursor-3.6.1.ebuild:
+ Version bump, bug #524450.
20 Jul 2014; Sven Wegener <swegener@gentoo.org>
-pdns-recursor-3.1.7.2.ebuild, -pdns-recursor-3.2.ebuild,
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.6.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.6.1.ebuild
new file mode 100644
index 000000000000..8a1808721521
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.6.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.6.1.ebuild,v 1.1 2014/10/23 10:11:16 swegener Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lua"
+
+DEPEND="lua? ( >=dev-lang/lua-5.1 )"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1"
+DEPEND="${DEPEND}
+ >=dev-libs/boost-1.33.1"
+
+pkg_setup() {
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ true
+}
+
+src_compile() {
+ emake \
+ LOCALSTATEDIR=/var/lib/powerdns \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)" \
+ OPTFLAGS="" \
+ LUA_LIBS_CONFIG="-llua" \
+ LUA_CPPFLAGS_CONFIG="" \
+ LUA="$(use lua && echo 1)"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control
+ doman pdns_recursor.1 rec_control.1
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf
+
+ doinitd "${FILESDIR}"/precursor
+
+ # Pretty ugly, uh?
+ dodir /var/lib/powerdns/var/lib
+ dosym ../.. /var/lib/powerdns/var/lib/powerdns
+}