summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-04-11 15:01:36 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-04-11 15:01:36 +0000
commit16d6e2d16a3262c29f05b54931f6eb775cc1b756 (patch)
tree3b8a4bdc6b0ec50a9b5b59c6ec636a10887cd76f /net-dns
parentFix Manifest. (diff)
downloadgentoo-2-16d6e2d16a3262c29f05b54931f6eb775cc1b756.tar.gz
gentoo-2-16d6e2d16a3262c29f05b54931f6eb775cc1b756.tar.bz2
gentoo-2-16d6e2d16a3262c29f05b54931f6eb775cc1b756.zip
Version bumepd, bug #362013. Added proxied developer.
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog8
-rw-r--r--net-dns/unbound/metadata.xml12
-rw-r--r--net-dns/unbound/unbound-1.4.9.ebuild85
3 files changed, 101 insertions, 4 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 1ddf0f7921c1..94027ae523d3 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.20 2011/01/25 14:20:31 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.21 2011/04/11 15:01:36 matsuu Exp $
+
+*unbound-1.4.9 (11 Apr 2011)
+
+ 11 Apr 2011; MATSUU Takuto <matsuu@gentoo.org> +unbound-1.4.9.ebuild,
+ metadata.xml:
+ Version bumepd, bug #362013. Added proxied developer.
*unbound-1.4.8 (25 Jan 2011)
diff --git a/net-dns/unbound/metadata.xml b/net-dns/unbound/metadata.xml
index 13adca7786cc..3df92ef0dcfe 100644
--- a/net-dns/unbound/metadata.xml
+++ b/net-dns/unbound/metadata.xml
@@ -3,7 +3,14 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
-<email>matsuu@gentoo.org</email>
+ <email>matsuu@gentoo.org</email>
+ <description>Primary maintainer</description>
+ <name>MATSUU Takuto</name>
+</maintainer>
+<maintainer>
+ <email>nabeken@tknetworks.org</email>
+ <description>Proxied developer. Please CC on bugs.</description>
+ <name>TANABE Ken-ichi</name>
</maintainer>
<longdescription lang="en">
Unbound is a validating, recursive, and caching DNS resolver.
@@ -17,8 +24,7 @@ DNSSEC (secure DNS) validation and stub-resolvers (that do not run
as a server, but are linked into an application) are easily possible.
</longdescription>
<use>
- <flag name='libevent'>Use <pkg>dev-libs/libevent</pkg> instead of internal
- select based events</flag>
+ <flag name='libevent'>Use <pkg>dev-libs/libevent</pkg> instead of internal select based events</flag>
<flag name='gost'>Enable GOST support</flag>
</use>
</pkgmetadata>
diff --git a/net-dns/unbound/unbound-1.4.9.ebuild b/net-dns/unbound/unbound-1.4.9.ebuild
new file mode 100644
index 000000000000..9ed6137753c1
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.9.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.9.ebuild,v 1.1 2011/04/11 15:01:36 matsuu Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+inherit eutils python
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="debug gost python static-libs test threads"
+
+RDEPEND="dev-libs/expat
+ dev-libs/libevent
+ >=dev-libs/openssl-0.9.8
+ >=net-libs/ldns-1.6.5[ssl,gost?]"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ python_set_active_version 2
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+}
+
+src_configure() {
+ econf \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(use_with threads pthreads) \
+ $(use_with python pyunbound) \
+ $(use_with python pythonmodule) \
+ --disable-rpath || die
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # bug #299016
+ if use python ; then
+ find "${ED}$(python_get_sitedir)" "(" -name "*.a" -o -name "*.la" ")" -type f -delete || die
+ fi
+
+ newinitd "${FILESDIR}/unbound.initd" unbound || die "newinitd failed"
+ newconfd "${FILESDIR}/unbound.confd" unbound || die "newconfd failed"
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES} || die "dodoc failed"
+
+ # bug #315519
+ #exeinto /usr/libexec/munin/plugins
+ #doexe contrib/unbound_munin_ || die "doexe failed"
+ dodoc contrib/unbound_munin_ || die "dodoc failed"
+
+ docinto selinux
+ dodoc contrib/selinux/* || die "dodoc failed"
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh || die "doexe failed"
+}