summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2010-01-23 09:07:22 +0000
committerMichael Januszewski <spock@gentoo.org>2010-01-23 09:07:22 +0000
commit8c13cd0745b2bd6c8265a0589fa912e2e158ebbb (patch)
treea199020d3a2e07aee3074b434c4a4e11fc6f7f99 /net-analyzer
parentVersion bumped. (diff)
downloadgentoo-2-8c13cd0745b2bd6c8265a0589fa912e2e158ebbb.tar.gz
gentoo-2-8c13cd0745b2bd6c8265a0589fa912e2e158ebbb.tar.bz2
gentoo-2-8c13cd0745b2bd6c8265a0589fa912e2e158ebbb.zip
Fix bug #301878.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-5.20-nolua.patch33
-rw-r--r--net-analyzer/nmap/nmap-5.20.ebuild3
3 files changed, 40 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 3553d5d88272..2d4a0b35812b 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.214 2010/01/22 20:41:04 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.215 2010/01/23 09:07:14 spock Exp $
+
+ 23 Jan 2010; Michał Januszewski <spock@gentoo.org> nmap-5.20.ebuild,
+ +files/nmap-5.20-nolua.patch:
+ Fix bug #301878.
*nmap-5.20 (21 Jan 2010)
diff --git a/net-analyzer/nmap/files/nmap-5.20-nolua.patch b/net-analyzer/nmap/files/nmap-5.20-nolua.patch
new file mode 100644
index 000000000000..5e158c568b3b
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-5.20-nolua.patch
@@ -0,0 +1,33 @@
+diff -Naurp nmap-5.20/portlist.cc nmap-5.20-fixed/portlist.cc
+--- nmap-5.20/portlist.cc 2009-12-20 04:22:19.000000000 +0100
++++ nmap-5.20-fixed/portlist.cc 2010-01-23 09:59:21.000000000 +0100
+@@ -412,7 +412,7 @@ void PortList::setRPCProbeResults(u16 po
+ }
+ }
+
+-
++#ifndef NOLUA
+ void PortList::addScriptResult(u16 portno, int protocol, ScriptResult& sr) {
+ Port *port;
+
+@@ -420,6 +420,7 @@ void PortList::addScriptResult(u16 portn
+
+ port->scriptResults.push_back(sr);
+ }
++#endif
+
+ /*****************************************************************************/
+ /* Convert protocol name from in.h to enum portlist_proto.
+diff -Naurp nmap-5.20/portlist.h nmap-5.20-fixed/portlist.h
+--- nmap-5.20/portlist.h 2009-12-20 04:22:19.000000000 +0100
++++ nmap-5.20-fixed/portlist.h 2010-01-23 09:56:20.000000000 +0100
+@@ -278,7 +278,9 @@ class PortList {
+ void setRPCProbeResults(u16 portno, int proto, int rpc_status, unsigned long rpc_program,
+ unsigned int rpc_lowver, unsigned int rpc_highver);
+
++#ifndef NOLUA
+ void addScriptResult(u16 portno, int protocol, ScriptResult& sr);
++#endif
+
+ /* Cycles through the 0 or more "ignored" ports which should be
+ consolidated for Nmap output. They are returned sorted by the
diff --git a/net-analyzer/nmap/nmap-5.20.ebuild b/net-analyzer/nmap/nmap-5.20.ebuild
index 401a0e4314e7..a2ea64d81463 100644
--- a/net-analyzer/nmap/nmap-5.20.ebuild
+++ b/net-analyzer/nmap/nmap-5.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.20.ebuild,v 1.1 2010/01/22 20:41:04 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-5.20.ebuild,v 1.2 2010/01/23 09:07:14 spock Exp $
EAPI="2"
@@ -33,6 +33,7 @@ src_prepare() {
epatch "${FILESDIR}/${PN}-4.75-include.patch"
epatch "${FILESDIR}/${PN}-4.75-nolua.patch"
epatch "${FILESDIR}/${PN}-5.10_beta1-string.patch"
+ epatch "${FILESDIR}/${PN}-5.20-nolua.patch"
sed -i -e 's/-m 755 -s ncat/-m 755 ncat/' ncat/Makefile.in
}