summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-07-04 19:55:26 +0000
committerEldad Zack <eldad@gentoo.org>2004-07-04 19:55:26 +0000
commit181e27c7512eaadf67eea2923693c8b433cfc7bd (patch)
treef9d442605113a21b5e7c924c3510235b257a028c /net-analyzer/nagios-core
parentAdd sparc patches (diff)
downloadgentoo-2-181e27c7512eaadf67eea2923693c8b433cfc7bd.tar.gz
gentoo-2-181e27c7512eaadf67eea2923693c8b433cfc7bd.tar.bz2
gentoo-2-181e27c7512eaadf67eea2923693c8b433cfc7bd.zip
fix chown /var/nagios/rw, closes #51939
Diffstat (limited to 'net-analyzer/nagios-core')
-rw-r--r--net-analyzer/nagios-core/ChangeLog8
-rw-r--r--net-analyzer/nagios-core/files/digest-nagios-core-1.1-r51
-rw-r--r--net-analyzer/nagios-core/files/digest-nagios-core-1.21
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild8
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild227
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild8
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild8
-rw-r--r--net-analyzer/nagios-core/nagios-core-1.2.ebuild216
8 files changed, 25 insertions, 452 deletions
diff --git a/net-analyzer/nagios-core/ChangeLog b/net-analyzer/nagios-core/ChangeLog
index 46320b4a9f0f..21ebc3347f3c 100644
--- a/net-analyzer/nagios-core/ChangeLog
+++ b/net-analyzer/nagios-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/nagios-core
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.29 2004/07/03 09:06:26 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/ChangeLog,v 1.30 2004/07/04 19:55:26 eldad Exp $
+
+ 04 Jul 2004; Eldad Zack <eldad@gentoo.org> nagios-core-1.1-r4.ebuild,
+ nagios-core-1.1-r5.ebuild, nagios-core-1.1-r6.ebuild,
+ nagios-core-1.2-r1.ebuild:
+ Fix chown of /var/nagios/rw for when there is no apache group. Closes #51939.
+ Thanks to katerina <kllba@operamail.com>.
03 Jul 2004; Eldad Zack <eldad@gentoo.org> nagios-core-1.1-r4.ebuild,
nagios-core-1.1-r5.ebuild, nagios-core-1.1-r6.ebuild,
diff --git a/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5 b/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5
deleted file mode 100644
index 14267bedc75b..000000000000
--- a/net-analyzer/nagios-core/files/digest-nagios-core-1.1-r5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5f48ecd9bad2c4d7c9d88d0b6f347ecf nagios-1.1.tar.gz 1619888
diff --git a/net-analyzer/nagios-core/files/digest-nagios-core-1.2 b/net-analyzer/nagios-core/files/digest-nagios-core-1.2
deleted file mode 100644
index 33ac901db72f..000000000000
--- a/net-analyzer/nagios-core/files/digest-nagios-core-1.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 414d70e5269d5b8d7c21bf3ee129309f nagios-1.2.tar.gz 1625322
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
index 0a1f9c71a084..339a13630320 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.16 2004/07/03 09:06:26 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r4.ebuild,v 1.17 2004/07/04 19:55:26 eldad Exp $
inherit eutils
@@ -124,7 +124,11 @@ pkg_preinst() {
keepdir /var/nagios/archives
chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
keepdir /var/nagios/rw
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ if use noweb; then
+ chown nagios:nagios ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ else
+ chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ fi
}
pkg_postinst() {
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
deleted file mode 100644
index 577b5e7e8c66..000000000000
--- a/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild
+++ /dev/null
@@ -1,227 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r5.ebuild,v 1.9 2004/07/03 09:06:26 eldad Exp $
-
-inherit eutils
-
-MY_P=${P/-core}
-DESCRIPTION="Nagios core - Host and service monitor cgi, docs etc..."
-HOMEPAGE="http://www.nagios.org/"
-SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="noweb mysql postgres perl debug apache2"
-
-DEPEND=">=mail-client/mailx-8.1
- !noweb? (
- >=media-libs/jpeg-6b-r3
- >=media-libs/libpng-1.2.5-r4
- >=media-libs/gd-1.8.3-r5
-
- apache2? ( >=net-www/apache-2.0.43-r1 )
- !apache2? ( <net-www/apache-2 )
- )
-
- perl? ( >=dev-lang/perl-5.6.1-r7 )
- mysql? ( >=dev-db/mysql-3.23.56 )
- postgres? ( >=dev-db/postgresql-7.3.2 )"
-
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # If there's a gd lib on the system, it will try to build with it.
- # check if gdlib-config is on, and then check its output.
- if [[ -x /usr/bin/gdlib-config ]]; then
- if [[ ! $(gdlib-config --libs | grep -- -ljpeg) ]]; then
- eerror "Your gd has been compiled without jpeg support."
- eerror "Please re-emerge gd:"
- eerror "# USE="jpeg" emerge gd"
- die "pkg_setup failed"
- fi
- fi
- enewgroup nagios
- enewuser nagios -1 /bin/bash /dev/null nagios
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/Makefile-distclean.diff.bz2
- use noweb || epatch ${FILESDIR}/tac.cgi.diff.bz2
-}
-
-src_compile() {
- if use mysql && use postgres; then
- eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
- eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
-
- has_version ">=sys-apps/portage-2.0.50" && (
- einfo "You can add:"
- einfo "net-analyzer/nagios-core [use flags]"
- einfo "to the file:"
- einfo "/etc/portage/package.use"
- einfo "to permamently set this package's USE flags"
- )
-
- exit 1
- fi
-
- local myconf
-
- use mysql && myconf="${myconf} \
- --with-mysql-xdata \
- --with-mysql-status \
- --with-mysql-comments \
- --with-mysql-extinfo \
- --with-mysql-retention \
- --with-mysql-downtime"
-
- use postgres && myconf="${myconf} \
- --with-pgsql-xdata \
- --with-pgsql-status \
- --with-pgsql-comments \
- --with-pgsql-extinfo \
- --with-pgsql-retention \
- --with-pgsql-downtime"
-
- use perl && myconf="${myconf} \
- --enable-embedded-perl \
- --with-perlcache"
-
- if use debug; then
- myconf="${myconf} --enable-DEBUG0"
- myconf="${myconf} --enable-DEBUG1"
- myconf="${myconf} --enable-DEBUG2"
- myconf="${myconf} --enable-DEBUG3"
- myconf="${myconf} --enable-DEBUG4"
- myconf="${myconf} --enable-DEBUG5"
- fi
-
- ./configure ${myconf} \
- --host=${CHOST} \
- --prefix=/usr/nagios \
- --localstatedir=/var/nagios \
- --sysconfdir=/etc/nagios \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make DESTDIR=${D} nagios contrib
-
- use noweb || make DESTDIR=${D} cgis # Only compile the CGI's if "noweb" useflag is not set.
-}
-
-src_install() {
- dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
-
- use noweb || (
- make DESTDIR=${D} install-html
- )
-
- make DESTDIR=${D} install
- make DESTDIR=${D} install-config
- make DESTDIR=${D} install-commandmode
-
- exeinto /etc/init.d
- doexe ${FILESDIR}/nagios
-
- insinto /etc/nagios
- doins ${FILESDIR}/nagios.cfg-sample
-
- insinto /usr/nagios/contrib
- doins contrib/*
-
- insinto /usr/nagios/contrib/database
- doins contrib/database/*
-
- insinto /usr/nagios/contrib/eventhandlers
- doins contrib/eventhandlers/*
-
- insinto /usr/nagios/contrib/eventhandlers/distributed-monitoring
- doins contrib/eventhandlers/distributed-monitoring/*
-
- insinto /usr/nagios/contrib/eventhandlers/redundancy-scenario1
- doins contrib/eventhandlers/redundancy-scenario1/*
-}
-
-pkg_preinst() {
- einfo "Sample config files installed by default will always"
- einfo "include cgi.cfg"
- chown -R nagios:nagios ${D}/etc/nagios || die "Failed Chown of ${D}/etc/nagios"
- keepdir /usr/nagios/share/ssi
- chown -R nagios:nagios ${D}/usr/nagios || die "Failed Chown of ${D}/usr/nagios"
- keepdir /var/nagios
- keepdir /var/nagios/archives
- chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
- keepdir /var/nagios/rw
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
-}
-
-pkg_postinst() {
- einfo
- einfo "Remember to edit the config files in /etc/nagios"
- einfo "Also, if you want nagios to start at boot time"
- einfo "remember to execute rc-update add nagios default"
- einfo
-
- if ! use noweb; then
- einfo "This does not include cgis that are perl-dependent"
- einfo "Currently traceroute.cgi is perl-dependent"
- einfo "To have ministatus.cgi requires copying of ministatus.c"
- einfo "to cgi directory for compiling."
-
- einfo "1. Execute the command:"
- einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
-
- if ! use apache2; then
- einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
- else
- einfo " 2. Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
- fi
-
- einfo
- einfo "That will make nagios's web front end visable via"
- einfo "http://localhost/nagios/"
- einfo
- else
- einfo "Please note that you have installed Nagios without web interface."
- einfo "Please don't file any bugs about having no web interface when you do this."
- einfo "Thank you!"
- fi
-
- einfo "If your kernel has /proc protection, nagios"
- einfo "will not be happy as it relies on accessing the proc"
- einfo "filesystem. You can fix this by adding nagios into"
- einfo "the group wheel, but this is not recomended."
- einfo
-}
-
-pkg_config() {
- if ! use noweb; then
- if use apache2; then
- insinto /etc/apache2/conf/modules.d
- doins ${FILESDIR}/99_nagios.conf
-
- einfo
- einfo "Remember to edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
- einfo
- else
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/nagios.conf
- echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
-
- einfo
- einfo "Remember to edit /etc/conf.d/apache and add \"-D NAGIOS\""
- einfo
- fi
- else
- einfo "Nothing to configure"
- fi
-}
-
-pkg_prerm() {
- /etc/init.d/nagios stop
-}
diff --git a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
index 10aef3aa128b..8d6105da176a 100644
--- a/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.10 2004/07/03 09:06:26 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.1-r6.ebuild,v 1.11 2004/07/04 19:55:26 eldad Exp $
inherit eutils
@@ -162,7 +162,11 @@ pkg_preinst() {
keepdir /var/nagios/archives
chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
keepdir /var/nagios/rw
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ if use noweb; then
+ chown nagios:nagios ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ else
+ chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ fi
}
pkg_postinst() {
diff --git a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
index 55ef8ab5720e..2e5a5badfded 100644
--- a/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.7 2004/07/03 09:06:26 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2-r1.ebuild,v 1.8 2004/07/04 19:55:26 eldad Exp $
inherit eutils
@@ -162,7 +162,11 @@ pkg_preinst() {
keepdir /var/nagios/archives
chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
keepdir /var/nagios/rw
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ if use noweb; then
+ chown nagios:nagios ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ else
+ chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
+ fi
}
pkg_postinst() {
diff --git a/net-analyzer/nagios-core/nagios-core-1.2.ebuild b/net-analyzer/nagios-core/nagios-core-1.2.ebuild
deleted file mode 100644
index a9a8ce1bb166..000000000000
--- a/net-analyzer/nagios-core/nagios-core-1.2.ebuild
+++ /dev/null
@@ -1,216 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nagios-core/nagios-core-1.2.ebuild,v 1.8 2004/07/03 09:06:26 eldad Exp $
-
-inherit eutils
-
-MY_P=${P/-core}
-DESCRIPTION="Nagios core - Host and service monitor cgi, docs etc..."
-HOMEPAGE="http://www.nagios.org/"
-SRC_URI="mirror://sourceforge/nagios/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~amd64"
-IUSE="noweb mysql postgres perl debug apache2"
-
-DEPEND=">=mail-client/mailx-8.1
- !noweb? (
- >=media-libs/jpeg-6b-r3
- >=media-libs/libpng-1.2.5-r4
- >=media-libs/gd-1.8.3-r5
-
- apache2? ( >=net-www/apache-2.0.43-r1 )
- !apache2? ( <net-www/apache-2 )
- )
-
- perl? ( >=dev-lang/perl-5.6.1-r7 )
- mysql? ( >=dev-db/mysql-3.23.56 )
- postgres? ( >=dev-db/postgresql-7.3.2 )"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- # If there's a gd lib on the system, it will try to build with it.
- # check if gdlib-config is on, and then check its output.
- if [[ -x /usr/bin/gdlib-config ]]; then
- if [[ ! $(gdlib-config --libs | grep -- -ljpeg) ]]; then
- eerror "Your gd has been compiled without jpeg support."
- eerror "Please re-emerge gd:"
- eerror "# USE="jpeg" emerge gd"
- die "pkg_setup failed"
- fi
- fi
-
- enewgroup nagios
- enewuser nagios -1 /bin/bash /dev/null nagios
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/Makefile-distclean.diff.bz2
-}
-
-src_compile() {
- if use mysql && use postgres; then
- eerror "Unfortunatly you can't have both MySQL and PostgreSQL enabled at the same time."
- eerror "You have to remove either 'mysql' or 'postgres' from your USE flags before emerging this."
-
- has_version ">=sys-apps/portage-2.0.50" && (
- einfo "You can add:"
- einfo "net-analyzer/nagios-core [use flags]"
- einfo "to the file:"
- einfo "/etc/portage/package.use"
- einfo "to permamently set this package's USE flags"
- )
-
- exit 1
- fi
-
- local myconf
-
- use mysql && myconf="${myconf} \
- --with-mysql-xdata \
- --with-mysql-status \
- --with-mysql-comments \
- --with-mysql-extinfo \
- --with-mysql-retention \
- --with-mysql-downtime"
-
- use postgres && myconf="${myconf} \
- --with-pgsql-xdata \
- --with-pgsql-status \
- --with-pgsql-comments \
- --with-pgsql-extinfo \
- --with-pgsql-retention \
- --with-pgsql-downtime"
-
- use perl && myconf="${myconf} \
- --enable-embedded-perl \
- --with-perlcache"
-
- if use debug; then
- myconf="${myconf} --enable-DEBUG0"
- myconf="${myconf} --enable-DEBUG1"
- myconf="${myconf} --enable-DEBUG2"
- myconf="${myconf} --enable-DEBUG3"
- myconf="${myconf} --enable-DEBUG4"
- myconf="${myconf} --enable-DEBUG5"
- fi
-
- ./configure ${myconf} \
- --host=${CHOST} \
- --prefix=/usr/nagios \
- --localstatedir=/var/nagios \
- --sysconfdir=/etc/nagios \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- make DESTDIR=${D} nagios contrib
-
- use noweb || make DESTDIR=${D} cgis # Only compile the CGI's if "noweb" useflag is not set.
-}
-
-src_install() {
- dodoc Changelog INSTALLING LEGAL LICENSE README UPGRADING
-
- use noweb && (
- sed -i -e 's/cd $(SRC_CGI) && $(MAKE) $@/# line removed due to noweb use flag/' Makefile
- sed -i -e 's/cd $(SRC_HTM) && $(MAKE) $@/# line removed due to noweb use flag/' Makefile
- )
-
- make DESTDIR=${D} install
- make DESTDIR=${D} install-config
- make DESTDIR=${D} install-commandmode
-
- docinto sample-configs
- dodoc ${D}/etc/nagios/*
- rm ${D}/etc/nagios/*
-
- dodoc ${FILESDIR}/nagios.cfg-sample
-
- exeinto /etc/init.d
- doexe ${FILESDIR}/nagios
-
- insinto /usr/nagios/contrib
- doins contrib/*
-
- insinto /usr/nagios/contrib/database
- doins contrib/database/*
-
- insinto /usr/nagios/contrib/eventhandlers
- doins contrib/eventhandlers/*
-
- insinto /usr/nagios/contrib/eventhandlers/distributed-monitoring
- doins contrib/eventhandlers/distributed-monitoring/*
-
- insinto /usr/nagios/contrib/eventhandlers/redundancy-scenario1
- doins contrib/eventhandlers/redundancy-scenario1/*
-}
-
-pkg_preinst() {
- einfo "Sample config files installed by default will always"
- einfo "include cgi.cfg"
- einfo "The sample configs can be found in /usr/share/doc/${PF}/sample-configs/"
- chown -R nagios:nagios ${D}/etc/nagios || die "Failed Chown of ${D}/etc/nagios"
- keepdir /usr/nagios/share/ssi
- chown -R nagios:nagios ${D}/usr/nagios || die "Failed Chown of ${D}/usr/nagios"
- keepdir /var/nagios
- keepdir /var/nagios/archives
- chown -R nagios:nagios ${D}/var/nagios || die "Failed Chown of ${D}/var/nagios"
- keepdir /var/nagios/rw
- chown nagios:apache ${D}/var/nagios/rw || die "Failed Chown of ${D}/var/nagios/rw"
-}
-
-pkg_postinst() {
- einfo
- einfo "Remember to edit the config files in /etc/nagios"
- einfo "Also, if you want nagios to start at boot time"
- einfo "remember to execute:"
- einfo " rc-update add nagios default"
- einfo
-
- if ! use noweb; then
- einfo "This does not include cgis that are perl-dependent"
- einfo "Currently traceroute.cgi is perl-dependent"
- einfo "To have ministatus.cgi requires copying of ministatus.c"
- einfo "to cgi directory for compiling."
-
- einfo "1. Execute the command:"
- einfo " \"ebuild /var/db/pkg/net-analyzer/${PF}/${PF}.ebuild config\""
-
- if use apache2; then
- insinto /etc/apache2/conf/modules.d
- doins ${FILESDIR}/99_nagios.conf
-
- einfo " 2. Edit /etc/conf.d/apache2 and add \"-D NAGIOS\""
- else
- insinto /etc/apache/conf/addon-modules
- doins ${FILESDIR}/nagios.conf
- echo "Include conf/addon-modules/nagios.conf" >> ${ROOT}/etc/apache/conf/apache.conf
-
- einfo " 2. Edit /etc/conf.d/apache and add \"-D NAGIOS\""
- fi
-
- einfo
- einfo "That will make nagios's web front end visable via"
- einfo "http://localhost/nagios/"
- einfo
- else
- einfo "Please note that you have installed Nagios without web interface."
- einfo "Please don't file any bugs about having no web interface when you do this."
- einfo "Thank you!"
- fi
-
- einfo "If your kernel has /proc protection, nagios"
- einfo "will not be happy as it relies on accessing the proc"
- einfo "filesystem. You can fix this by adding nagios into"
- einfo "the group wheel, but this is not recomended."
- einfo
-}
-
-pkg_prerm() {
- /etc/init.d/nagios stop
-}