summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-12-22 10:48:45 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-12-22 10:48:45 +0000
commitc06cf92bf9413b6412ecdeb0d66b9534c6ef942c (patch)
tree58058a3cb00446f75631ae05196281324bc9658b /media-video/minitube
parentVersion bump. (diff)
downloadgentoo-2-c06cf92bf9413b6412ecdeb0d66b9534c6ef942c.tar.gz
gentoo-2-c06cf92bf9413b6412ecdeb0d66b9534c6ef942c.tar.bz2
gentoo-2-c06cf92bf9413b6412ecdeb0d66b9534c6ef942c.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-video/minitube')
-rw-r--r--media-video/minitube/ChangeLog7
-rw-r--r--media-video/minitube/minitube-2.1.5.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/media-video/minitube/ChangeLog b/media-video/minitube/ChangeLog
index b40147ba155c..ac86b2d1456a 100644
--- a/media-video/minitube/ChangeLog
+++ b/media-video/minitube/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/minitube
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.92 2013/11/30 00:16:22 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/ChangeLog,v 1.93 2013/12/22 10:48:45 hwoarang Exp $
+
+*minitube-2.1.5 (22 Dec 2013)
+
+ 22 Dec 2013; Markos Chandras <hwoarang@gentoo.org> +minitube-2.1.5.ebuild:
+ Version bump
30 Nov 2013; Markos Chandras <hwoarang@gentoo.org> minitube-2.1.3.ebuild:
Remove gtkstyle use-dep from dev-qt/qtgui. Bug #492818 by Alec Moskvin
diff --git a/media-video/minitube/minitube-2.1.5.ebuild b/media-video/minitube/minitube-2.1.5.ebuild
new file mode 100644
index 000000000000..e45c516e68a8
--- /dev/null
+++ b/media-video/minitube/minitube-2.1.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/minitube/minitube-2.1.5.ebuild,v 1.1 2013/12/22 10:48:45 hwoarang Exp $
+
+EAPI=5
+PLOCALES="ar ca ca_ES da de_DE el en es es_AR es_ES fi fi_FI fr he_IL hr hu
+ia it jv nl pl pl_PL pt_BR ro ru sk sl tr zh_CN"
+
+inherit l10n qt4-r2
+
+DESCRIPTION="Qt4 YouTube Client"
+HOMEPAGE="http://flavio.tordini.org/minitube"
+# As usual, upstream never releases proper tarballs
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug download gstreamer kde"
+
+DEPEND=">=dev-qt/qtgui-4.8:4[accessibility]
+ >=dev-qt/qtdbus-4.8:4
+ >=dev-qt/qtsql-4.8:4
+ kde? ( || ( media-libs/phonon[gstreamer?] >=dev-qt/qtphonon-4.8:4 ) )
+ !kde? ( || ( >=dev-qt/qtphonon-4.8:4 media-libs/phonon[gstreamer?] ) )
+ gstreamer? (
+ media-plugins/gst-plugins-soup:0.10
+ media-plugins/gst-plugins-ffmpeg:0.10
+ media-plugins/gst-plugins-faac:0.10
+ media-plugins/gst-plugins-faad:0.10
+ media-plugins/gst-plugins-theora
+ )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="AUTHORS CHANGES TODO"
+
+#455976
+PATCHES=( "${FILESDIR}"/${PN}-2.1.3-disable-updates.patch )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ # Remove unneeded translations
+ local trans=
+ for x in $(l10n_get_locales); do
+ trans+="${x}.ts "
+ done
+ if [[ -n ${trans} ]]; then
+ sed -i -e "/^TRANSLATIONS/s/+=.*/+=${trans}/" locale/locale.pri || die
+ fi
+ # gcc-4.7. Bug #422977. Will probably be fixed
+ # once ubuntu moves to gcc-4.7
+ epatch "${FILESDIR}"/${PN}-1.9-gcc47.patch
+ # Enable video downloads. Bug #491344
+ use download && { echo "DEFINES += APP_DOWNLOADS" >> ${PN}.pro; }
+}
+
+src_install() {
+ qt4-r2_src_install
+ newicon images/app.png minitube.png
+}
+
+pkg_postinst() {
+ if use download; then
+ elog "You activated the 'download' USE flag. This allows you to"
+ elog "download videos from youtube, which might violate the youtube"
+ elog "terms-of-service (TOS) in some legislations. If downloading"
+ elog "youtube-videos is not allowed in your legislation, please"
+ elog "disable the 'download' use flag. For details on the youtube TOS,"
+ elog "see http://www.youtube.com/t/terms"
+ fi
+}