summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-10 01:49:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-10 01:49:42 +0000
commitbe65cc91a221e52a75b93b85ddebea5236585cb0 (patch)
treecff04158c43cc1bce9ebb08518e1c9529deb19a0 /media-video/griffith
parentVersion bump to new bugfix release and remove old. (diff)
downloadgentoo-2-be65cc91a221e52a75b93b85ddebea5236585cb0.tar.gz
gentoo-2-be65cc91a221e52a75b93b85ddebea5236585cb0.tar.bz2
gentoo-2-be65cc91a221e52a75b93b85ddebea5236585cb0.zip
Version bump
(Portage version: 2.2_rc91/cvs/Linux x86_64)
Diffstat (limited to 'media-video/griffith')
-rw-r--r--media-video/griffith/ChangeLog7
-rw-r--r--media-video/griffith/griffith-0.12.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/media-video/griffith/ChangeLog b/media-video/griffith/ChangeLog
index 330512d5fdb1..2df99ecb29a3 100644
--- a/media-video/griffith/ChangeLog
+++ b/media-video/griffith/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/griffith
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.48 2010/08/21 20:13:54 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/ChangeLog,v 1.49 2010/10/10 01:49:42 hwoarang Exp $
+
+*griffith-0.12 (10 Oct 2010)
+
+ 10 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +griffith-0.12.ebuild:
+ Version bump
21 Aug 2010; Markos Chandras <hwoarang@gentoo.org>
-files/0.9.6-moving_share_dir.patch, -files/0.9.7.1-fix_spellcheck.patch:
diff --git a/media-video/griffith/griffith-0.12.ebuild b/media-video/griffith/griffith-0.12.ebuild
new file mode 100644
index 000000000000..8666a8f920db
--- /dev/null
+++ b/media-video/griffith/griffith-0.12.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/griffith/griffith-0.12.ebuild,v 1.1 2010/10/10 01:49:41 hwoarang Exp $
+
+EAPI="2"
+
+PYTHON_DEPEND="2"
+
+inherit eutils versionator python multilib
+
+ARTWORK_PV="0.9.4"
+
+DESCRIPTION="Movie collection manager"
+HOMEPAGE="http://griffith.berlios.de/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz
+ mirror://berlios/griffith/${PN}-extra-artwork-${ARTWORK_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="csv doc spell"
+
+RDEPEND="dev-python/imaging
+ gnome-base/libglade
+ dev-python/pyxml
+ >=dev-python/pygtk-2.6.1
+ dev-python/pysqlite:2
+ >=dev-python/sqlalchemy-0.5.2
+ >=dev-python/reportlab-1.19
+ csv? ( dev-python/chardet )
+ spell? ( >=dev-python/gnome-python-extras-2.0 )"
+DEPEND="${RDEPEND}
+ doc? ( app-text/docbook2X )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's#/pl/#/pl.UTF-8/#' \
+ "${S}"/docs/pl/Makefile || die "sed failed"
+
+ sed -i \
+ -e 's/ISO-8859-1/UTF-8/' \
+ "${S}"/lib/gconsole.py || die "sed failed"
+ epatch "${FILESDIR}/0.10-fix_lib_path.patch"
+}
+
+src_compile() {
+ # Nothing to compile and default `emake` spews an error message
+ true
+}
+
+src_install() {
+ use doc || sed -i -e '/docs/d' Makefile
+
+ emake \
+ LIBDIR="${D}/usr/$(get_libdir)/griffith" \
+ DESTDIR="${D}" DOC2MAN=docbook2man.pl install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README THANKS TODO NEWS TRANSLATORS
+
+ cd "${WORKDIR}/${PN}-extra-artwork-${ARTWORK_PV}/"
+ emake DESTDIR="${D}" install || die "emake install artwork failed"
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${PN}
+}