summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Anderson <gentoofan23@gentoo.org>2009-08-25 16:52:15 +0000
committerThomas Anderson <gentoofan23@gentoo.org>2009-08-25 16:52:15 +0000
commit51e8cd11a642ae831d212f4b08d7033ba4083543 (patch)
treec179867ac56e06d44216161403f67c927afbabc1 /media-tv
parentsparc stable wrt #277294 (diff)
downloadgentoo-2-51e8cd11a642ae831d212f4b08d7033ba4083543.tar.gz
gentoo-2-51e8cd11a642ae831d212f4b08d7033ba4083543.tar.bz2
gentoo-2-51e8cd11a642ae831d212f4b08d7033ba4083543.zip
Make all ebuilds use mythtv.eclass' SRC_URI, fixing bug #280516. Convert mythtv-0.21_p18314-r* to EAPI 2 for SRC_URI arrows. Adjust all ebuilds to call source preparation commands in src_prepare as they should be in EAPI 2.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/mythtv/ChangeLog10
-rw-r--r--media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild18
-rw-r--r--media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild18
-rw-r--r--media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild11
-rw-r--r--media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild11
5 files changed, 29 insertions, 39 deletions
diff --git a/media-tv/mythtv/ChangeLog b/media-tv/mythtv/ChangeLog
index 83065c4a250c..ff87bd73ff3a 100644
--- a/media-tv/mythtv/ChangeLog
+++ b/media-tv/mythtv/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-tv/mythtv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.277 2009/08/16 13:45:16 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/ChangeLog,v 1.278 2009/08/25 16:52:15 gentoofan23 Exp $
+
+ 25 Aug 2009; Thomas Anderson <gentoofan23@gentoo.org>
+ mythtv-0.21_p18314-r1.ebuild, mythtv-0.21_p18314-r2.ebuild,
+ mythtv-0.21_p19961-r1.ebuild, mythtv-0.21_p19961-r2.ebuild:
+ Make all ebuilds use mythtv.eclass' SRC_URI, fixing bug #280516. Convert
+ mythtv-0.21_p18314-r* to EAPI 2 for SRC_URI arrows. Adjust all ebuilds to
+ call source preparation commands in src_prepare as they should be in EAPI
+ 2.
16 Aug 2009; Thomas Anderson <gentoofan23@gentoo.org>
mythtv-0.21_p19961-r2.ebuild:
diff --git a/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild b/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild
index 7ab261274b60..63997fddc3bd 100644
--- a/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild
@@ -1,16 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild,v 1.7 2009/03/06 18:11:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p18314-r1.ebuild,v 1.8 2009/08/25 16:52:15 gentoofan23 Exp $
-EAPI=1
+EAPI=2
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python confutils
DESCRIPTION="Homebrew PVR project"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
IUSE_VIDEO_CARDS="video_cards_nvidia"
IUSE="aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd \
lirc mmx opengl perl python xvmc ${IUSE_VIDEO_CARDS}"
@@ -72,11 +70,7 @@ pkg_setup() {
usermod -a -G ${MYTHTV_GROUPS} mythtv
}
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# upstream wants the revision number in their version.cpp
# since the subversion.eclass strips out the .svn directory
# svnversion in MythTV's build doesn't work
@@ -94,7 +88,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-0.21-bttv.patch
}
-src_compile() {
+src_configure() {
local myconf="--prefix=/usr
--mandir=/usr/share/man
--libdir-name=$(get_libdir)"
@@ -177,8 +171,10 @@ src_compile() {
CFLAGS=""
CXXFLAGS=""
einfo "Running ./configure ${myconf}"
- ./configure ${myconf} || die "configure died"
+ sh configure ${myconf} || die "configure died"
+}
+src_compile() {
eqmake3 mythtv.pro -o "Makefile" || die "eqmake3 failed"
emake || die "emake failed"
diff --git a/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild b/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild
index 5610e8724346..c52f2a4c763e 100644
--- a/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild
@@ -1,16 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild,v 1.1 2009/05/29 20:13:06 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p18314-r2.ebuild,v 1.2 2009/08/25 16:52:15 gentoofan23 Exp $
-EAPI=1
+EAPI=2
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python confutils
DESCRIPTION="Homebrew PVR project"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_via"
IUSE="aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd \
lirc mmx opengl perl python xvmc ${IUSE_VIDEO_CARDS}"
@@ -72,11 +70,7 @@ pkg_setup() {
usermod -a -G ${MYTHTV_GROUPS} mythtv
}
-src_unpack() {
-
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# upstream wants the revision number in their version.cpp
# since the subversion.eclass strips out the .svn directory
# svnversion in MythTV's build doesn't work
@@ -98,7 +92,7 @@ src_unpack() {
}
-src_compile() {
+src_configure() {
local myconf="--prefix=/usr
--mandir=/usr/share/man
--libdir-name=$(get_libdir)"
@@ -178,8 +172,10 @@ src_compile() {
CFLAGS=""
CXXFLAGS=""
einfo "Running ./configure ${myconf}"
- ./configure ${myconf} || die "configure died"
+ sh configure ${myconf} || die "configure died"
+}
+src_compile() {
eqmake3 mythtv.pro -o "Makefile" || die "eqmake3 failed"
emake || die "emake failed"
diff --git a/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild b/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
index d848f346020b..f7f5df74d633 100644
--- a/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild,v 1.3 2009/03/06 18:11:04 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r1.ebuild,v 1.4 2009/08/25 16:52:15 gentoofan23 Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python confutils
@@ -9,8 +9,6 @@ DESCRIPTION="Homebrew PVR project"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
IUSE_VIDEO_CARDS="video_cards_nvidia"
IUSE="aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd \
lirc mmx opengl perl python xvmc ${IUSE_VIDEO_CARDS}"
@@ -69,10 +67,7 @@ pkg_setup() {
usermod -a -G ${MYTHTV_GROUPS} mythtv
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# upstream wants the revision number in their version.cpp
# since the subversion.eclass strips out the .svn directory
# svnversion in MythTV's build doesn't work
@@ -167,7 +162,7 @@ src_configure() {
CFLAGS=""
CXXFLAGS=""
einfo "Running ./configure ${myconf}"
- ./configure ${myconf} || die "configure died"
+ sh configure ${myconf} || die "configure died"
}
src_compile() {
diff --git a/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild b/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild
index 8debff2da4d1..50b9626032ce 100644
--- a/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild
+++ b/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild,v 1.2 2009/08/16 13:45:16 gentoofan23 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-tv/mythtv/mythtv-0.21_p19961-r2.ebuild,v 1.3 2009/08/25 16:52:15 gentoofan23 Exp $
EAPI=2
inherit flag-o-matic multilib eutils qt3 mythtv toolchain-funcs python confutils
@@ -9,8 +9,6 @@ DESCRIPTION="Homebrew PVR project"
SLOT="0"
KEYWORDS="amd64 ~ppc ~x86"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
IUSE_VIDEO_CARDS="video_cards_nvidia video_cards_via"
IUSE="aac alsa altivec autostart debug directv dvb dvd fftw ieee1394 jack lcd \
lirc mmx opengl perl python xvmc ${IUSE_VIDEO_CARDS}"
@@ -70,10 +68,7 @@ pkg_setup() {
usermod -a -G ${MYTHTV_GROUPS} mythtv
}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# upstream wants the revision number in their version.cpp
# since the subversion.eclass strips out the .svn directory
# svnversion in MythTV's build doesn't work
@@ -165,7 +160,7 @@ src_configure() {
CFLAGS=""
CXXFLAGS=""
einfo "Running ./configure ${myconf}"
- ./configure ${myconf} || die "configure died"
+ sh configure ${myconf} || die "configure died"
}
src_compile() {