summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Cort <tcort@gentoo.org>2006-09-11 13:19:31 +0000
committerThomas Cort <tcort@gentoo.org>2006-09-11 13:19:31 +0000
commitec3a8ed106f9b720a0e98ee0ee74ff82c45d3ba6 (patch)
treec09f64c8f108ad22f5c930b50a3a842ca201f746 /media-sound
parentMigrated to new Java build system. (diff)
downloadgentoo-2-ec3a8ed106f9b720a0e98ee0ee74ff82c45d3ba6.tar.gz
gentoo-2-ec3a8ed106f9b720a0e98ee0ee74ff82c45d3ba6.tar.bz2
gentoo-2-ec3a8ed106f9b720a0e98ee0ee74ff82c45d3ba6.zip
Version bump to 1.61.27.
(Portage version: 2.1-r2)
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/streamripper/ChangeLog7
-rw-r--r--media-sound/streamripper/files/digest-streamripper-1.61.273
-rw-r--r--media-sound/streamripper/streamripper-1.61.27.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/media-sound/streamripper/ChangeLog b/media-sound/streamripper/ChangeLog
index c5408f0577bc..0b827393e7ea 100644
--- a/media-sound/streamripper/ChangeLog
+++ b/media-sound/streamripper/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/streamripper
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.35 2006/09/04 12:12:51 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.36 2006/09/11 13:19:31 tcort Exp $
+
+*streamripper-1.61.27 (11 Sep 2006)
+
+ 11 Sep 2006; Thomas Cort <tcort@gentoo.org> +streamripper-1.61.27.ebuild:
+ Version bump to 1.61.27.
04 Sep 2006; Thomas Cort <tcort@gentoo.org>
-files/streamripper-1.60.5-interface.patch,
diff --git a/media-sound/streamripper/files/digest-streamripper-1.61.27 b/media-sound/streamripper/files/digest-streamripper-1.61.27
new file mode 100644
index 000000000000..0b87fc2b621b
--- /dev/null
+++ b/media-sound/streamripper/files/digest-streamripper-1.61.27
@@ -0,0 +1,3 @@
+MD5 d92a37bf23ee3f1bd5a9498d72c0562a streamripper-1.61.27.tar.gz 1227559
+RMD160 14b55b91e3b995515d6978383f9fc618fe92bbcb streamripper-1.61.27.tar.gz 1227559
+SHA256 d53fc5d3fb49bbb2332a4d26c5a63a0679009d6bf6b4b0e4e5078a9cdc183111 streamripper-1.61.27.tar.gz 1227559
diff --git a/media-sound/streamripper/streamripper-1.61.27.ebuild b/media-sound/streamripper/streamripper-1.61.27.ebuild
new file mode 100644
index 000000000000..85bf83ee5b70
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.61.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.61.27.ebuild,v 1.1 2006/09/11 13:19:31 tcort Exp $
+
+inherit eutils
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE="vorbis"
+
+DEPEND="media-libs/libmad
+ vorbis? ( media-libs/libogg
+ media-libs/libvorbis )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Force package to use system libmad
+ rm -rf libmad*
+ sed -i -e 's/libmad//' Makefile.in || die "sed failed"
+
+ # for some reason the install-sh file is not executable on OSX...
+ chmod a+x install-sh
+}
+
+src_compile() {
+ econf $(use_with vorbis ogg) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES README THANKS readme_xfade.txt
+}