summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2011-02-27 19:47:21 +0000
committerChristian Parpart <trapni@gentoo.org>2011-02-27 19:47:21 +0000
commit2070d3ff702924ce819cc56bc1991cbb6dad0cc9 (patch)
treea3a71e965c4b86891db626fd367bfb469e324a27 /media-sound/teamspeak-client-bin
parentRemove old ebuilds & patches up to current stable. (diff)
downloadgentoo-2-2070d3ff702924ce819cc56bc1991cbb6dad0cc9.tar.gz
gentoo-2-2070d3ff702924ce819cc56bc1991cbb6dad0cc9.tar.bz2
gentoo-2-2070d3ff702924ce819cc56bc1991cbb6dad0cc9.zip
version bump
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/teamspeak-client-bin')
-rw-r--r--media-sound/teamspeak-client-bin/ChangeLog10
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta36.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/media-sound/teamspeak-client-bin/ChangeLog b/media-sound/teamspeak-client-bin/ChangeLog
index 5fa13d150fce..a62b9b68addd 100644
--- a/media-sound/teamspeak-client-bin/ChangeLog
+++ b/media-sound/teamspeak-client-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/teamspeak-client-bin
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.17 2010/10/23 23:47:32 trapni Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/ChangeLog,v 1.18 2011/02/27 19:47:21 trapni Exp $
+
+*teamspeak-client-bin-3.0.0_beta36 (27 Feb 2011)
+
+ 27 Feb 2011; Christian Parpart <trapni@gentoo.org>
+ +teamspeak-client-bin-3.0.0_beta36.ebuild:
+ version bump
*teamspeak-client-bin-3.0.0_beta32-r2 (23 Oct 2010)
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta36.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta36.ebuild
new file mode 100644
index 000000000000..e617dab747fe
--- /dev/null
+++ b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta36.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.0_beta36.ebuild,v 1.1 2011/02/27 19:47:21 trapni Exp $
+
+# NOTE: The comments in this file are for instruction and documentation.
+# They're not meant to appear with your final, production ebuild. Please
+# remember to remove them before submitting or committing your ebuild. That
+# doesn't mean you can't add your own comments though.
+
+# The 'Header' on the third line should just be left alone. When your ebuild
+# will be committed to cvs, the details on that line will be automatically
+# generated to contain the correct data.
+
+EAPI=1
+
+inherit eutils
+
+DESCRIPTION="TeamSpeak Client - Voice Communication Software"
+HOMEPAGE="http://teamspeak.com/"
+LICENSE="teamspeak3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+PROPERTIES="interactive"
+
+SRC_URI="
+ amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-${PV/3.0.0_beta/}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
+ x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/beta-${PV/3.0.0_beta/}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )
+"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ =media-libs/libpng-1.4*
+ x11-libs/qt-gui:4
+ >=x11-libs/libXinerama-1.0.2"
+
+src_unpack() {
+ # TODO: unpack_makeself -- use this version once it supports makeself 2.1.6
+ for i in ${A}; do
+ sh "${DISTDIR}/${i}" --target "${WORKDIR}" || die "unpack failed"
+ done
+}
+
+src_install() {
+ local dest="${D}/opt/teamspeak3-client"
+
+ mkdir -p "${dest}"
+
+ # remove the qt-libraries as they just cause trouble with the system's Qt
+ # see bug #328807
+ rm "${WORKDIR}"/libQt* || die
+
+ cp -R "${WORKDIR}/"* "${dest}/" || die
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/teamspeak3"
+
+ mv "${dest}/ts3client_linux_"* "${dest}/ts3client"
+
+ make_desktop_entry teamspeak3 TeamSpeak3 \
+ "/opt/teamspeak3-client/gfx/default/24x24_connect.png" \
+ Network
+}