summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-04-15 22:28:13 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-04-15 22:28:13 +0000
commitd60eb0a558142fc1f16c29ee58b0c37a1324564f (patch)
tree2d3a708929ebdc4e3f2f85635dd903cf77ed4159 /media-sound/audacious
parentVersion bump. (diff)
downloadgentoo-2-d60eb0a558142fc1f16c29ee58b0c37a1324564f.tar.gz
gentoo-2-d60eb0a558142fc1f16c29ee58b0c37a1324564f.tar.bz2
gentoo-2-d60eb0a558142fc1f16c29ee58b0c37a1324564f.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux i686)
Diffstat (limited to 'media-sound/audacious')
-rw-r--r--media-sound/audacious/ChangeLog7
-rw-r--r--media-sound/audacious/audacious-3.2.2.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/media-sound/audacious/ChangeLog b/media-sound/audacious/ChangeLog
index 304e4669ffb9..e0bc117c2e16 100644
--- a/media-sound/audacious/ChangeLog
+++ b/media-sound/audacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/audacious
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.258 2012/03/18 15:15:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/ChangeLog,v 1.259 2012/04/15 22:28:13 jdhore Exp $
+
+*audacious-3.2.2 (15 Apr 2012)
+
+ 15 Apr 2012; Jeff Horelick <jdhore@gentoo.org> +audacious-3.2.2.ebuild:
+ Version bump.
18 Mar 2012; Raúl Porcel <armin76@gentoo.org> audacious-2.5.4.ebuild:
alpha/sparc stable wrt #380575
diff --git a/media-sound/audacious/audacious-3.2.2.ebuild b/media-sound/audacious/audacious-3.2.2.ebuild
new file mode 100644
index 000000000000..503a22127908
--- /dev/null
+++ b/media-sound/audacious/audacious-3.2.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/audacious/audacious-3.2.2.ebuild,v 1.1 2012/04/15 22:28:13 jdhore Exp $
+
+EAPI=4
+inherit eutils
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Audacious Player - Your music, your way, no exceptions"
+HOMEPAGE="http://audacious-media-player.org/"
+SRC_URI="http://distfiles.audacious-media-player.org/${MY_P}.tar.bz2
+ mirror://gentoo/gentoo_ice-xmms-0.2.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="chardet +gtk gtk3 nls session"
+
+RDEPEND=">=dev-libs/dbus-glib-0.60
+ >=dev-libs/glib-2.16
+ dev-libs/libxml2
+ >=x11-libs/cairo-1.2.6
+ >=x11-libs/pango-1.8.0
+ gtk? ( x11-libs/gtk+:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ session? ( x11-libs/libSM )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9.0
+ chardet? ( >=app-i18n/libguess-1.1 )
+ nls? ( dev-util/intltool )"
+
+PDEPEND=">=media-plugins/audacious-plugins-3.2.2"
+REQUIRED_USE="^^ ( gtk gtk3 )"
+
+src_configure() {
+ # D-Bus is a mandatory dependency, remote control,
+ # session management and some plugins depend on this.
+ # Building without D-Bus is *unsupported* and a USE-flag
+ # will not be added due to the bug reports that will result.
+ # Bugs #197894, #199069, #207330, #208606
+ # Use of GTK+2 causes plugin build failures, bug #384185
+ econf \
+ --enable-dbus \
+ $(use_enable gtk3) \
+ $(use_enable chardet) \
+ $(use_enable nls) \
+ $(use_enable session sm)
+}
+
+src_install() {
+ default
+ dodoc AUTHORS README
+
+ # Gentoo_ice skin installation; bug #109772
+ insinto /usr/share/audacious/Skins/gentoo_ice
+ doins "${WORKDIR}"/gentoo_ice/*
+ docinto gentoo_ice
+ dodoc "${WORKDIR}"/README
+}