summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-02-26 05:36:57 +0000
committerTim Harder <radhermit@gentoo.org>2012-02-26 05:36:57 +0000
commit8f104dad8b2740a0cf71c0fb2ba5dbfc59cea254 (patch)
tree789e74ea1cc7a5762e104a5789439c2a590dc623 /media-sound/abcm2ps
parentVersion bump. Add screen use flag to allow using app-misc/screen as the defau... (diff)
downloadgentoo-2-8f104dad8b2740a0cf71c0fb2ba5dbfc59cea254.tar.gz
gentoo-2-8f104dad8b2740a0cf71c0fb2ba5dbfc59cea254.tar.bz2
gentoo-2-8f104dad8b2740a0cf71c0fb2ba5dbfc59cea254.zip
Version bumps.
(Portage version: 2.2.0_alpha87/cvs/Linux x86_64)
Diffstat (limited to 'media-sound/abcm2ps')
-rw-r--r--media-sound/abcm2ps/ChangeLog9
-rw-r--r--media-sound/abcm2ps/abcm2ps-6.6.7.ebuild44
-rw-r--r--media-sound/abcm2ps/abcm2ps-7.0.2.ebuild44
3 files changed, 96 insertions, 1 deletions
diff --git a/media-sound/abcm2ps/ChangeLog b/media-sound/abcm2ps/ChangeLog
index 5563c1d0d9a5..fd0025e442e6 100644
--- a/media-sound/abcm2ps/ChangeLog
+++ b/media-sound/abcm2ps/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-sound/abcm2ps
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.42 2012/02/15 09:33:19 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/ChangeLog,v 1.43 2012/02/26 05:36:57 radhermit Exp $
+
+*abcm2ps-7.0.2 (26 Feb 2012)
+*abcm2ps-6.6.7 (26 Feb 2012)
+
+ 26 Feb 2012; Tim Harder <radhermit@gentoo.org> +abcm2ps-6.6.7.ebuild,
+ +abcm2ps-7.0.2.ebuild:
+ Version bumps.
*abcm2ps-7.0.1 (15 Feb 2012)
diff --git a/media-sound/abcm2ps/abcm2ps-6.6.7.ebuild b/media-sound/abcm2ps/abcm2ps-6.6.7.ebuild
new file mode 100644
index 000000000000..32a8071a9280
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-6.6.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/abcm2ps-6.6.7.ebuild,v 1.1 2012/02/26 05:36:57 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+RDEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}
diff --git a/media-sound/abcm2ps/abcm2ps-7.0.2.ebuild b/media-sound/abcm2ps/abcm2ps-7.0.2.ebuild
new file mode 100644
index 000000000000..a8ee38014f51
--- /dev/null
+++ b/media-sound/abcm2ps/abcm2ps-7.0.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/abcm2ps/abcm2ps-7.0.2.ebuild,v 1.1 2012/02/26 05:36:57 radhermit Exp $
+
+EAPI=4
+
+DESCRIPTION="A program to convert abc files to Postscript files"
+HOMEPAGE="http://moinejf.free.fr/"
+SRC_URI="http://moinejf.free.fr/${P}.tar.gz
+ http://moinejf.free.fr/transpose_abc.pl"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples pango"
+
+RDEPEND="pango? ( x11-libs/pango media-libs/freetype:2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --enable-a4 \
+ --enable-deco-is-roll \
+ $(use_enable pango)
+}
+
+src_install() {
+ dobin abcm2ps
+
+ insinto /usr/share/${PN}
+ doins *.fmt
+
+ dodoc Changes README *.txt
+
+ if use examples ; then
+ docinto examples
+ dodoc *.{abc,eps}
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ docinto contrib
+ dodoc "${DISTDIR}"/transpose_abc.pl
+}