summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-07-17 01:30:53 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-07-17 01:30:53 +0000
commitdaa4acb2b91012a4e9a08d6dbbd5d1df90abbb23 (patch)
tree5a3e3fce4f4eac562ff5e35e2d0bd8e5e20ff89b /media-plugins
parentRemove out unused files (diff)
downloadgentoo-2-daa4acb2b91012a4e9a08d6dbbd5d1df90abbb23.tar.gz
gentoo-2-daa4acb2b91012a4e9a08d6dbbd5d1df90abbb23.tar.bz2
gentoo-2-daa4acb2b91012a4e9a08d6dbbd5d1df90abbb23.zip
Version bump.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins')
-rw-r--r--media-plugins/mythplugins/ChangeLog8
-rw-r--r--media-plugins/mythplugins/mythplugins-0.25.2_p20120716.ebuild129
2 files changed, 136 insertions, 1 deletions
diff --git a/media-plugins/mythplugins/ChangeLog b/media-plugins/mythplugins/ChangeLog
index c2f6e77e37ae..090b7fe9ade1 100644
--- a/media-plugins/mythplugins/ChangeLog
+++ b/media-plugins/mythplugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/mythplugins
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.3 2012/07/12 01:51:54 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/ChangeLog,v 1.4 2012/07/17 01:30:53 cardoe Exp $
+
+*mythplugins-0.25.2_p20120716 (16 Jul 2012)
+
+ 16 Jul 2012; Doug Goldstein <cardoe@gentoo.org>
+ +mythplugins-0.25.2_p20120716.ebuild:
+ Version bump.
11 Jul 2012; Doug Goldstein <cardoe@gentoo.org> mythplugins-0.25.1.ebuild,
metadata.xml:
diff --git a/media-plugins/mythplugins/mythplugins-0.25.2_p20120716.ebuild b/media-plugins/mythplugins/mythplugins-0.25.2_p20120716.ebuild
new file mode 100644
index 000000000000..9d27c8fa4dc9
--- /dev/null
+++ b/media-plugins/mythplugins/mythplugins-0.25.2_p20120716.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/mythplugins/mythplugins-0.25.2_p20120716.ebuild,v 1.1 2012/07/17 01:30:53 cardoe Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+BACKPORTS="4e446508ec"
+MY_P=${P%_p*}
+
+inherit eutils python
+
+DESCRIPTION="Official MythTV plugins"
+HOMEPAGE="http://www.mythtv.org"
+SRC_URI="ftp://ftp.osuosl.org/pub/mythtv/${MY_P}.tar.bz2
+ ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+MYTHPLUGINS="mytharchive mythbrowser mythgallery mythgame \
+mythmusic mythnetvision mythnews mythweather"
+
+IUSE="${MYTHPLUGINS} cdda cdr exif fftw raw"
+
+DEPEND="!media-plugins/mytharchive
+ !media-plugins/mythbrowser
+ !media-plugins/mythgallery
+ !media-plugins/mythgame
+ !media-plugins/mythmovies
+ !media-plugins/mythmusic
+ !media-plugins/mythnetvision
+ !media-plugins/mythnews
+ !media-plugins/mythweather
+ =media-tv/mythtv-${PV}*[python]
+ mytharchive? (
+ app-cdr/dvd+rw-tools
+ dev-python/imaging
+ media-video/dvdauthor
+ media-video/mjpegtools[png]
+ media-video/transcode
+ virtual/cdrtools
+ )
+ mythgallery? (
+ media-libs/tiff
+ virtual/opengl
+ exif? ( >media-libs/libexif-0.6.9 )
+ raw? ( media-gfx/dcraw )
+ )
+ mythmusic? (
+ >=media-libs/flac-1.1.2
+ >=media-libs/libvorbis-1.0
+ >=media-libs/taglib-1.6
+ media-sound/lame
+ virtual/opengl
+ cdda? (
+ dev-libs/libcdio
+ cdr? ( virtual/cdrtools )
+ )
+ fftw? ( sci-libs/fftw )
+ )
+ mythnetvision? (
+ =dev-lang/python-2*[xml]
+ dev-python/lxml
+ dev-python/mysql-python
+ dev-python/oauth
+ dev-python/pycurl
+ )
+ mythweather? (
+ dev-perl/DateManip
+ dev-perl/DateTime-Format-ISO8601
+ dev-perl/ImageSize
+ dev-perl/JSON
+ dev-perl/SOAP-Lite
+ dev-perl/XML-Simple
+ dev-perl/XML-Parser
+ dev-perl/XML-SAX
+ dev-perl/XML-XPath
+ )"
+RDEPEND="${DEPEND}"
+
+REQUIRED_USE="
+ cdda? ( mythmusic )
+ cdr? ( mythmusic cdda )
+ exif? ( mythgallery )
+ fftw? ( mythmusic )
+ mythnews? ( mythbrowser )
+ raw? ( mythgallery )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ [[ -n ${BACKPORTS} ]] && \
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/patches" \
+ epatch
+
+ epatch_user
+}
+
+src_configure() {
+ ./configure \
+ --prefix=/usr \
+ --python=python2 \
+ --enable-opengl \
+ --disable-mythzoneminder \
+ $(use_enable mytharchive) \
+ $(use_enable mythbrowser) \
+ $(use_enable mythgallery) \
+ $(use_enable mythgame) \
+ $(use_enable mythmusic) \
+ $(use_enable mythnetvision) \
+ $(use_enable mythnews) \
+ $(use_enable mythweather) \
+ $(use_enable cdda cdio) \
+ $(use_enable exif) \
+ $(use_enable exif new-exif) \
+ $(use_enable raw dcraw) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+}