summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2010-05-25 09:40:32 +0000
committerChristoph Mende <angelos@gentoo.org>2010-05-25 09:40:32 +0000
commit1b3a137ab9f45402deb35642ffd88b5e592508fc (patch)
tree8f8d5ba338f0a8408cf55d597ae5348b8079da42 /media-plugins/gmpc-jamendo
parentVersion bump (diff)
downloadgentoo-2-1b3a137ab9f45402deb35642ffd88b5e592508fc.tar.gz
gentoo-2-1b3a137ab9f45402deb35642ffd88b5e592508fc.tar.bz2
gentoo-2-1b3a137ab9f45402deb35642ffd88b5e592508fc.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-plugins/gmpc-jamendo')
-rw-r--r--media-plugins/gmpc-jamendo/ChangeLog10
-rw-r--r--media-plugins/gmpc-jamendo/gmpc-jamendo-0.20.0.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/media-plugins/gmpc-jamendo/ChangeLog b/media-plugins/gmpc-jamendo/ChangeLog
index 69d3db4d1b18..02431aaef18b 100644
--- a/media-plugins/gmpc-jamendo/ChangeLog
+++ b/media-plugins/gmpc-jamendo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-plugins/gmpc-jamendo
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-jamendo/ChangeLog,v 1.3 2009/09/27 13:29:13 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-jamendo/ChangeLog,v 1.4 2010/05/25 09:40:32 angelos Exp $
+
+*gmpc-jamendo-0.20.0 (25 May 2010)
+
+ 25 May 2010; Christoph Mende <angelos@gentoo.org>
+ +gmpc-jamendo-0.20.0.ebuild:
+ Version bump
*gmpc-jamendo-0.19.0 (27 Sep 2009)
diff --git a/media-plugins/gmpc-jamendo/gmpc-jamendo-0.20.0.ebuild b/media-plugins/gmpc-jamendo/gmpc-jamendo-0.20.0.ebuild
new file mode 100644
index 000000000000..2aea0cbfdbd7
--- /dev/null
+++ b/media-plugins/gmpc-jamendo/gmpc-jamendo-0.20.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/gmpc-jamendo/gmpc-jamendo-0.20.0.ebuild,v 1.1 2010/05/25 09:40:32 angelos Exp $
+
+EAPI=2
+
+DESCRIPTION="Plugin allows you to browse and preview music available on jamendo."
+HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_JAMENDO"
+SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=media-sound/gmpc-${PV}
+ >=media-libs/libmpd-0.15.98
+ dev-db/sqlite:3
+ sys-libs/zlib
+ >=dev-libs/libxml2-2.6
+ >=x11-libs/gtk+-2.4:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-util/gob
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}