summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2013-09-17 21:20:18 +0000
committerChris Reffett <creffett@gentoo.org>2013-09-17 21:20:18 +0000
commit8004d04efa601130e6aa08efa5b6351fc44eb066 (patch)
treeb360e0072c96d41b41828f2f8ae5f2de4c9d6ebb /media-libs
parentAdd explicit dep on python-exec:0 since the package wraps the script manually. (diff)
downloadgentoo-2-8004d04efa601130e6aa08efa5b6351fc44eb066.tar.gz
gentoo-2-8004d04efa601130e6aa08efa5b6351fc44eb066.tar.bz2
gentoo-2-8004d04efa601130e6aa08efa5b6351fc44eb066.zip
Security bump wrt bug 308033.
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/lib3ds/ChangeLog9
-rw-r--r--media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/media-libs/lib3ds/ChangeLog b/media-libs/lib3ds/ChangeLog
index bc92967bd776..3f56e892c8ef 100644
--- a/media-libs/lib3ds/ChangeLog
+++ b/media-libs/lib3ds/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/lib3ds
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lib3ds/ChangeLog,v 1.19 2012/12/01 18:30:57 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lib3ds/ChangeLog,v 1.20 2013/09/17 21:20:18 creffett Exp $
+
+*lib3ds-2.0.0_rc1 (17 Sep 2013)
+
+ 17 Sep 2013; Chris Reffett <creffett@gentoo.org> +lib3ds-2.0.0_rc1.ebuild:
+ Security bump wrt bug 308033.
01 Dec 2012; Anthony G. Basile <blueness@gentoo.org> lib3ds-1.3.0.ebuild:
stable ppc64, bug #436574
diff --git a/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild b/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild
new file mode 100644
index 000000000000..15be41911407
--- /dev/null
+++ b/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lib3ds/lib3ds-2.0.0_rc1.ebuild,v 1.1 2013/09/17 21:20:18 creffett Exp $
+EAPI=5
+
+MY_PV="20080909"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="library for managing 3D-Studio Release 3 and 4 .3DS files"
+HOMEPAGE="http://code.google.com/p/lib3ds/"
+SRC_URI="http://lib3ds.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="media-libs/freeglut
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+}