summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-28 06:30:08 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-28 06:30:08 +0000
commit5f5448127b408ad278ad48de8678562b1c69d7ea (patch)
treeb34c214aa6de4d6fd9c18f9f8d8d2d1e9612a80d /media-libs/x264
parentFixed minor syntax (diff)
downloadgentoo-2-5f5448127b408ad278ad48de8678562b1c69d7ea.tar.gz
gentoo-2-5f5448127b408ad278ad48de8678562b1c69d7ea.tar.bz2
gentoo-2-5f5448127b408ad278ad48de8678562b1c69d7ea.zip
Import live ebuild from the multimedia overlay (requested by Nikoli).
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/x264')
-rw-r--r--media-libs/x264/ChangeLog7
-rw-r--r--media-libs/x264/x264-9999.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/media-libs/x264/ChangeLog b/media-libs/x264/ChangeLog
index 367048a08718..8cab42d3f716 100644
--- a/media-libs/x264/ChangeLog
+++ b/media-libs/x264/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/x264
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.49 2011/04/27 17:20:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/ChangeLog,v 1.50 2011/05/28 06:30:08 radhermit Exp $
+
+*x264-9999 (28 May 2011)
+
+ 28 May 2011; Tim Harder <radhermit@gentoo.org> +x264-9999.ebuild:
+ Import live ebuild from the multimedia overlay (requested by Nikoli).
*x264-0.0.20110426 (27 Apr 2011)
diff --git a/media-libs/x264/x264-9999.ebuild b/media-libs/x264/x264-9999.ebuild
new file mode 100644
index 000000000000..66c787501d94
--- /dev/null
+++ b/media-libs/x264/x264-9999.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/x264/x264-9999.ebuild,v 1.1 2011/05/28 06:30:08 radhermit Exp $
+
+EAPI=4
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ V_ECLASS="git-2"
+else
+ V_ECLASS="versionator"
+fi
+
+inherit multilib toolchain-funcs ${V_ECLASS}
+
+if [ "${PV#9999}" = "${PV}" ] ; then
+ MY_P="x264-snapshot-$(get_version_component_range 3)-2245"
+fi
+DESCRIPTION="A free library for encoding X264/AVC streams"
+HOMEPAGE="http://www.videolan.org/developers/x264.html"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ EGIT_REPO_URI="git://git.videolan.org/x264.git"
+ SRC_URI=""
+else
+ SRC_URI="http://ftp.videolan.org/pub/videolan/x264/snapshots/${MY_P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+fi
+IUSE="debug +threads pic static-libs"
+
+RDEPEND=""
+ASM_DEP=">=dev-lang/yasm-0.6.2"
+DEPEND="
+ amd64? ( ${ASM_DEP} )
+ x86? ( ${ASM_DEP} )
+ x86-fbsd? ( ${ASM_DEP} )
+"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S=${WORKDIR}/${MY_P}
+fi
+DOCS="AUTHORS doc/*.txt"
+
+src_configure() {
+ tc-export CC
+
+ local myconf=""
+ use debug && myconf+=" --enable-debug"
+ use static-libs && myconf+=" --enable-static"
+ use threads || myconf+=" --disable-thread"
+
+ if use x86 && use pic; then
+ myconf+=" --disable-asm"
+ fi
+
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ --disable-cli \
+ --disable-avs \
+ --disable-lavf \
+ --disable-swscale \
+ --disable-ffms \
+ --disable-gpac \
+ --enable-pic \
+ --enable-shared \
+ --extra-asflags="${ASFLAGS}" \
+ --extra-cflags="${CFLAGS}" \
+ --extra-ldflags="${LDFLAGS}" \
+ --host="${CHOST}" \
+ ${myconf} \
+ || die
+}