summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-08 21:29:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-08 21:29:03 +0000
commit2782836083e8033d59e9df32bfb7efd1bd43d38d (patch)
tree7b43f5ccafec96afca5c750cc63c8b64a73914f0 /media-libs/sdl-ttf
parentzapping fixed. (diff)
downloadgentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.tar.gz
gentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.tar.bz2
gentoo-2-2782836083e8033d59e9df32bfb7efd1bd43d38d.zip
added sdl-ttf and pygame
Diffstat (limited to 'media-libs/sdl-ttf')
-rw-r--r--media-libs/sdl-ttf/files/digest-sdl-ttf-2.0.31
-rw-r--r--media-libs/sdl-ttf/sdl-ttf-2.0.3.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/media-libs/sdl-ttf/files/digest-sdl-ttf-2.0.3 b/media-libs/sdl-ttf/files/digest-sdl-ttf-2.0.3
new file mode 100644
index 000000000000..ecfc6b0c0d45
--- /dev/null
+++ b/media-libs/sdl-ttf/files/digest-sdl-ttf-2.0.3
@@ -0,0 +1 @@
+MD5 29d12d1b883bf834c291c93f52ba8dc5 SDL_ttf-2.0.3.tar.gz
diff --git a/media-libs/sdl-ttf/sdl-ttf-2.0.3.ebuild b/media-libs/sdl-ttf/sdl-ttf-2.0.3.ebuild
new file mode 100644
index 000000000000..635e1b466ee0
--- /dev/null
+++ b/media-libs/sdl-ttf/sdl-ttf-2.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author David Creswick <davidc@sat.net>
+
+S="${WORKDIR}/SDL_ttf-${PV}"
+DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
+SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/SDL_ttf-2.0.3.tar.gz"
+HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
+
+#build-time dependencies
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/freetype-2.0.1"
+
+src_compile() {
+ ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ dodoc CHANGES COPYING README
+}