summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-02-11 07:46:50 +0000
committerMichael Weber <xmw@gentoo.org>2013-02-11 07:46:50 +0000
commitf97e8e883c3e2f7dcd5b3c0e8fbdb70b4c18b076 (patch)
treea99a79bc1f381b3c359991d43e2c0ed16d712967 /media-libs/oyranos
parentAdd the gstreamer-2012.11 SDK git snapshot of gst-plugins-ffmpeg with additio... (diff)
downloadgentoo-2-f97e8e883c3e2f7dcd5b3c0e8fbdb70b4c18b076.tar.gz
gentoo-2-f97e8e883c3e2f7dcd5b3c0e8fbdb70b4c18b076.tar.bz2
gentoo-2-f97e8e883c3e2f7dcd5b3c0e8fbdb70b4c18b076.zip
Revbump to include buildsystem patch by Benjamin Schindler, thanks to all contributors of bug 456104
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'media-libs/oyranos')
-rw-r--r--media-libs/oyranos/ChangeLog11
-rw-r--r--media-libs/oyranos/files/oyranos-0.9.1-buildsystem-2.patch22
-rw-r--r--media-libs/oyranos/oyranos-0.9.1-r1.ebuild84
3 files changed, 115 insertions, 2 deletions
diff --git a/media-libs/oyranos/ChangeLog b/media-libs/oyranos/ChangeLog
index daee22fa937a..904d189ec652 100644
--- a/media-libs/oyranos/ChangeLog
+++ b/media-libs/oyranos/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-libs/oyranos
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/ChangeLog,v 1.8 2012/11/23 21:55:30 xmw Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/ChangeLog,v 1.9 2013/02/11 07:46:50 xmw Exp $
+
+*oyranos-0.9.1-r1 (11 Feb 2013)
+
+ 11 Feb 2013; Michael Weber <xmw@gentoo.org> +oyranos-0.9.1-r1.ebuild,
+ +files/oyranos-0.9.1-buildsystem-2.patch:
+ Revbump to include buildsystem patch by Benjamin Schindler, thanks to all
+ contributors of bug 456104
23 Nov 2012; Michael Weber <xmw@gentoo.org> oyranos-0.4.0-r1.ebuild,
oyranos-0.9.0.ebuild, oyranos-0.9.1.ebuild:
diff --git a/media-libs/oyranos/files/oyranos-0.9.1-buildsystem-2.patch b/media-libs/oyranos/files/oyranos-0.9.1-buildsystem-2.patch
new file mode 100644
index 000000000000..6593f6392699
--- /dev/null
+++ b/media-libs/oyranos/files/oyranos-0.9.1-buildsystem-2.patch
@@ -0,0 +1,22 @@
+--- oyranos-0.9.1/configure_tests.sh
++++ oyranos-0.9.1/configure_tests.sh
+@@ -612,8 +612,9 @@
+ ID_LIBS="$ID"_LIBS
+ if [ -z "$found" ]; then
+ pkg-config --atleast-version=0.2 $pc_package
++ found=$?
+ if [ $? = 0 ]; then
+- found=`pkg-config --cflags $pc_package`
++ xcm_cflags=`pkg-config --cflags $pc_package`
+ version=`pkg-config --modversion $pc_package`
+ fi
+ fi
+@@ -627,7 +628,7 @@
+ if [ -n "$MAKEFILE_DIR" ]; then
+ for i in $MAKEFILE_DIR; do
+ test -f "$ROOT_DIR/$i/makefile".in && echo "XCM = 1" >> "$i/makefile"
+- test -f "$ROOT_DIR/$i/makefile".in && echo "XCM_H = $found" >> "$i/makefile"
++ test -f "$ROOT_DIR/$i/makefile".in && echo "XCM_H = $xcm_cflags" >> "$i/makefile"
+ test -f "$ROOT_DIR/$i/makefile".in && echo "$ID_LIBS = `pkg-config --libs $name | sed \"$STRIPOPT\"`" >> "$i/makefile"
+ done
+ fi
diff --git a/media-libs/oyranos/oyranos-0.9.1-r1.ebuild b/media-libs/oyranos/oyranos-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..67490aeb1328
--- /dev/null
+++ b/media-libs/oyranos/oyranos-0.9.1-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/oyranos/oyranos-0.9.1-r1.ebuild,v 1.1 2013/02/11 07:46:50 xmw Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="colour management system allowing to share various settings across applications and services"
+HOMEPAGE="http://www.oyranos.org/"
+SRC_URI="mirror://sourceforge/oyranos/Oyranos/Oyranos%200.4/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc static-libs test xinerama"
+
+RDEPEND="app-admin/elektra
+ dev-libs/libxml2
+ dev-libs/yajl
+ media-gfx/exiv2
+ media-libs/lcms:0
+ media-libs/libpng:0
+ media-libs/libraw
+ >=media-libs/libXcm-0.5.1
+ X? ( x11-libs/fltk:1
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+ xinerama? ( x11-libs/libXinerama ) )"
+DEPEND="${RDEPEND}
+ app-doc/doxygen
+ media-gfx/graphviz
+ test? ( media-libs/icc-profiles-basiccolor-printing2009
+ media-libs/icc-profiles-openicc )"
+
+RESTRICT="test"
+
+src_prepare() {
+ einfo remove bundled elektra yajl
+ rm -rf elektra* yajl || die
+ #keep bundled libXNVCtrl
+
+ epatch "${FILESDIR}"/${PN}-0.9.0-buildsystem.patch
+ epatch "${FILESDIR}"/${PN}-0.9.1-buildsystem-2.patch
+
+ if ! use X ; then
+ sed -e '/FLTK_GUI =/s:=.*:=:' \
+ -i makefile.in || die
+ fi
+
+ if has_version "<app-admin/elektra-0.8.3" ; then
+ sed -e '/^#include/s:kdb.h:elektra-kdb.h:' \
+ -i test.c test2.cpp oyranos_elektra.c || die
+ fi
+}
+
+src_configure() {
+ tc-export CC CXX
+ econf --prefix=/usr \
+ --enable-verbose \
+ $(use_with X x) \
+ $(use_enable X libX11) \
+ $(use_enable X libXext) \
+ $(use_enable X libXrandr) \
+ $(use_enable X libXxf86vm) \
+ $(use_enable X fltk) \
+ $(use_enable static-libs static) \
+ $(use_enable xinerama libXinerama)
+}
+
+src_compile() {
+ emake all
+ use X && emake oforms
+ emake docu
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}"/usr/share/doc/${P} install-main
+
+ if ! use doc ; then
+ rm -rf "${ED}/usr/share/doc/${P}/html" || die
+ fi
+}