summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-09-18 23:24:45 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-09-18 23:24:45 +0000
commit26cf88da881109cc0886ab61c8033aa9fcce650a (patch)
tree4490392ff0c9408468707a0fbb2124ea7a89b417 /media-libs/glu
parentMask glu and mesa without glu, bug #433880. (diff)
downloadgentoo-2-26cf88da881109cc0886ab61c8033aa9fcce650a.tar.gz
gentoo-2-26cf88da881109cc0886ab61c8033aa9fcce650a.tar.bz2
gentoo-2-26cf88da881109cc0886ab61c8033aa9fcce650a.zip
Import mattst88's glu ebuild from the x11 overlay.
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/glu')
-rw-r--r--media-libs/glu/ChangeLog9
-rw-r--r--media-libs/glu/glu-9.0.0.ebuild70
-rw-r--r--media-libs/glu/metadata.xml5
3 files changed, 84 insertions, 0 deletions
diff --git a/media-libs/glu/ChangeLog b/media-libs/glu/ChangeLog
new file mode 100644
index 000000000000..a0a35cd59477
--- /dev/null
+++ b/media-libs/glu/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for media-libs/glu
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/ChangeLog,v 1.1 2012/09/18 23:24:45 chithanh Exp $
+
+*glu-9.0.0 (18 Sep 2012)
+
+ 18 Sep 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +glu-9.0.0.ebuild, +metadata.xml:
+ Import mattst88's glu ebuild from the x11 overlay.
diff --git a/media-libs/glu/glu-9.0.0.ebuild b/media-libs/glu/glu-9.0.0.ebuild
new file mode 100644
index 000000000000..643f1f27ad83
--- /dev/null
+++ b/media-libs/glu/glu-9.0.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/glu/glu-9.0.0.ebuild,v 1.1 2012/09/18 23:24:45 chithanh Exp $
+
+EAPI=4
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/mesa/glu"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools-utils multilib ${GIT_ECLASS}
+
+DESCRIPTION="The OpenGL Utility Library"
+HOMEPAGE="http://cgit.freedesktop.org/mesa/glu/"
+
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ SRC_URI="ftp://ftp.freedesktop.org/pub/mesa/${PN}/${P}.tar.bz2"
+fi
+
+LICENSE="SGI-B-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="multilib static-libs"
+
+DEPEND="virtual/opengl"
+RDEPEND="${DEPEND}
+ !<=media-libs/mesa-9_pre20120831
+ multilib? ( !app-emulation/emul-linux-x86-opengl )"
+
+foreachabi() {
+ if use multilib; then
+ local ABI
+ for ABI in $(get_all_abis); do
+ multilib_toolchain_setup ${ABI}
+ AUTOTOOLS_BUILD_DIR=${WORKDIR}/${ABI} "${@}"
+ done
+ else
+ "${@}"
+ fi
+}
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-2_src_unpack
+}
+
+src_prepare() {
+ AUTOTOOLS_AUTORECONF=1 autotools-utils_src_prepare
+}
+
+src_configure() {
+ foreachabi autotools-utils_src_configure
+}
+
+src_compile() {
+ foreachabi autotools-utils_src_compile
+}
+
+src_install() {
+ foreachabi autotools-utils_src_install
+}
+
+src_test() {
+ :;
+}
diff --git a/media-libs/glu/metadata.xml b/media-libs/glu/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/media-libs/glu/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>