summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-09-14 22:48:06 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-09-14 22:48:06 +0000
commit62ec210f7866c6e46862d22ca9f419c942504e9b (patch)
treefd4a6a54cfd08397d1610fae9a0ab28c0db44010 /media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild
parentStable on amd64 wrt bug #189349 (diff)
downloadgentoo-2-62ec210f7866c6e46862d22ca9f419c942504e9b.tar.gz
gentoo-2-62ec210f7866c6e46862d22ca9f419c942504e9b.tar.bz2
gentoo-2-62ec210f7866c6e46862d22ca9f419c942504e9b.zip
Added a patch from Michal Januszewski <spock@gentoo.org> to fix an icon cycling issue. This closes bug #182065.
(Portage version: 2.1.3.7)
Diffstat (limited to 'media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild')
-rw-r--r--media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild b/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild
new file mode 100644
index 000000000000..fc2abad71b7c
--- /dev/null
+++ b/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/splash-themes-livecd/splash-themes-livecd-2007.0-r1.ebuild,v 1.1 2007/09/14 22:48:06 wolf31o2 Exp $
+
+inherit eutils
+
+MY_P="gentoo-livecd-${PV}"
+MY_REV="0.9.5"
+DESCRIPTION="Gentoo theme for gensplash consoles"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${MY_P}-${MY_REV}.tar.bz2"
+
+SLOT=${PV}
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+RESTRICT="binchecks strip"
+
+DEPEND=">=media-gfx/splashutils-1.4.1"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ if ! built_with_use media-gfx/splashutils mng
+ then
+ ewarn "MNG support is missing from splashutils. You will not see the"
+ ewarn "service icons as services are starting."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i -e 's-/sbin/functions.sh-/etc/init.d/functions.sh-' \
+ scripts/rc_init-pre
+ epatch "${FILESDIR}"/${P}-rounding.patch
+}
+
+src_install() {
+ dodir /etc/splash/livecd-${PV}
+ cp -r ${S}/* ${D}/etc/splash/livecd-${PV}
+}