summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-10-11 21:07:13 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-10-11 21:07:13 +0000
commitde8b060162e0da0744836c4c2e9fe557988fddf0 (patch)
tree84f8b6b5300180b1ce3b1e068253030cd7e1c034 /media-gfx/mypaint
parentbump (diff)
downloadgentoo-2-de8b060162e0da0744836c4c2e9fe557988fddf0.tar.gz
gentoo-2-de8b060162e0da0744836c4c2e9fe557988fddf0.tar.bz2
gentoo-2-de8b060162e0da0744836c4c2e9fe557988fddf0.zip
Respect all compiler flags. Drop static lib and pkgconfig file. Multiple other fixes by Nikoli. Bug #452456
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'media-gfx/mypaint')
-rw-r--r--media-gfx/mypaint/ChangeLog10
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch53
-rw-r--r--media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch24
-rw-r--r--media-gfx/mypaint/mypaint-1.1.0-r1.ebuild88
4 files changed, 174 insertions, 1 deletions
diff --git a/media-gfx/mypaint/ChangeLog b/media-gfx/mypaint/ChangeLog
index 033933bf55da..36f248db92a0 100644
--- a/media-gfx/mypaint/ChangeLog
+++ b/media-gfx/mypaint/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/mypaint
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/ChangeLog,v 1.22 2013/04/26 17:54:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/ChangeLog,v 1.23 2013/10/11 21:07:13 hwoarang Exp $
+
+*mypaint-1.1.0-r1 (11 Oct 2013)
+
+ 11 Oct 2013; Markos Chandras <hwoarang@gentoo.org>
+ +files/mypaint-1.1.0-build-env-vars.patch, +files/mypaint-1.1.0-desktop.patch,
+ +mypaint-1.1.0-r1.ebuild:
+ Respect all compiler flags. Drop static lib and pkgconfig file. Multiple other
+ fixes by Nikoli. Bug #452456
26 Apr 2013; Markos Chandras <hwoarang@gentoo.org>
+files/mypaint-1.1.0-json-c-0.11.patch, mypaint-1.1.0.ebuild:
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch b/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch
new file mode 100644
index 000000000000..7d7ac3e36359
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-build-env-vars.patch
@@ -0,0 +1,53 @@
+From 516d184b5db8ebdd8b184ef871050c3ab3f03fdf Mon Sep 17 00:00:00 2001
+From: Andrew Chadwick <andrewc-git@piffle.org>
+Date: Sun, 21 Apr 2013 22:51:05 +0100
+Subject: [PATCH] SConstruct: support standard build environ vars
+
+Support the standard build environment vars CC, CXX, CFLAGS, CXXFLAGS,
+CPPFLAGS, and LDFLAGS everywhere.
+
+Partially addresses https://gna.org/bugs/?20754
+---
+ SConstruct | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
+
+diff --git a/SConstruct b/SConstruct
+index 0b55da1..ef39b9e 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -1,6 +1,7 @@
+ import os, sys
+ from os.path import join, basename
+ from SCons.Script.SConscript import SConsEnvironment
++import SCons.Util
+
+ EnsureSConsVersion(1, 0)
+
+@@ -45,6 +46,24 @@ print('using %r (use scons python_config=xxx to change)' % env['python_config'])
+ if sys.platform == "win32":
+ # remove this mingw if trying VisualStudio
+ env = Environment(tools=tools + ['mingw'], ENV=os.environ, options=opts)
++
++# Respect some standard build environment stuff
++if os.environ.has_key('CC'):
++ env['CC'] = os.environ['CC']
++if os.environ.has_key('CFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CFLAGS'])
++if os.environ.has_key('CXX'):
++ env['CXX'] = os.environ['CXX']
++if os.environ.has_key('CXXFLAGS'):
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CXXFLAGS'])
++if os.environ.has_key('CPPFLAGS'):
++ env['CCFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
++ env['CXXFLAGS'] += SCons.Util.CLVar(os.environ['CPPFLAGS'])
++if os.environ.has_key('LDFLAGS'):
++ env['LINKFLAGS'] += SCons.Util.CLVar(os.environ['LDFLAGS'])
++if "$CCFLAGS" in env['CXXCOM']:
++ env['CXXCOM'] = env['CXXCOM'].replace("$CCFLAGS","")
++
+ opts.Update(env)
+
+ env.Append(CXXFLAGS=' -Wall -Wno-sign-compare -Wno-write-strings')
+--
+1.7.10.4
+
diff --git a/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch b/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch
new file mode 100644
index 000000000000..b992131bf29e
--- /dev/null
+++ b/media-gfx/mypaint/files/mypaint-1.1.0-desktop.patch
@@ -0,0 +1,24 @@
+From: Andrew Chadwick <andrewc-git@piffle.org>
+Date: Tue, 8 Jan 2013 13:53:01 +0000
+Subject: desktop: remove deprecated Encoding key
+
+The Encoding key is deprecated as of 1.0 of the Desktop Entry Specification
+(8 Jan 2012)
+
+http://standards.freedesktop.org/desktop-entry-spec/1.0/apc.html
+---
+ desktop/mypaint.desktop | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/desktop/mypaint.desktop b/desktop/mypaint.desktop
+index 9850b54..24383db 100644
+--- a/desktop/mypaint.desktop
++++ b/desktop/mypaint.desktop
+@@ -1,6 +1,5 @@
+ [Desktop Entry]
+ Version=1.0
+-Encoding=UTF-8
+ Name=MyPaint
+ TryExec=mypaint
+ Exec=mypaint %f
+--
diff --git a/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild b/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..dcdcc4812233
--- /dev/null
+++ b/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/mypaint/mypaint-1.1.0-r1.ebuild,v 1.1 2013/10/11 21:07:13 hwoarang Exp $
+
+EAPI=5
+
+PYTHON_DEPEND="2:2.5"
+
+inherit eutils fdo-mime gnome2-utils multilib scons-utils toolchain-funcs python
+
+DESCRIPTION="fast and easy graphics application for digital painters"
+HOMEPAGE="http://mypaint.intilinux.com/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="cs de en_CA en_GB es fr hu id it ja ko nb nn_NO pl pt_BR ro ru sl sv uk zh_CN zh_TW"
+for x in ${LANGS}; do
+ IUSE+="linguas_${x} "
+done
+
+RDEPEND="
+ dev-python/pygtk:2
+ dev-python/numpy
+ >=dev-python/pycairo-1.4
+ dev-libs/protobuf[python]
+ >=dev-libs/json-c-0.11:=
+ media-libs/lcms:2
+ media-libs/libpng:0=
+"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ virtual/pkgconfig"
+
+pkg_setup(){
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # multilib support
+ sed -i -e "s:lib\/${PN}:$(get_libdir)\/${PN}:" \
+ SConstruct SConscript || die
+ # respect CXXFLAGS,CXX,LDFLAGS
+ epatch "${FILESDIR}"/${P}-build-env-vars.patch
+ # fix mypaint.desktop
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ # pkgconfig patch for json-c-0.11. 467322
+ epatch "${FILESDIR}"/${P}-json-c-0.11.patch
+}
+
+src_compile() {
+ #workaround scons bug with locales. Bug #352700
+ export LANG="en_US.UTF-8"
+ tc-export CC CXX
+ escons
+}
+
+src_install () {
+ escons prefix="${D}/usr" install
+ newicon pixmaps/${PN}_logo.png ${PN}.png
+ for x in ${LANGS}; do
+ if ! has ${x} ${LINGUAS}; then
+ rm -rf "${ED}"/usr/share/locale/${x} || die
+ fi
+ done
+
+ # not used and broken
+ rm -rf "${ED}"/usr/{include/,lib/libmypaint.a,lib/pkgconfig/} || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ python_mod_cleanup /usr/share/${PN}
+}