summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-02-03 15:58:55 +0000
committerJohannes Huber <johu@gentoo.org>2012-02-03 15:58:55 +0000
commit6bab94c0e838ea2195a24b0ce5ef062c25988ffe (patch)
tree0907309fb76d7ab44584b530e2a1a17e017d7553 /kde-base
parentAdd upstream patch by Michael Palimaka <kde@scribeofthenile.com>, to make pam... (diff)
downloadgentoo-2-6bab94c0e838ea2195a24b0ce5ef062c25988ffe.tar.gz
gentoo-2-6bab94c0e838ea2195a24b0ce5ef062c25988ffe.tar.bz2
gentoo-2-6bab94c0e838ea2195a24b0ce5ef062c25988ffe.zip
Revision bump. Removes pam patch which has no effect. Is fixed in kde-base/libkworkspace bug #398333.
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kcheckpass/ChangeLog10
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.7.4-r1.ebuild36
-rw-r--r--kde-base/kcheckpass/kcheckpass-4.8.0-r1.ebuild (renamed from kde-base/kcheckpass/kcheckpass-4.8.0.ebuild)6
3 files changed, 46 insertions, 6 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index f82b4255f404..df0ddbc7dd3b 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.209 2012/01/25 18:16:51 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.210 2012/02/03 15:58:55 johu Exp $
+
+*kcheckpass-4.8.0-r1 (03 Feb 2012)
+*kcheckpass-4.7.4-r1 (03 Feb 2012)
+
+ 03 Feb 2012; Johannes Huber <johu@gentoo.org> +kcheckpass-4.7.4-r1.ebuild,
+ +kcheckpass-4.8.0-r1.ebuild, -kcheckpass-4.8.0.ebuild:
+ Revision bump. Removes pam patch which has no effect. Is fixed in kde-
+ base/libkworkspace bug #398333.
*kcheckpass-4.8.0 (25 Jan 2012)
diff --git a/kde-base/kcheckpass/kcheckpass-4.7.4-r1.ebuild b/kde-base/kcheckpass/kcheckpass-4.7.4-r1.ebuild
new file mode 100644
index 000000000000..c5f67f299cab
--- /dev/null
+++ b/kde-base/kcheckpass/kcheckpass-4.7.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.7.4-r1.ebuild,v 1.1 2012/02/03 15:58:55 johu Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="A simple password checker, used by any software in need of user authentication."
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug pam"
+
+RDEPEND="
+ pam? (
+ >=kde-base/kdebase-pam-7
+ virtual/pam
+ )
+"
+DEPEND="${RDEPEND}
+ x11-libs/libxkbfile
+"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ use pam && epatch "${FILESDIR}/${PN}-4.4.2-no-SUID-no-GUID.patch"
+}
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with pam)
+ )
+
+ kde4-meta_src_configure
+}
diff --git a/kde-base/kcheckpass/kcheckpass-4.8.0.ebuild b/kde-base/kcheckpass/kcheckpass-4.8.0-r1.ebuild
index 19b642c852af..44df64d31de6 100644
--- a/kde-base/kcheckpass/kcheckpass-4.8.0.ebuild
+++ b/kde-base/kcheckpass/kcheckpass-4.8.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.8.0.ebuild,v 1.1 2012/01/25 18:16:51 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-4.8.0-r1.ebuild,v 1.1 2012/02/03 15:58:55 johu Exp $
EAPI=4
@@ -21,10 +21,6 @@ DEPEND="${RDEPEND}
x11-libs/libxkbfile
"
-PATCHES=(
- "${FILESDIR}/kdebase-4.0.2-pam-optional.patch"
-)
-
src_prepare() {
kde4-meta_src_prepare