summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:35:01 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:35:01 +0000
commit937b821d3c0b581b2fa24b461cfb484672341b43 (patch)
tree37968bc821afb9bbb4b14f1b11e4de8360abac9b /kde-base/qtruby/qtruby-3.5.9.ebuild
parentVersion bump to KDE 3.5.9. (diff)
downloadgentoo-2-937b821d3c0b581b2fa24b461cfb484672341b43.tar.gz
gentoo-2-937b821d3c0b581b2fa24b461cfb484672341b43.tar.bz2
gentoo-2-937b821d3c0b581b2fa24b461cfb484672341b43.zip
Version bump to KDE 3.5.9.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/qtruby/qtruby-3.5.9.ebuild')
-rw-r--r--kde-base/qtruby/qtruby-3.5.9.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/qtruby/qtruby-3.5.9.ebuild b/kde-base/qtruby/qtruby-3.5.9.ebuild
new file mode 100644
index 000000000000..aa794ade56a3
--- /dev/null
+++ b/kde-base/qtruby/qtruby-3.5.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qtruby/qtruby-3.5.9.ebuild,v 1.1 2008/02/20 23:35:01 philantrop Exp $
+
+KMNAME=kdebindings
+KMCOPYLIB="libsmokeqt smoke/qt"
+KM_MAKEFILESREV=1
+EAPI="1"
+inherit kde-meta
+
+DESCRIPTION="Ruby bindings for QT"
+HOMEPAGE="http://developer.kde.org/language-bindings/ruby/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/ruby-1.8
+>=kde-base/smoke-${PV}:${SLOT}"
+
+PATCHES="${FILESDIR}/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/ruby/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely.
+# Note that it still depends on a specific range of (slotted) smoke versions.
+SLOT="0"
+
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}