summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-20 11:01:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-10-20 11:01:46 +0000
commit351c86e9f61252c59390e984d5945b9304fac542 (patch)
tree2742fc76e2278745e357d7f819ce01008619fb5a /kde-base/kcheckpass
parentPunted ftpusers as ftpbase supplies it (diff)
downloadgentoo-2-351c86e9f61252c59390e984d5945b9304fac542.tar.gz
gentoo-2-351c86e9f61252c59390e984d5945b9304fac542.tar.bz2
gentoo-2-351c86e9f61252c59390e984d5945b9304fac542.zip
Added patch to compile kcheckpass fine on PIC architectures when using --enable-final. See bug #107218.
(Portage version: 2.0.53_rc5)
Diffstat (limited to 'kde-base/kcheckpass')
-rw-r--r--kde-base/kcheckpass/ChangeLog7
-rw-r--r--kde-base/kcheckpass/files/kcheckpass-pie-final.patch20
-rw-r--r--kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild6
3 files changed, 31 insertions, 2 deletions
diff --git a/kde-base/kcheckpass/ChangeLog b/kde-base/kcheckpass/ChangeLog
index ae568afbcb13..7e109265a26e 100644
--- a/kde-base/kcheckpass/ChangeLog
+++ b/kde-base/kcheckpass/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcheckpass
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.20 2005/10/15 11:08:40 greg_g Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/ChangeLog,v 1.21 2005/10/20 11:01:46 flameeyes Exp $
+
+ 20 Oct 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kcheckpass-pie-final.patch, kcheckpass-3.5.0_beta2.ebuild:
+ Added patch to compile kcheckpass fine on PIC architectures when using
+ --enable-final. See bug #107218.
*kcheckpass-3.5.0_beta2 (14 Oct 2005)
diff --git a/kde-base/kcheckpass/files/kcheckpass-pie-final.patch b/kde-base/kcheckpass/files/kcheckpass-pie-final.patch
new file mode 100644
index 000000000000..3ae34a4d6724
--- /dev/null
+++ b/kde-base/kcheckpass/files/kcheckpass-pie-final.patch
@@ -0,0 +1,20 @@
+Index: Makefile.am
+===================================================================
+--- kcheckpass/Makefile.am (revision 472230)
++++ kcheckpass/Makefile.am (revision 472231)
+@@ -2,14 +2,13 @@
+ ## written by Christian Esken
+ ##
+
+-INCLUDES= $(all_includes)
++INCLUDES= $(KDE_USE_FPIE) $(all_includes)
+
+ bin_PROGRAMS = kcheckpass
+
+ kcheckpass_SOURCES = kcheckpass.c \
+ checkpass_etcpasswd.c checkpass_pam.c checkpass_shadow.c \
+ checkpass_osfc2passwd.c checkpass_aix.c
+-kcheckpass_CFLAGS = $(KDE_USE_FPIE)
+ kcheckpass_LDADD = -lkdefakes $(PASSWDLIBS) $(LIBSOCKET)
+ kcheckpass_LDFLAGS = $(KDE_USE_PIE) $(all_libraries)
+
diff --git a/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild b/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
index a963da350985..b3b0214ed3d6 100644
--- a/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
+++ b/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild,v 1.1 2005/10/14 18:41:50 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcheckpass/kcheckpass-3.5.0_beta2.ebuild,v 1.2 2005/10/20 11:01:46 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -12,3 +12,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="pam"
DEPEND="pam? ( kde-base/kdebase-pam ) !pam? ( sys-apps/shadow )"
+# Fixes problem with PIE and kcheckpass with --enable-final on PIC plaforms
+# Already applied for 3.5 RC.
+PATCHES="${FILESDIR}/${PN}-pie-final.patch"
+