summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
committerJohannes Huber <johu@gentoo.org>2014-04-01 18:10:05 +0000
commitb0c8c41397c5a2e84e4a1126a6ac202205014ee7 (patch)
tree1c82eef4e9829216eda4b7a814332e668a7afcea /kde-base/dolphin-plugins
parentVersion bump to snapshot version since there are a lot of fixes and upstream ... (diff)
downloadgentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.gz
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.tar.bz2
gentoo-2-b0c8c41397c5a2e84e4a1126a6ac202205014ee7.zip
Version bump KDE SC 4.12.4
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog7
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.12.4.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 3200f72a4629..3a91a1d17107 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.143 2014/03/11 13:06:47 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.144 2014/04/01 18:09:38 johu Exp $
+
+*dolphin-plugins-4.12.4 (01 Apr 2014)
+
+ 01 Apr 2014; Johannes Huber <johu@gentoo.org> +dolphin-plugins-4.12.4.ebuild:
+ Version bump KDE SC 4.12.4
11 Mar 2014; Johannes Huber <johu@gentoo.org> -dolphin-plugins-4.12.2.ebuild:
Remove KDE SC 4.12.2
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.12.4.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.12.4.ebuild
new file mode 100644
index 000000000000..06cafb5d0d9f
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.12.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.12.4.ebuild,v 1.1 2014/04/01 18:09:38 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug bazaar git mercurial subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ bazaar? ( dev-vcs/bzr )
+ git? ( dev-vcs/git )
+ mercurial? ( dev-vcs/mercurial )
+ subversion? ( dev-vcs/subversion )
+"
+
+src_install() {
+ { use bazaar || use git || use mercurial || use subversion; } && kde4-base_src_install
+}
+
+pkg_postinst() {
+ if ! use bazaar && ! use git && ! use mercurial && ! use subversion ; then
+ einfo
+ einfo "You have disabled all plugin use flags. If you want to have vcs"
+ einfo "integration in dolphin, enable those of your needs."
+ einfo
+ fi
+}