summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-12 14:09:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-12 14:09:39 +0000
commit61f10550a2fa470dd4bbcb096c5ba6bba55c61b4 (patch)
tree9dc16844adecc8eb9e436e78b9702d6deab13acc /games-strategy/tornado
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-61f10550a2fa470dd4bbcb096c5ba6bba55c61b4.tar.gz
gentoo-2-61f10550a2fa470dd4bbcb096c5ba6bba55c61b4.tar.bz2
gentoo-2-61f10550a2fa470dd4bbcb096c5ba6bba55c61b4.zip
Fix --as-needed bug #247508
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-strategy/tornado')
-rw-r--r--games-strategy/tornado/ChangeLog8
-rw-r--r--games-strategy/tornado/files/tornado-1.3-gentoo.patch26
-rw-r--r--games-strategy/tornado/tornado-1.3.ebuild20
3 files changed, 39 insertions, 15 deletions
diff --git a/games-strategy/tornado/ChangeLog b/games-strategy/tornado/ChangeLog
index 68511e1df9e5..72b930579191 100644
--- a/games-strategy/tornado/ChangeLog
+++ b/games-strategy/tornado/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/tornado
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/ChangeLog,v 1.11 2007/02/08 22:27:48 wolf31o2 Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/ChangeLog,v 1.12 2009/02/12 14:09:39 tupone Exp $
+
+ 12 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/tornado-1.3-gentoo.patch, tornado-1.3.ebuild:
+ Fix --as-needed bug #247508 by flameeyes@gentoo.org
08 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/games-strategy/tornado/files/tornado-1.3-gentoo.patch b/games-strategy/tornado/files/tornado-1.3-gentoo.patch
new file mode 100644
index 000000000000..fb8966841158
--- /dev/null
+++ b/games-strategy/tornado/files/tornado-1.3-gentoo.patch
@@ -0,0 +1,26 @@
+--- Makefile.old 2009-02-12 12:42:25.000000000 +0100
++++ Makefile 2009-02-12 12:44:52.000000000 +0100
+@@ -1,10 +1,9 @@
+-CC = gcc
+ MAKE = make
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+ OBJFILES = main.o draw.o erwin.o network.o scores.o
+-PREFIX = /usr/local
+-LOCALEPATH = /usr/local/share/locale
+-CFLAGS = -Wall -O2 -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
++PREFIX = /usr
++LOCALEPATH = /usr/share/locale
++CFLAGS += -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
+ VERSION = `grep " VERSION" version.h | sed s/\"//g | sed s/\#define\ VERSION\ //`
+ LOCALES = de
+ MAN = doc/man
+@@ -25,7 +24,7 @@
+ $(MAKE) -C $(MAN) all
+
+ tornado: $(OBJFILES)
+- $(CC) $(LDFLAGS) $(OBJFILES) -o tornado
++ $(CC) $(LDFLAGS) $(OBJFILES) $(LDLIBS) -o tornado
+
+ debug: tornado.6 locales
+ gcc -g -ggdb -Wall -ansi -pedantic -o tornado draw.c main.c erwin.c network.c scores.c -lncurses -DPREFIX="\"$(PREFIX)\"" -DLOCALEPATH="\"$(LOCALEPATH)\""
diff --git a/games-strategy/tornado/tornado-1.3.ebuild b/games-strategy/tornado/tornado-1.3.ebuild
index fecf25abaaba..44c161358463 100644
--- a/games-strategy/tornado/tornado-1.3.ebuild
+++ b/games-strategy/tornado/tornado-1.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/tornado-1.3.ebuild,v 1.6 2007/04/18 01:36:36 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/tornado/tornado-1.3.ebuild,v 1.7 2009/02/12 14:09:39 tupone Exp $
-inherit games
+EAPI=2
+inherit eutils games
DESCRIPTION="Clone of a C64 game - destroy the opponent's house"
HOMEPAGE="http://home.kcore.de/~kiza/linux/tornado/"
@@ -13,23 +14,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=">=sys-libs/ncurses-5.3"
+DEPEND=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- sed -i \
- -e "s:/usr/local:/usr:" \
- -e "s:-O2:${CFLAGS}:" \
- Makefile \
- || die "sed failed"
+src_prepare() {
sed -i \
-e "s:PREFIX/bin:${GAMES_BINDIR}:" \
-e "s:PREFIX/man:/usr/man:" \
-e "s:/usr/local:/usr:" \
doc/man/tornado.6.in \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
}
src_install() {