summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-10-17 01:39:31 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-10-17 01:39:31 +0000
commitca61465904ffb1007d3b3a0ae735d98051caa627 (patch)
tree0c25b44faac72ea37778975c63c3a94d3d7f26b9 /games-sports/trigger
parentFix data loading (diff)
downloadgentoo-2-ca61465904ffb1007d3b3a0ae735d98051caa627.tar.gz
gentoo-2-ca61465904ffb1007d3b3a0ae735d98051caa627.tar.bz2
gentoo-2-ca61465904ffb1007d3b3a0ae735d98051caa627.zip
Use autotools eclass; fix dependencies
(Portage version: 2.1.2_pre3-r2)
Diffstat (limited to 'games-sports/trigger')
-rw-r--r--games-sports/trigger/ChangeLog5
-rw-r--r--games-sports/trigger/trigger-0.5.2-r1.ebuild34
2 files changed, 20 insertions, 19 deletions
diff --git a/games-sports/trigger/ChangeLog b/games-sports/trigger/ChangeLog
index e1ff5b43a2e9..b315f3ee30ad 100644
--- a/games-sports/trigger/ChangeLog
+++ b/games-sports/trigger/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-sports/trigger
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.14 2006/07/23 03:36:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/ChangeLog,v 1.15 2006/10/17 01:39:31 nyhm Exp $
+
+ 17 Oct 2006; Tristan Heaven <nyhm@gentoo.org> trigger-0.5.2-r1.ebuild:
+ Use autotools eclass; fix dependencies
23 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+files/trigger-0.5.2-physfs.patch, trigger-0.5.2.ebuild,
diff --git a/games-sports/trigger/trigger-0.5.2-r1.ebuild b/games-sports/trigger/trigger-0.5.2-r1.ebuild
index 73eeead06d79..7a6a0bc3bb1e 100644
--- a/games-sports/trigger/trigger-0.5.2-r1.ebuild
+++ b/games-sports/trigger/trigger-0.5.2-r1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.5.2-r1.ebuild,v 1.5 2006/07/23 03:36:30 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/trigger/trigger-0.5.2-r1.ebuild,v 1.6 2006/10/17 01:39:31 nyhm Exp $
-inherit eutils games
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit autotools eutils games
DESCRIPTION="Free OpenGL rally car racing game"
HOMEPAGE="http://www.positro.net/trigger/"
@@ -15,21 +17,17 @@ KEYWORDS="~amd64 ~ppc x86"
IUSE=""
RDEPEND="virtual/opengl
- || (
- ( x11-libs/libX11 )
- virtual/x11 )
- >=media-libs/libsdl-1.2.5
- >=media-libs/sdl-image-1.2
+ virtual/glu
+ x11-libs/libX11
+ x11-libs/libXt
+ media-libs/libsdl
+ media-libs/sdl-image
media-libs/sdl-mixer
- ~media-libs/openal-0.0.8
+ media-libs/openal
media-libs/freealut
dev-games/physfs"
DEPEND="${RDEPEND}
- || (
- ( x11-libs/libXt
- x11-proto/xproto )
- virtual/x11
- )
+ x11-proto/xproto
dev-util/jam"
S=${WORKDIR}/${P}-src
@@ -46,11 +44,10 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-freealut.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-physfs.patch
-
+ AT_M4DIR=mk/autoconf eautoreconf
}
src_compile() {
- ./autogen.sh
egamesconf --datadir="${GAMES_DATADIR}/${PN}" || die
jam || die "jam failed"
}
@@ -60,7 +57,8 @@ src_install() {
cd ../${P}-data
insinto "${GAMES_DATADIR}/${PN}"
- doins -r events maps plugins sounds textures vehicles trigger.config.defs
+ doins -r events maps plugins sounds textures vehicles trigger.config.defs \
+ || die "doins failed"
dodoc README.txt README-stereo.txt
prepgamesdirs
@@ -68,7 +66,7 @@ src_install() {
pkg_postinst() {
games_pkg_postinst
- einfo "After running ${PN} for the first time, a config file is"
- einfo "available in ~/.trigger/trigger.config"
+ elog "After running ${PN} for the first time, a config file is"
+ elog "available in ~/.trigger/trigger.config"
echo
}