summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:26:35 +0000
commit47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b (patch)
treefb3668b891be6dd444a1643d20573e4224e149a3 /games-sports/race
parentsimulation games (diff)
downloadgentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.tar.gz
gentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.tar.bz2
gentoo-2-47f8ba0ac8d1440ebaa74200e3af6b6777be5f1b.zip
sports games !
Diffstat (limited to 'games-sports/race')
-rw-r--r--games-sports/race/ChangeLog8
-rw-r--r--games-sports/race/Manifest4
-rw-r--r--games-sports/race/files/0.5-gentoo.patch107
-rw-r--r--games-sports/race/files/digest-race-0.51
-rw-r--r--games-sports/race/race-0.5.ebuild43
5 files changed, 163 insertions, 0 deletions
diff --git a/games-sports/race/ChangeLog b/games-sports/race/ChangeLog
new file mode 100644
index 000000000000..9640da71254d
--- /dev/null
+++ b/games-sports/race/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-games/race
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/ChangeLog,v 1.1 2003/09/11 12:26:35 vapier Exp $
+
+*race-0.5 (30 Jul 2003)
+
+ 30 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-sports/race/Manifest b/games-sports/race/Manifest
new file mode 100644
index 000000000000..dce732265152
--- /dev/null
+++ b/games-sports/race/Manifest
@@ -0,0 +1,4 @@
+MD5 670bc20849dedca09c980cb7bc67114f race-0.5.ebuild 972
+MD5 f7ccf6058ee9a01cfbd5e475d8c2e834 files/digest-race-0.5 61
+MD5 e8ca685e0adb1972e290852a3583ca47 files/0.5-gentoo.patch 3224
+MD5 4b499efd82a61c36972b793d0398c14e ChangeLog 330
diff --git a/games-sports/race/files/0.5-gentoo.patch b/games-sports/race/files/0.5-gentoo.patch
new file mode 100644
index 000000000000..0aa35c4ad7b6
--- /dev/null
+++ b/games-sports/race/files/0.5-gentoo.patch
@@ -0,0 +1,107 @@
+--- src/game.c.orig 2003-07-30 15:21:48.000000000 -0400
++++ src/game.c 2003-07-30 15:22:29.000000000 -0400
+@@ -39,10 +39,10 @@
+ player.z = -1000;
+
+ debugf("Reset Player Variables");
+- playmusic("data/music/fuck.xm");
++ playmusic("GENTOO_DATADIR/music/fuck.xm");
+ newgame = 0;
+ timestart = SDL_GetTicks();
+- printf("\nLoaded Map:\n %s (data/%s)\n %s\n\n",
++ printf("\nLoaded Map:\n %s (GENTOO_DATADIR/%s)\n %s\n\n",
+ course[loadc].name, course[loadc].dir,
+ course[loadc].description);
+
+--- src/menu.c.orig 2003-07-30 15:21:57.000000000 -0400
++++ src/menu.c 2003-07-30 15:23:19.000000000 -0400
+@@ -28,7 +28,7 @@
+
+ int initmenu(void){
+
+- playmusic("data/music/lktheme.mod");
++ playmusic("GENTOO_DATADIR/music/lktheme.mod");
+
+ return 1;
+ }
+@@ -114,13 +114,13 @@
+ loadc = COURSES-1;
+ else
+ loadc--;
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+
+ case 2:
+ SDL_WM_ToggleFullScreen(surface);
+ fullscreen = 0;
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+ default:
+ break;
+@@ -133,12 +133,12 @@
+ loadc = 0;
+ else
+ loadc++;
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+ case 2:
+ fullscreen = 0;
+ SDL_WM_ToggleFullScreen(surface);
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+ default:
+ break;
+@@ -149,14 +149,14 @@
+ menuitem = MENU_ITEMS-1;
+ else
+ menuitem--;
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+ case SDLK_DOWN:
+ if(menuitem == MENU_ITEMS-1)
+ menuitem = 0;
+ else
+ menuitem++;
+- playsound("data/sounds/menu.wav",0);
++ playsound("GENTOO_DATADIR/sounds/menu.wav",0);
+ break;
+ case SDLK_q:
+ killgame(1);
+--- src/terrain.c.orig 2003-07-30 15:22:01.000000000 -0400
++++ src/terrain.c 2003-07-30 15:22:46.000000000 -0400
+@@ -36,7 +36,7 @@
+
+ debugf("Started Loading Map (%s)",course->dir);
+
+- sprintf(temp,"data/%s/%s",course->dir,"map.bmp");
++ sprintf(temp,"GENTOO_DATADIR/%s/%s",course->dir,"map.bmp");
+
+ if(!(mapimg = IMG_Load(temp)))
+ error("Missing Level Data");
+--- src/textures.c.orig 2003-07-30 15:22:06.000000000 -0400
++++ src/textures.c 2003-07-30 15:22:52.000000000 -0400
+@@ -35,7 +35,7 @@
+ SDL_Surface *image;
+ char location[6+strlen(dir)+strlen(file)];
+
+- sprintf(location,"data/%s/%s",dir,file);
++ sprintf(location,"GENTOO_DATADIR/%s/%s",dir,file);
+
+ if((image = IMG_Load(location))){
+ glGenTextures(1, &texture[id]);
+--- src/main.c.orig 2003-07-30 15:25:48.000000000 -0400
++++ src/main.c 2003-07-30 15:26:10.000000000 -0400
+@@ -75,7 +75,7 @@
+
+ printf("%s version %s\nCopyleft foobar and judeo (See COPYING for info)\n",TITLE,VERSION);
+
+- loadconfig("config");
++ loadconfig("GENTOO_CONFDIR/race.conf");
+
+ if(!initsdl()) error("SDL Loading Failed");
+ else printf(" Loaded: SDL\n");
diff --git a/games-sports/race/files/digest-race-0.5 b/games-sports/race/files/digest-race-0.5
new file mode 100644
index 000000000000..63fe29ccc320
--- /dev/null
+++ b/games-sports/race/files/digest-race-0.5
@@ -0,0 +1 @@
+MD5 9f6efbe1b1a7969a9e8d718d691b4095 race-0.5.tar.bz2 550872
diff --git a/games-sports/race/race-0.5.ebuild b/games-sports/race/race-0.5.ebuild
new file mode 100644
index 000000000000..a253e194b489
--- /dev/null
+++ b/games-sports/race/race-0.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.1 2003/09/11 12:26:35 vapier Exp $
+
+inherit games gcc eutils
+
+DESCRIPTION="OpenGL Racing Game"
+HOMEPAGE="http://projectz.org/?id=70"
+SRC_URI="ftp://users.freebsd.org.uk/pub/foobar2k/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:g" \
+ -e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}:g" \
+ *.c
+}
+
+src_compile() {
+ emake CC="$(gcc-getCC) ${CFLAGS}" || die
+}
+
+src_install() {
+ dogamesbin race
+ insinto ${GAMES_SYSCONFDIR}
+ newins config race.conf
+ dodir ${GAMES_DATADIR}/${PN}
+ mv data/* ${D}/${GAMES_DATADIR}/${PN}/
+ dodoc README
+ prepgamesdirs
+}