summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-08-07 06:45:58 +0000
committerChristoph Mende <angelos@gentoo.org>2011-08-07 06:45:58 +0000
commit822c420e5ae94fa3b776c4aa71666a41a425e1e3 (patch)
treed7ddeb318802ffb44063f9b47d6220f7099e8cc8 /games-roguelike/crossfire-client
parentFix building with libpng15 (diff)
downloadgentoo-2-822c420e5ae94fa3b776c4aa71666a41a425e1e3.tar.gz
gentoo-2-822c420e5ae94fa3b776c4aa71666a41a425e1e3.tar.bz2
gentoo-2-822c420e5ae94fa3b776c4aa71666a41a425e1e3.zip
Add missing curl dependency and fix compilation with curl-7.21.7 (bug #378035)
(Portage version: 2.2.0_alpha50/cvs/Linux x86_64)
Diffstat (limited to 'games-roguelike/crossfire-client')
-rw-r--r--games-roguelike/crossfire-client/ChangeLog8
-rw-r--r--games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild6
-rw-r--r--games-roguelike/crossfire-client/files/crossfire-client-1.12.0-curl-headers.patch12
3 files changed, 23 insertions, 3 deletions
diff --git a/games-roguelike/crossfire-client/ChangeLog b/games-roguelike/crossfire-client/ChangeLog
index 3e2bb8d0afc8..c63c07555fb6 100644
--- a/games-roguelike/crossfire-client/ChangeLog
+++ b/games-roguelike/crossfire-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/crossfire-client
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.25 2011/06/14 10:42:55 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/ChangeLog,v 1.26 2011/08/07 06:45:58 angelos Exp $
+
+ 07 Aug 2011; Christoph Mende <angelos@gentoo.org>
+ crossfire-client-1.12.0.ebuild,
+ +files/crossfire-client-1.12.0-curl-headers.patch:
+ Add missing curl dependency and fix compilation with curl-7.21.7 (bug
+ #378035)
14 Jun 2011; Tupone Alfredo <tupone@gentoo.org>
crossfire-client-1.12.0.ebuild,
diff --git a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
index cd9332209ef5..daa676c5fdb5 100644
--- a/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
+++ b/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.6 2011/06/14 10:42:55 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/crossfire-client/crossfire-client-1.12.0.ebuild,v 1.7 2011/08/07 06:45:58 angelos Exp $
EAPI=2
inherit eutils autotools games
@@ -18,6 +18,7 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
gtk? ( x11-libs/gtk+:2
sdl? ( media-libs/libsdl[video]
media-libs/sdl-image ) )
+ net-misc/curl
media-libs/freeglut
media-libs/libpng
sys-libs/zlib"
@@ -30,7 +31,8 @@ src_prepare() {
$(find . -name "*man") \
|| die "sed failed"
epatch "${FILESDIR}/${P}-lua.patch" \
- "${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-underlink.patch \
+ "${FILESDIR}"/${P}-curl-headers.patch
eautoreconf
}
diff --git a/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-curl-headers.patch b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-curl-headers.patch
new file mode 100644
index 000000000000..26f884da6ab2
--- /dev/null
+++ b/games-roguelike/crossfire-client/files/crossfire-client-1.12.0-curl-headers.patch
@@ -0,0 +1,12 @@
+diff --git a/common/metaserver.c b/common/metaserver.c
+index f963da6..0c75b11 100644
+--- a/common/metaserver.c
++++ b/common/metaserver.c
+@@ -47,7 +47,6 @@ const char * const rcsid_common_metaserver_c =
+
+ #ifdef HAVE_CURL_CURL_H
+ #include <curl/curl.h>
+-#include <curl/types.h>
+ #include <curl/easy.h>
+ #endif
+