summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-11 21:17:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-11 21:17:23 +0000
commit28969a714a42114e280cb3ea77677292bc572f92 (patch)
tree5fb80f586ba3c84d1e5bc82c60b49878bdba2228 /games-puzzle/candycrisis/candycrisis-1.0.ebuild
parentremove cstetex mask: its gone (diff)
downloadgentoo-2-28969a714a42114e280cb3ea77677292bc572f92.tar.gz
gentoo-2-28969a714a42114e280cb3ea77677292bc572f92.tar.bz2
gentoo-2-28969a714a42114e280cb3ea77677292bc572f92.zip
New package. Bug #197770
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-puzzle/candycrisis/candycrisis-1.0.ebuild')
-rw-r--r--games-puzzle/candycrisis/candycrisis-1.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-puzzle/candycrisis/candycrisis-1.0.ebuild b/games-puzzle/candycrisis/candycrisis-1.0.ebuild
new file mode 100644
index 000000000000..84b133a08d29
--- /dev/null
+++ b/games-puzzle/candycrisis/candycrisis-1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/candycrisis/candycrisis-1.0.ebuild,v 1.1 2007/12/11 21:17:22 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="An exciting combination of pure action and puzzle gaming"
+HOMEPAGE="http://candycrisis.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=""
+
+S=${WORKDIR}/CandyCrisis/Source
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}/:g" \
+ -e "s:@GENTOO_STATEDIR@:${GAMES_STATEDIR}/${PN}/:g" \
+ main.cpp prefs.cpp || die "sed failed"
+ mv ../CandyCrisisResources/Preferences.txt . \
+ || die "Move of preference file failed"
+}
+
+src_install() {
+ dogamesbin CandyCrisis || die "dogamesbin failed"
+ dodoc ../CandyCrisisReadMe.rtf
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins ../CandyCrisisResources/* || die "Installing data failed"
+ if [ ! -e "${GAMES_STATEDIR}"/${PN}/Preferences.txt ]; then
+ insinto "${GAMES_STATEDIR}"/${PN}
+ insopts -m0760
+ doins Preferences.txt || die "Installing preference file failed"
+ fi
+ newicon ../CandyCrisisResources/PICT_10000.png ${PN}.png
+ make_desktop_entry "CandyCrisis" "CandyCrisis" ${PN}.png
+ prepgamesdirs
+}