summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-01-03 22:23:10 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-01-03 22:23:10 +0000
commitc7eb662886794b495cfe2d26957967f36272468d (patch)
treee634af6f56888ca81217180455908b3f6ad27f04 /games-fps
parentRespect env AR/CC/RANLIB #446202 by Ambroz Bizjak. (diff)
downloadgentoo-2-c7eb662886794b495cfe2d26957967f36272468d.tar.gz
gentoo-2-c7eb662886794b495cfe2d26957967f36272468d.tar.bz2
gentoo-2-c7eb662886794b495cfe2d26957967f36272468d.zip
Set new repo address for live ebuild, wrt bug #449510
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3/ChangeLog7
-rw-r--r--games-fps/quake3/quake3-9999.ebuild22
2 files changed, 12 insertions, 17 deletions
diff --git a/games-fps/quake3/ChangeLog b/games-fps/quake3/ChangeLog
index b793d056a078..f7e77f46a5c7 100644
--- a/games-fps/quake3/ChangeLog
+++ b/games-fps/quake3/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quake3
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.63 2012/12/20 19:02:02 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/ChangeLog,v 1.64 2013/01/03 22:23:10 pinkbyte Exp $
+
+ 03 Jan 2013; Sergey Popov <pinkbyte@gentoo.org> quake3-9999.ebuild:
+ Set new repo address for live ebuild, wrt bug #449510
20 Dec 2012; Agostino Sarubbo <ago@gentoo.org> quake3-1.36-r1.ebuild:
Stable for amd64, wrt bug #447164
diff --git a/games-fps/quake3/quake3-9999.ebuild b/games-fps/quake3/quake3-9999.ebuild
index 0216082427ba..64055989fdb6 100644
--- a/games-fps/quake3/quake3-9999.ebuild
+++ b/games-fps/quake3/quake3-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.22 2011/05/16 15:09:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3/quake3-9999.ebuild,v 1.23 2013/01/03 22:23:10 pinkbyte Exp $
-# quake3-9999 -> latest svn
-# quake3-9999.REV -> use svn REV
-# quake3-VER_alphaREV -> svn snapshot REV for version VER
+# quake3-9999 -> latest git
+# quake3-9999.REV -> use git REV
+# quake3-VER_alphaREV -> git snapshot REV for version VER
# quake3-VER -> normal quake release
EAPI=2
inherit eutils flag-o-matic games toolchain-funcs
-[[ "${PV}" == 9999* ]] && inherit subversion
+[[ "${PV}" == 9999* ]] && inherit git-2
MY_PN="ioquake3"
MY_PV="${PV}"
@@ -18,7 +18,7 @@ MY_P="${MY_PN}-${MY_PV}"
DESCRIPTION="Quake III Arena - 3rd installment of the classic id 3D first-person shooter"
HOMEPAGE="http://ioquake3.org/"
[[ "${PV}" != 9999* ]] && SRC_URI="http://ioquake3.org/files/${MY_PV}/${MY_P}.tar.bz2"
-ESVN_REPO_URI="svn://svn.icculus.org/quake3/trunk"
+EGIT_REPO_URI="git://github.com/ioquake/ioq3.git"
LICENSE="GPL-2"
SLOT="0"
@@ -66,14 +66,6 @@ my_platform() {
esac
}
-src_prepare() {
- if [[ "${PV}" == 9999* ]] ; then
- # Workaround for the version string
- subversion_wc_info
- ln -s "${ESVN_WC_PATH}/.svn" .svn || die "ln ${ESVN_WC_PATH}/.svn"
- fi
-}
-
src_compile() {
buildit() { use $1 && echo 1 || echo 0 ; }