summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-02-23 20:23:15 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-02-23 20:23:15 +0000
commit38448c748e2a96a58e8a3a73147944754bbcefb4 (patch)
tree7b7655da5d548ae1e653c68e758f12ce78f87b17 /games-engines
parentNew ebuild for stargazer. Contributed by SpiderX. Fixes bug #452916. (diff)
downloadgentoo-2-38448c748e2a96a58e8a3a73147944754bbcefb4.tar.gz
gentoo-2-38448c748e2a96a58e8a3a73147944754bbcefb4.tar.bz2
gentoo-2-38448c748e2a96a58e8a3a73147944754bbcefb4.zip
fix bug #458902
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/odamex/ChangeLog6
-rw-r--r--games-engines/odamex/files/odamex-0.6.2-libagar.patch15
-rw-r--r--games-engines/odamex/odamex-0.6.2.ebuild7
3 files changed, 25 insertions, 3 deletions
diff --git a/games-engines/odamex/ChangeLog b/games-engines/odamex/ChangeLog
index f52d603745ea..d0f6d8c20402 100644
--- a/games-engines/odamex/ChangeLog
+++ b/games-engines/odamex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-engines/odamex
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/ChangeLog,v 1.6 2013/02/16 22:38:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/ChangeLog,v 1.7 2013/02/23 20:23:15 hasufell Exp $
+
+ 23 Feb 2013; Julian Ospald <hasufell@gentoo.org> odamex-0.6.2.ebuild,
+ +files/odamex-0.6.2-libagar.patch:
+ fix bug #458902
16 Feb 2013; Agostino Sarubbo <ago@gentoo.org> odamex-0.6.2.ebuild:
Stable for x86, wrt bug #457894
diff --git a/games-engines/odamex/files/odamex-0.6.2-libagar.patch b/games-engines/odamex/files/odamex-0.6.2-libagar.patch
new file mode 100644
index 000000000000..5f367aff1d6e
--- /dev/null
+++ b/games-engines/odamex/files/odamex-0.6.2-libagar.patch
@@ -0,0 +1,15 @@
+http://odamex.net/svn/revision.php?rev=3691
+
+Index: ag-odalaunch/src/main.cpp
+===================================================================
+--- ag-odalaunch/src/main.cpp (revision 3668)
++++ ag-odalaunch/src/main.cpp (working copy)
+@@ -52,7 +52,7 @@
+ {
+ AG_Window *win;
+
+- if((win = AG_GuiDebugger(agWindowFocused)) != NULL)
++ if((win = (AG_Window*)AG_GuiDebugger(agWindowFocused)) != NULL)
+ {
+ AG_WindowShow(win);
+ }
diff --git a/games-engines/odamex/odamex-0.6.2.ebuild b/games-engines/odamex/odamex-0.6.2.ebuild
index 6cb7a5312ad4..b746f3d7a9f9 100644
--- a/games-engines/odamex/odamex-0.6.2.ebuild
+++ b/games-engines/odamex/odamex-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/odamex-0.6.2.ebuild,v 1.3 2013/02/16 22:38:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/odamex/odamex-0.6.2.ebuild,v 1.4 2013/02/23 20:23:15 hasufell Exp $
EAPI=5
WX_GTK_VER="2.8"
@@ -28,7 +28,10 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-libagar.patch
+
+ epatch_user
}
src_configure() {