summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-20 10:41:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-20 10:41:01 +0000
commit5c8f20e2cfc76aef676e1d78043e04027a1f6292 (patch)
tree73b5ef7798098f8fc7f20d75eec2453bc212ab1c /games-emulation
parentalpha/arm/ia64/s390/sh/x86 stable wrt #253155 (diff)
downloadgentoo-2-5c8f20e2cfc76aef676e1d78043e04027a1f6292.tar.gz
gentoo-2-5c8f20e2cfc76aef676e1d78043e04027a1f6292.tar.bz2
gentoo-2-5c8f20e2cfc76aef676e1d78043e04027a1f6292.zip
Fix gcc-4.3 bug #251128
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r7 x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-riceplugin/ChangeLog9
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-5.1.0-gcc43.patch21
-rw-r--r--games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild8
3 files changed, 33 insertions, 5 deletions
diff --git a/games-emulation/mupen64-riceplugin/ChangeLog b/games-emulation/mupen64-riceplugin/ChangeLog
index f01e8c59e9c5..21940e80ead9 100644
--- a/games-emulation/mupen64-riceplugin/ChangeLog
+++ b/games-emulation/mupen64-riceplugin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/mupen64-riceplugin
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.14 2006/06/01 18:51:02 tupone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.15 2009/01/20 10:41:01 tupone Exp $
+
+ 20 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/mupen64-riceplugin-5.1.0-gcc43.patch,
+ mupen64-riceplugin-5.1.0.ebuild:
+ Fix gcc-4.3 bug #251128 by flameeyes@gentoo.org
01 Jun 2006; <Tupone@gentoo.org> mupen64-riceplugin-5.1.0.ebuild:
Fix for gcc-4.1 not compiling without -msse, bug #132051 by me
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-5.1.0-gcc43.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-5.1.0-gcc43.patch
new file mode 100644
index 000000000000..6a66245fca4f
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-5.1.0-gcc43.patch
@@ -0,0 +1,21 @@
+--- DLParser.h.old 2009-01-20 11:33:53.000000000 +0100
++++ DLParser.h 2009-01-20 11:34:07.000000000 +0100
+@@ -21,6 +21,7 @@
+ #ifndef __DAEDALUS_RDP_GFX_H__
+ #define __DAEDALUS_RDP_GFX_H__
+
++#include <cstring>
+ #include "ultra_sptask.h"
+ //#include "Debugger.h"
+
+--- ROM.h.old 2009-01-20 11:34:41.000000000 +0100
++++ ROM.h 2009-01-20 11:34:56.000000000 +0100
+@@ -21,6 +21,7 @@
+ #ifndef __DAEDALUS_ROM_H__
+ #define __DAEDALUS_ROM_H__
+
++#include <climits>
+ #include "ultra_types.h"
+ #include "IniFile.h"
+
+
diff --git a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
index 284fbdceeb42..e44396393a21 100644
--- a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
+++ b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.11 2007/04/06 05:46:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.12 2009/01/20 10:41:01 tupone Exp $
inherit toolchain-funcs eutils flag-o-matic games
@@ -26,11 +26,13 @@ S=${WORKDIR}/riceplugin
src_unpack() {
unpack ${A}
cd "${S}"
+ edos2unix DLParser.h ROM.h
epatch \
"${FILESDIR}"/${PN}-makefile.patch \
"${FILESDIR}"/${PN}-gtk2.patch \
"${FILESDIR}"/${PN}-compile.patch \
- "${FILESDIR}"/${PN}-gcc4.patch
+ "${FILESDIR}"/${PN}-gcc4.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
}
src_compile() {