summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 07:28:10 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 07:28:10 +0000
commitea5c71565d851c24050eb8a2c6e27f0855a7f56a (patch)
treedc3c36a7ec47c6954a7198e1626b5f0d39332ff0 /games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild
parentrename version (diff)
downloadgentoo-2-ea5c71565d851c24050eb8a2c6e27f0855a7f56a.tar.gz
gentoo-2-ea5c71565d851c24050eb8a2c6e27f0855a7f56a.tar.bz2
gentoo-2-ea5c71565d851c24050eb8a2c6e27f0855a7f56a.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild')
-rw-r--r--games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild
new file mode 100644
index 000000000000..c5ee4ccc531a
--- /dev/null
+++ b/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-spu2null/ps2emu-spu2null-0.4.ebuild,v 1.1 2005/08/07 07:28:10 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 NULL Sound plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.8release/SPU2null${PV//.}.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unrar"
+
+S=${WORKDIR}/SPU2null${PV//.}
+
+src_unpack() {
+ unrar x -idq "${DISTDIR}"/${A}
+ cd "${S}"
+ sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' Src/Makefile || die
+}
+
+src_compile() {
+ cd Src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+ newexe Src/libSPU2null.so libSPU2null-${PV//.}.so || die
+ prepgamesdirs
+}